You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@impala.apache.org by "Marcel Kornacker (Code Review)" <ge...@cloudera.org> on 2016/03/07 22:41:55 UTC
[Impala-CR](cdh5-trunk) IMPALA-1772: Add additional date/time functions.
Marcel Kornacker has posted comments on this change.
Change subject: IMPALA-1772: Add additional date/time functions.
......................................................................
Patch Set 4:
(2 comments)
http://gerrit.cloudera.org:8080/#/c/2148/4/be/src/exprs/expr-test.cc
File be/src/exprs/expr-test.cc:
Line 3558: TestValue("millisecond(cast('2011-12-22 09:10:11.123456' as timestamp))", TYPE_INT, 123);
long line
http://gerrit.cloudera.org:8080/#/c/2148/4/be/src/exprs/timestamp-functions.cc
File be/src/exprs/timestamp-functions.cc:
Line 353: const time_duration& time = ts_value.time();
use explicit namespace here (boost::posix_time::time_duration), that's easier to follow and isn't more verbose (it's not like you have this all over the place).
remove using.
--
To view, visit http://gerrit.cloudera.org:8080/2148
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: I3bafc6aaf80d1d8d2a634d120d9dbdb954d3f0c4
Gerrit-PatchSet: 4
Gerrit-Project: Impala
Gerrit-Branch: cdh5-trunk
Gerrit-Owner: Thomas Tauber-Marshall <tm...@cloudera.com>
Gerrit-Reviewer: Casey Ching <ca...@cloudera.com>
Gerrit-Reviewer: Marcel Kornacker <ma...@cloudera.com>
Gerrit-Reviewer: Matthew Jacobs <mj...@cloudera.com>
Gerrit-Reviewer: Thomas Tauber-Marshall <tm...@cloudera.com>
Gerrit-HasComments: Yes