You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Chen Liang (JIRA)" <ji...@apache.org> on 2016/09/26 17:34:20 UTC

[jira] [Updated] (HADOOP-13658) Replace config key literal string with the name of the keys in o.a.h.i.f.t.Compression

     [ https://issues.apache.org/jira/browse/HADOOP-13658?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Chen Liang updated HADOOP-13658:
--------------------------------
    Description: 
There are several places in o.a.h.i.f.t.Compression where the config keys are used by the literal strings instead of their names as in configuration key classes. For example

{code}
conf.setInt("io.compression.codec.lzo.buffersize", 64 * 1024);
{code}

should be

{code}
conf.setInt(CommonConfigurationKeys.IO_COMPRESSION_CODEC_LZO_BUFFERSIZE_KEY, 64 * 1024);
{code}

instead

  was:
There are several places in o.a.h.i.f.t.Compression where the config keys are used by the literal strings instead of their names as in configuration key classes. For example

{code}
conf.setInt("io.compression.codec.lzo.buffersize", 64 * 1024);
{code}

should be

{code}
conf.setInt(      CommonConfigurationKeys.IO_COMPRESSION_CODEC_LZO_BUFFERSIZE_KEY, 64 * 1024);
{code}

instead


> Replace config key literal string with the name of the keys in o.a.h.i.f.t.Compression
> --------------------------------------------------------------------------------------
>
>                 Key: HADOOP-13658
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13658
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: conf
>            Reporter: Chen Liang
>            Assignee: Chen Liang
>            Priority: Minor
>
> There are several places in o.a.h.i.f.t.Compression where the config keys are used by the literal strings instead of their names as in configuration key classes. For example
> {code}
> conf.setInt("io.compression.codec.lzo.buffersize", 64 * 1024);
> {code}
> should be
> {code}
> conf.setInt(CommonConfigurationKeys.IO_COMPRESSION_CODEC_LZO_BUFFERSIZE_KEY, 64 * 1024);
> {code}
> instead



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org