You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@ofbiz.apache.org by "Jacopo Cappellato (JIRA)" <ji...@apache.org> on 2007/02/24 09:15:05 UTC
[jira] Commented: (OFBIZ-671) Remove HTML styling code from widgets
[ https://issues.apache.org/jira/browse/OFBIZ-671?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12475610 ]
Jacopo Cappellato commented on OFBIZ-671:
-----------------------------------------
Adrian,
I'm starting to review the formwidget.patch (thanks for your work!), I had actually a very cursory review for now, and here are my first comments:
1) would it be possible for you to pull out from the patch the three new attributes? I'm not saying that they are not worth of inclusion, but I'd like to discuss a bit more about them with others, and probably select better names for them; for example, "focus-widget" maybe should be named "focus-field-name"
2) please ignore this if you'll follow my suggestion in #1; I think that the lines:
if (this.containerId == null || formElement.hasAttribute("id")) {
this.containerId = formElement.getAttribute("container-id");
}
should be instead:
if (this.containerId == null || formElement.hasAttribute("id")) {
this.containerId = formElement.getAttribute("id");
}
3) here and there you used "\r\n" for newlines, instead you should use the appendWhitespace(...) method
4) are the spaces that you added here and there really necessary? For example:
- buffer.append("<td align=\"center\"");
+ buffer.append(" <td align=\"center\"");
5) why did you comment out many of the calls to the appendWhitespace(...)?
- this.appendWhitespace(buffer);
+ //this.appendWhitespace(buffer
Jacopo
> Remove HTML styling code from widgets
> -------------------------------------
>
> Key: OFBIZ-671
> URL: https://issues.apache.org/jira/browse/OFBIZ-671
> Project: OFBiz (The Open for Business Project)
> Issue Type: Sub-task
> Components: framework
> Reporter: Adrian Crum
> Priority: Minor
> Attachments: formwidget.patch, menuwidget.patch, menuwidget.patch, treewidget.patch
>
>
> Widgets have embedded styling code in them. Styling should be left to the css files. A CSS class should be created called "alert" or something similar, and that class should be used instead of the hard-coded color="red" found in the widgets.
> Files affected (as far as I can tell): htmlMenuRenderer.java and htmlFormRenderer.java.
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.