You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@wicket.apache.org by "Igor Vaynberg (JIRA)" <ji...@apache.org> on 2010/08/07 21:04:11 UTC

[jira] Updated: (WICKET-757) FormComponent.rawInput needs a better name

     [ https://issues.apache.org/jira/browse/WICKET-757?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Igor Vaynberg updated WICKET-757:
---------------------------------

    Fix Version/s: 1.5-M2
                       (was: 1.5-M1)

> FormComponent.rawInput needs a better name
> ------------------------------------------
>
>                 Key: WICKET-757
>                 URL: https://issues.apache.org/jira/browse/WICKET-757
>             Project: Wicket
>          Issue Type: Wish
>          Components: wicket
>    Affects Versions: 1.2.6
>            Reporter: Willis Blackburn
>            Priority: Minor
>             Fix For: 1.5-M2
>
>
> It took me a while looking through the code to figure out that the "raw" input isn't really the raw input.  The *real* raw input is what comes from the getInputAsArray method.  rawInput seems to be a kind of holding place for the form-submitted value that, if present, overrides the value in the model, so that the form can re-display the user's input even if it failed validation or conversion and therefore cannot be stored in the model.  It's really a tentative or proposed value.
> Also, some more comments about what exactly NO_RAW_VALUE indicates would be helpful.  It seems to indicate that the form-submitted value has been cleared and that getValue should return the value from the model.  If you change the "raw" input to something else, then maybe this can be called USE_MODEL_VALUE or something like that instead.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.