You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Akira Ajisaka (JIRA)" <ji...@apache.org> on 2016/08/22 08:03:20 UTC

[jira] [Commented] (HDFS-10783) The option '-maxSize' and '-step' fail in OfflineImageViewer

    [ https://issues.apache.org/jira/browse/HDFS-10783?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15430268#comment-15430268 ] 

Akira Ajisaka commented on HDFS-10783:
--------------------------------------

Thanks [~linyiqun] for the quick fix!
{code}
  public void testOfflineImageViewerForFailedOptions() throws Throwable {
{code}
This method name looks ambiguous to me. I'm thinking it can be interpreted as two different meanings
* Test for previously failed option (now succeeded)
* Test for options that have failed (now failing)

In this issue, "previously failed" is correct but it doesn't mean anything. This is because generally regression tests are for fixing "previously failed" something. Would you make the name more straightforward? (ex. testOfflineImageViewerMaxSizeAndStepOptions)

> The option '-maxSize' and '-step' fail in OfflineImageViewer
> ------------------------------------------------------------
>
>                 Key: HDFS-10783
>                 URL: https://issues.apache.org/jira/browse/HDFS-10783
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: tools
>            Reporter: Yiqun Lin
>            Assignee: Yiqun Lin
>         Attachments: HDFS-10783.001.patch
>
>
> Executing -step or -maxSize option in {{OfflineImageViewer}} will cause the following exception:
> {code}
> org.apache.commons.cli.UnrecognizedOptionException: Unrecognized option: -maxSize
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org