You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@shardingsphere.apache.org by du...@apache.org on 2023/03/31 01:21:50 UTC

[shardingsphere] branch master updated: Add utility class naming convention (#24916)

This is an automated email from the ASF dual-hosted git repository.

duanzhengqiang pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/shardingsphere.git


The following commit(s) were added to refs/heads/master by this push:
     new fd736280531 Add utility class naming convention (#24916)
fd736280531 is described below

commit fd7362805312814d1e965d98422bed4ae028e108
Author: yx9o <ya...@163.com>
AuthorDate: Fri Mar 31 09:21:33 2023 +0800

    Add utility class naming convention (#24916)
---
 docs/community/content/involved/conduct/code.cn.md | 1 +
 docs/community/content/involved/conduct/code.en.md | 1 +
 2 files changed, 2 insertions(+)

diff --git a/docs/community/content/involved/conduct/code.cn.md b/docs/community/content/involved/conduct/code.cn.md
index f1c8df5ef66..be40837813a 100644
--- a/docs/community/content/involved/conduct/code.cn.md
+++ b/docs/community/content/involved/conduct/code.cn.md
@@ -63,6 +63,7 @@ chapter = true
  - 条件表达式中,优先使用正向语义,以便于理解代码逻辑。例如:`if (null == param) {} else {}`。
  - 使用具体的 `@SuppressWarnings("xxx")` 代替 `@SuppressWarnings("all")`。
  - 热点方法内应避免使用 Java Stream,除非该场景下使用 Stream 的性能优于普通循环。
+ - 工具类名称命名为 `xxUtils`。
 
 ## 单元测试规范
 
diff --git a/docs/community/content/involved/conduct/code.en.md b/docs/community/content/involved/conduct/code.en.md
index b6311d542a9..6575df039a3 100644
--- a/docs/community/content/involved/conduct/code.en.md
+++ b/docs/community/content/involved/conduct/code.en.md
@@ -60,6 +60,7 @@ The following code of conduct is based on full compliance with [ASF CODE OF COND
  - Use forward semantics in priority for better understanding code logic in conditional expressions. For example: `if (null == param) {} else {}`.
  - Use concentrate `@SuppressWarnings("xxx")` instead of `@SuppressWarnings("all")`.
  - Avoid using Java Stream in hot methods, unless the performance of using Stream is better than using loop in that situation.
+ - Utility class should be named in the form of `xxUtils`.
 
 ## Contributor Covenant Unit Test of Conduct