You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@storm.apache.org by "darion yaphets (JIRA)" <ji...@apache.org> on 2015/12/08 11:52:10 UTC

[jira] [Created] (STORM-1379) Removed Redundant Structure

darion yaphets created STORM-1379:
-------------------------------------

             Summary: Removed Redundant Structure
                 Key: STORM-1379
                 URL: https://issues.apache.org/jira/browse/STORM-1379
             Project: Apache Storm
          Issue Type: Improvement
          Components: storm-kafka
    Affects Versions: 0.10.0, 0.9.4, 0.9.5, 0.9.6
         Environment: CentOS 6  JDK1.7.0_75
            Reporter: darion yaphets
            Priority: Minor


Storm KafkaSpout have a static class MessageAndRealOffset which is same with Kafka API 's  kafka.message.MessageAndOffset . So I hava remove MessageAndRealOffset and replace with MessageAndOffset :)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)