You are viewing a plain text version of this content. The canonical link for it is here.
Posted to user@ant.apache.org by David Smiley <ds...@mitre.org> on 2004/11/09 21:50:07 UTC

Re: "available" shouldn't actually load the class; just see if it's resolvable

Peter Reilly wrote:
> David Smiley wrote:
> 
>> Does anyone want to offer their opinion?  It should be an easy change 
>> and I think it would be very unlikely if this broke any existing builds.
> 
> 
> It will break some builds.
> Using the current method, the script knows that the class is present and 
> useable, and so it can be used later in the build.
> Peter
> 

I believe the primary use of "available" is to conditionally compile 
code against.  The class's follow-on dependancies don't need to be 
present for this common use-case.  My suggestion here is only a problem 
if (a) you really do want to load the class because you need to execute 
code spawned from ant, and (b) the follow-on dependancies if any are not 
available.

I'd also like to recommend that ant explain what follow-on class is 
preventing "available" from succeeding without having to enable ant's 
debug mode.

Dominique wrote:
> I think it's a reasonable request, but to keep the former behavior
> as-is, I'd simply add an initialize="true|false" attribute, to mirror's
> Java's Class#forName overload. The attribute would default to true, and
> you'd be able to set it explicitly to false. --DD

I suggest the name "load" instead since that is the java vernacular for 
what's happening.

I also suggest that the next snapshot implementing this have it default 
to "false" and we'll get a feel for wether this is a problem at that time.

~ David Smiley
   MITRE


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Re: "available" shouldn't actually load the class; just see if it's resolvable

Posted by Conor MacNeill <co...@cortexebusiness.com.au>.
David Smiley wrote:
> 
> I suggest the name "load" instead since that is the java vernacular for 
> what's happening.
> 
> I also suggest that the next snapshot implementing this have it default 
> to "false" and we'll get a feel for wether this is a problem at that time.
> 

Unfortunately that would not be backward compatible. If you want new 
behaviour, it needs to be explicitly enabled, IMHO.

Conor

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org