You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@apr.apache.org by "William A. Rowe, Jr." <wr...@rowe-clan.net> on 2002/06/07 20:00:03 UTC

Deprecating functions

I just got bit by apr_parent_get_pool (bad, bad name).

So I've hacked up a example patch for apr_allocator_max_free_set.

First, adding -D APR_STRICT, coders can test that they don't use
deprecated symbols when building their code against apr headers.

Second, if the user defines APR_FAST_COMPAT, they get a much
more optimal code path (either an inline thunk or a simple #define
translation when possible.)  But this code will NOT be backwards
compatible to an older libapr dynamic library.

If the user fails to define APR_FAST_COMPAT, they will link to
a backwards compatible symbol that will bind to any older APR
library with that original symbol, or the current library which will
is a light wrapper around the new function.

Thoughts before I whack lots of functions, and reintroduce some
symbols that should not have been eliminated?

All these symbols will be removed in APR 1.0.0, if I understand
Greg's schema.