You are viewing a plain text version of this content. The canonical link for it is here.
Posted to derby-dev@db.apache.org by "Knut Anders Hatlen (JIRA)" <ji...@apache.org> on 2013/04/10 17:12:16 UTC

[jira] [Resolved] (DERBY-6162) Simplify privileged actions in NetworkServerControlApiTest

     [ https://issues.apache.org/jira/browse/DERBY-6162?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Knut Anders Hatlen resolved DERBY-6162.
---------------------------------------

          Resolution: Fixed
       Fix Version/s: 10.11.0.0
    Issue & fix info:   (was: Patch Available)
    
> Simplify privileged actions in NetworkServerControlApiTest
> ----------------------------------------------------------
>
>                 Key: DERBY-6162
>                 URL: https://issues.apache.org/jira/browse/DERBY-6162
>             Project: Derby
>          Issue Type: Improvement
>          Components: Test
>    Affects Versions: 10.11.0.0
>            Reporter: Knut Anders Hatlen
>            Assignee: Knut Anders Hatlen
>            Priority: Trivial
>             Fix For: 10.11.0.0
>
>         Attachments: d6162-1a.diff
>
>
> Noticed two privileged blocks in NetworkServerControlApiTest that could be simplified:
> - privInetAddressGetByName() tests whether the PrivilegedActionException wraps a SecurityException. PAE only wraps checked exceptions, and SecurityException is an unchecked exception, so that can never happen.
> - fileExists() could use the existing helper method PrivilegedFileOpsForTests.exists() and remove its privileged block.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira