You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Brandon Atkinson (JIRA)" <ji...@apache.org> on 2009/11/30 16:51:20 UTC

[jira] Created: (DBUTILS-65) Duplicate code introduced during Java 1.5 branch merge

Duplicate code introduced during Java 1.5 branch merge
------------------------------------------------------

                 Key: DBUTILS-65
                 URL: https://issues.apache.org/jira/browse/DBUTILS-65
             Project: Commons DbUtils
          Issue Type: Bug
    Affects Versions: 1.3
            Reporter: Brandon Atkinson


The merge of Java 1.5 code into the main line introduced duplicate code in at least one place (BeanProcessor.java).

My guess is that some patches were applied to both the trunk and 1.5 branch during development.  When the merge occurred, the patches contents were duplicated.

I haven't analyzed all files for duplicate code, but I will be attaching a patch for the BeanProcessor class.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (DBUTILS-65) Duplicate code introduced during Java 1.5 branch merge

Posted by "Brandon Atkinson (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/DBUTILS-65?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Brandon Atkinson updated DBUTILS-65:
------------------------------------

    Attachment: BeanProcessor-patch.diff

Remove duplicated code in BeanProcessor#processColumn 

> Duplicate code introduced during Java 1.5 branch merge
> ------------------------------------------------------
>
>                 Key: DBUTILS-65
>                 URL: https://issues.apache.org/jira/browse/DBUTILS-65
>             Project: Commons DbUtils
>          Issue Type: Bug
>    Affects Versions: 1.3
>            Reporter: Brandon Atkinson
>         Attachments: BeanProcessor-patch.diff
>
>
> The merge of Java 1.5 code into the main line introduced duplicate code in at least one place (BeanProcessor.java).
> My guess is that some patches were applied to both the trunk and 1.5 branch during development.  When the merge occurred, the patches contents were duplicated.
> I haven't analyzed all files for duplicate code, but I will be attaching a patch for the BeanProcessor class.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.