You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@httpd.apache.org by Eric Covener <co...@gmail.com> on 2015/06/24 22:03:46 UTC

Re: svn commit: r1684900 - in /httpd/httpd/trunk: CHANGES modules/filters/mod_substitute.c

For 2.4, do we need some kind of global property for people who were
already working around the merge?

On Thu, Jun 11, 2015 at 10:22 AM,  <ni...@apache.org> wrote:
> Author: niq
> Date: Thu Jun 11 14:22:21 2015
> New Revision: 1684900
>
> URL: http://svn.apache.org/r1684900
> Log:
> mod_substitute: Fix configuraton merge order.
> PR 57641 [Marc.Stern]
>
> Modified:
>     httpd/httpd/trunk/CHANGES
>     httpd/httpd/trunk/modules/filters/mod_substitute.c
>
> Modified: httpd/httpd/trunk/CHANGES
> URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/CHANGES?rev=1684900&r1=1684899&r2=1684900&view=diff
> ==============================================================================
> --- httpd/httpd/trunk/CHANGES [utf-8] (original)
> +++ httpd/httpd/trunk/CHANGES [utf-8] Thu Jun 11 14:22:21 2015
> @@ -1,6 +1,9 @@
>                                                           -*- coding: utf-8 -*-
>  Changes with Apache 2.5.0
>
> +  *) mod_substitute: Fix configuraton merge order.
> +     PR 57641 [<Marc.Stern approach.be>]
> +
>    *) core: Limit accepted chunk-size to 2^63-1 and be strict about chunk-ext
>       authorized characters.  [Yann Ylavic]
>
>
> Modified: httpd/httpd/trunk/modules/filters/mod_substitute.c
> URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/modules/filters/mod_substitute.c?rev=1684900&r1=1684899&r2=1684900&view=diff
> ==============================================================================
> --- httpd/httpd/trunk/modules/filters/mod_substitute.c (original)
> +++ httpd/httpd/trunk/modules/filters/mod_substitute.c Thu Jun 11 14:22:21 2015
> @@ -84,8 +84,8 @@ static void *merge_substitute_dcfg(apr_p
>      subst_dir_conf *base = (subst_dir_conf *) basev;
>      subst_dir_conf *over = (subst_dir_conf *) overv;
>
> -    a->patterns = apr_array_append(p, over->patterns,
> -                                                  base->patterns);
> +    a->patterns = apr_array_append(p, base->patterns,
> +                                                  over->patterns);
>      a->max_line_length = over->max_line_length_set ?
>                           over->max_line_length : base->max_line_length;
>      a->max_line_length_set = over->max_line_length_set ?
>
>



-- 
Eric Covener
covener@gmail.com

Re: svn commit: r1684900 - in /httpd/httpd/trunk: CHANGES modules/filters/mod_substitute.c

Posted by Yann Ylavic <yl...@gmail.com>.
On Wed, Jun 24, 2015 at 11:09 PM, Eric Covener <co...@gmail.com> wrote:
> SubstituteInheritBefore

I chose this one, was the easiest for me to write its doc.
Committed in r1687539.

Re: svn commit: r1684900 - in /httpd/httpd/trunk: CHANGES modules/filters/mod_substitute.c

Posted by Eric Covener <co...@gmail.com>.
On Wed, Jun 24, 2015 at 5:04 PM, Yann Ylavic <yl...@gmail.com> wrote:
> I think we need that yes (backport probably proposed the too early).
> Would something like SubstituteBaseFirst (server scope), on by default
> on 2.4.x and off on trunk, be OK?

I'm not sure about the default, I think changed behavior might be okay
in this case as long as they can opt out if they need to.  Could be
swayed though.

> Maybe a better name?

Can't say better -- but some other option:

SubstituteMergeCompat
SubstituteInheritCompat
SubstituteInheritBefore

Re: svn commit: r1684900 - in /httpd/httpd/trunk: CHANGES modules/filters/mod_substitute.c

Posted by Yann Ylavic <yl...@gmail.com>.
I think we need that yes (backport probably proposed the too early).
Would something like SubstituteBaseFirst (server scope), on by default
on 2.4.x and off on trunk, be OK?
Maybe a better name?

On Wed, Jun 24, 2015 at 10:03 PM, Eric Covener <co...@gmail.com> wrote:
> For 2.4, do we need some kind of global property for people who were
> already working around the merge?
>
> On Thu, Jun 11, 2015 at 10:22 AM,  <ni...@apache.org> wrote:
>> Author: niq
>> Date: Thu Jun 11 14:22:21 2015
>> New Revision: 1684900
>>
>> URL: http://svn.apache.org/r1684900
>> Log:
>> mod_substitute: Fix configuraton merge order.
>> PR 57641 [Marc.Stern]
>>
>> Modified:
>>     httpd/httpd/trunk/CHANGES
>>     httpd/httpd/trunk/modules/filters/mod_substitute.c
>>
>> Modified: httpd/httpd/trunk/CHANGES
>> URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/CHANGES?rev=1684900&r1=1684899&r2=1684900&view=diff
>> ==============================================================================
>> --- httpd/httpd/trunk/CHANGES [utf-8] (original)
>> +++ httpd/httpd/trunk/CHANGES [utf-8] Thu Jun 11 14:22:21 2015
>> @@ -1,6 +1,9 @@
>>                                                           -*- coding: utf-8 -*-
>>  Changes with Apache 2.5.0
>>
>> +  *) mod_substitute: Fix configuraton merge order.
>> +     PR 57641 [<Marc.Stern approach.be>]
>> +
>>    *) core: Limit accepted chunk-size to 2^63-1 and be strict about chunk-ext
>>       authorized characters.  [Yann Ylavic]
>>
>>
>> Modified: httpd/httpd/trunk/modules/filters/mod_substitute.c
>> URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/modules/filters/mod_substitute.c?rev=1684900&r1=1684899&r2=1684900&view=diff
>> ==============================================================================
>> --- httpd/httpd/trunk/modules/filters/mod_substitute.c (original)
>> +++ httpd/httpd/trunk/modules/filters/mod_substitute.c Thu Jun 11 14:22:21 2015
>> @@ -84,8 +84,8 @@ static void *merge_substitute_dcfg(apr_p
>>      subst_dir_conf *base = (subst_dir_conf *) basev;
>>      subst_dir_conf *over = (subst_dir_conf *) overv;
>>
>> -    a->patterns = apr_array_append(p, over->patterns,
>> -                                                  base->patterns);
>> +    a->patterns = apr_array_append(p, base->patterns,
>> +                                                  over->patterns);
>>      a->max_line_length = over->max_line_length_set ?
>>                           over->max_line_length : base->max_line_length;
>>      a->max_line_length_set = over->max_line_length_set ?
>>
>>
>
>
>
> --
> Eric Covener
> covener@gmail.com

Re: svn commit: r1684900 - in /httpd/httpd/trunk: CHANGES modules/filters/mod_substitute.c

Posted by Nick Kew <ni...@apache.org>.
On Wed, 2015-06-24 at 16:03 -0400, Eric Covener wrote:
> For 2.4, do we need some kind of global property for people who were
> already working around the merge?

My commit was to trunk (after someone prodded us on-list).
For 2.4 we should not change existing behaviour. At least,
not as a default.

New directive as per Yann's suggestion?  Maybe, but perhaps OTT.
If so, it would be good to make it 2.4-only and keep trunk pure.
And add it to upgrade notes!

-- 
Nick Kew