You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@pig.apache.org by "Rohini Palaniswamy (JIRA)" <ji...@apache.org> on 2017/10/26 17:09:00 UTC

[jira] [Commented] (PIG-5201) Null handling on FLATTEN

    [ https://issues.apache.org/jira/browse/PIG-5201?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16220800#comment-16220800 ] 

Rohini Palaniswamy commented on PIG-5201:
-----------------------------------------

Comments:
1) Can we rename flattenNumFieldsForNull to flattenNumFields? Naming it based on the purpose will make it odd when it is reused for something else.
2) POForeach clone should copy flattenNumFieldsForNull
3) isToBeFlattenedArray[ i ] is checked in 3 if statements. Can we create a outer block with that condition to simplify?
4) TestFlatten.java - license is modified. Unintended change?
6)  :)
{code}
System.err.println("KOJIKOJI");
152	        for( Tuple t : actualResults ) {
153	            System.err.println(t);
154	        }

        System.err.println("KOJIKOJI2");
167	        for( Tuple t : expectedResults ) {
168	            System.err.println(t);
169	        }
170	
{code}

7) testFlattenOnNullBagWithColumnPrune is redundant. ColumPrune does not affect Flatten. Currently we don’t column prune nested data structures - tuple, bag (PIG-1324). We can remove this test or merge it into one of the other tests considering our unit test run time is already too high. 

> Null handling on FLATTEN
> ------------------------
>
>                 Key: PIG-5201
>                 URL: https://issues.apache.org/jira/browse/PIG-5201
>             Project: Pig
>          Issue Type: Bug
>            Reporter: Koji Noguchi
>            Assignee: Koji Noguchi
>            Priority: Minor
>             Fix For: 0.18.0
>
>         Attachments: pig-5201-v00-testonly.patch, pig-5201-v01.patch, pig-5201-v02.patch, pig-5201-v03.patch, pig-5201-v04.patch
>
>
> Sometimes, FLATTEN(null) or FLATTEN(bag-with-null) seem to produce incorrect results.
> Test code/script to follow.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)