You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@qpid.apache.org by "Lorenz Quack (JIRA)" <ji...@apache.org> on 2015/10/26 16:33:28 UTC

[jira] [Updated] (QPID-6812) SelectorThread needs cleanup/refactoring

     [ https://issues.apache.org/jira/browse/QPID-6812?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Lorenz Quack updated QPID-6812:
-------------------------------
    Description: 
The SelectorThread class needs some refactoring.
Which includes at least
* Rename to reflect its purpose
* It should not extend Thread but rather implement Runnable
* The API is to liberal. make more stuff private/package protected (e.g., SelectionTask)
* SelectionTask._wakeups should be renamed and should be AtomicBoolean
* The inner classes might need renaming as well
* The inner classes might need to move to their own classes
* The order in which work is readded to the workQueue in performSelect could be inverted
 {code}_workQueue.addAll(connections);
_workQueue.add(this);{code}

  was:
The SelectorThread class needs some refactoring.
Which includes at least
* Rename to reflect its purpose
* It should not extend Thread but rather implement Runnable
* The API is to liberal. make more stuff private/package protected (e.g., SelectionTask)
* SelectionTask._wakeups should be renamed and should be AtomicBoolean
* The inner classes might need renaming as well
* The inner classes might need to move to their own classes



> SelectorThread needs cleanup/refactoring
> ----------------------------------------
>
>                 Key: QPID-6812
>                 URL: https://issues.apache.org/jira/browse/QPID-6812
>             Project: Qpid
>          Issue Type: Improvement
>          Components: Java Broker
>            Reporter: Lorenz Quack
>
> The SelectorThread class needs some refactoring.
> Which includes at least
> * Rename to reflect its purpose
> * It should not extend Thread but rather implement Runnable
> * The API is to liberal. make more stuff private/package protected (e.g., SelectionTask)
> * SelectionTask._wakeups should be renamed and should be AtomicBoolean
> * The inner classes might need renaming as well
> * The inner classes might need to move to their own classes
> * The order in which work is readded to the workQueue in performSelect could be inverted
>  {code}_workQueue.addAll(connections);
> _workQueue.add(this);{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@qpid.apache.org
For additional commands, e-mail: dev-help@qpid.apache.org