You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by Joseph Wu <jo...@mesosphere.io> on 2016/01/05 18:32:54 UTC

Re: Review Request 41781: Logger Module: Add test for the rotating container logger module.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41781/
-----------------------------------------------------------

(Updated Jan. 5, 2016, 9:32 a.m.)


Review request for mesos, Benjamin Hindman and Artem Harutyunyan.


Changes
-------

Shorten summary.


Summary (updated)
-----------------

Logger Module: Add test for the rotating container logger module.


Bugs: MESOS-4136
    https://issues.apache.org/jira/browse/MESOS-4136


Repository: mesos


Description
-------

This test loads a non-default ContainerLogger module that rotates logs (i.e. renaming the head log file) and constrains total log size.


Diffs
-----

  src/tests/container_logger_tests.cpp c6b2e597517c74a55649287dc5ae5a3115f9a640 

Diff: https://reviews.apache.org/r/41781/diff/


Testing
-------

This test is run later in the review chain.


Thanks,

Joseph Wu


Re: Review Request 41781: Logger Module: Add test for the rotating container logger module.

Posted by Joseph Wu <jo...@mesosphere.io>.

> On Jan. 7, 2016, 4:12 p.m., Benjamin Hindman wrote:
> > src/tests/container_logger_tests.cpp, lines 28-30
> > <https://reviews.apache.org/r/41781/diff/2/?file=1181460#file1181460line28>
> >
> >     How come these aren't pulled out since they are three levels?

Looks like we're a bit inconsistent.  I'll fix this here and submit a separate set of patches to tweak this in other places.
https://reviews.apache.org/r/42082/
https://reviews.apache.org/r/42083/
https://reviews.apache.org/r/42084/


- Joseph


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41781/#review113369
-----------------------------------------------------------


On Jan. 8, 2016, 12:06 p.m., Joseph Wu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/41781/
> -----------------------------------------------------------
> 
> (Updated Jan. 8, 2016, 12:06 p.m.)
> 
> 
> Review request for mesos, Benjamin Hindman and Artem Harutyunyan.
> 
> 
> Bugs: MESOS-4136
>     https://issues.apache.org/jira/browse/MESOS-4136
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This test loads a non-default ContainerLogger module that rotates logs (i.e. renaming the head log file) and constrains total log size.
> 
> 
> Diffs
> -----
> 
>   src/tests/container_logger_tests.cpp c6b2e597517c74a55649287dc5ae5a3115f9a640 
> 
> Diff: https://reviews.apache.org/r/41781/diff/
> 
> 
> Testing
> -------
> 
> This test is run later in the review chain.
> 
> 
> Thanks,
> 
> Joseph Wu
> 
>


Re: Review Request 41781: Logger Module: Add test for the rotating container logger module.

Posted by Benjamin Hindman <be...@berkeley.edu>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41781/#review113369
-----------------------------------------------------------

Ship it!



src/tests/container_logger_tests.cpp (lines 28 - 30)
<https://reviews.apache.org/r/41781/#comment173947>

    How come these aren't pulled out since they are three levels?



src/tests/container_logger_tests.cpp (line 172)
<https://reviews.apache.org/r/41781/#comment173944>

    s/agent_flags/flags/



src/tests/container_logger_tests.cpp (line 184)
<https://reviews.apache.org/r/41781/#comment173945>

    s/agent/slave/
    
    I thought this is what we decided to do with the previous reviews too?



src/tests/container_logger_tests.cpp (line 241)
<https://reviews.apache.org/r/41781/#comment173946>

    s/sandboxPath/sandboxDirectory/
    
    Isn't that what we decided before? Or not?


- Benjamin Hindman


On Jan. 5, 2016, 5:32 p.m., Joseph Wu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/41781/
> -----------------------------------------------------------
> 
> (Updated Jan. 5, 2016, 5:32 p.m.)
> 
> 
> Review request for mesos, Benjamin Hindman and Artem Harutyunyan.
> 
> 
> Bugs: MESOS-4136
>     https://issues.apache.org/jira/browse/MESOS-4136
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This test loads a non-default ContainerLogger module that rotates logs (i.e. renaming the head log file) and constrains total log size.
> 
> 
> Diffs
> -----
> 
>   src/tests/container_logger_tests.cpp c6b2e597517c74a55649287dc5ae5a3115f9a640 
> 
> Diff: https://reviews.apache.org/r/41781/diff/
> 
> 
> Testing
> -------
> 
> This test is run later in the review chain.
> 
> 
> Thanks,
> 
> Joseph Wu
> 
>


Re: Review Request 41781: Logger Module: Add test for the rotating container logger module.

Posted by Joseph Wu <jo...@mesosphere.io>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41781/
-----------------------------------------------------------

(Updated Jan. 19, 2016, 7:41 p.m.)


Review request for mesos, Benjamin Hindman and Artem Harutyunyan.


Changes
-------

Rename from "rotate" to "logrotate".


Summary (updated)
-----------------

Logger Module: Add test for the rotating container logger module.


Bugs: MESOS-4136
    https://issues.apache.org/jira/browse/MESOS-4136


Repository: mesos


Description (updated)
-------

This test loads a non-default ContainerLogger module that rotates logs (i.e. renaming the head log file) and constrains total log size.


Diffs (updated)
-----

  src/tests/container_logger_tests.cpp c6b2e597517c74a55649287dc5ae5a3115f9a640 

Diff: https://reviews.apache.org/r/41781/diff/


Testing
-------

This test is run later in the review chain.


Thanks,

Joseph Wu


Re: Review Request 41781: Add test for behavior of the rotating container logger module.

Posted by Joseph Wu <jo...@mesosphere.io>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41781/
-----------------------------------------------------------

(Updated Jan. 15, 2016, 4:54 p.m.)


Review request for mesos, Benjamin Hindman and Artem Harutyunyan.


Changes
-------

* Add new test to `LOGROTATE_` test filter.
* Fix some flakiness (cleanup of subprocesses) in the test.
* Change expectations inside test to match the default behavior of `logrotate`.


Summary (updated)
-----------------

Add test for behavior of the rotating container logger module.


Bugs: MESOS-4136
    https://issues.apache.org/jira/browse/MESOS-4136


Repository: mesos


Description (updated)
-------

Add test for behavior of the rotating container logger module.


Diffs (updated)
-----

  src/tests/container_logger_tests.cpp c6b2e597517c74a55649287dc5ae5a3115f9a640 

Diff: https://reviews.apache.org/r/41781/diff/


Testing
-------

This test is run later in the review chain.


Thanks,

Joseph Wu


Re: Review Request 41781: Logger Module: Add test for the rotating container logger module.

Posted by Joseph Wu <jo...@mesosphere.io>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41781/
-----------------------------------------------------------

(Updated Jan. 15, 2016, 11:34 a.m.)


Review request for mesos, Benjamin Hindman and Artem Harutyunyan.


Changes
-------

Inserted a review behind this one.


Bugs: MESOS-4136
    https://issues.apache.org/jira/browse/MESOS-4136


Repository: mesos


Description
-------

This test loads a non-default ContainerLogger module that rotates logs (i.e. renaming the head log file) and constrains total log size.


Diffs
-----

  src/tests/container_logger_tests.cpp c6b2e597517c74a55649287dc5ae5a3115f9a640 

Diff: https://reviews.apache.org/r/41781/diff/


Testing
-------

This test is run later in the review chain.


Thanks,

Joseph Wu


Re: Review Request 41781: Logger Module: Add test for the rotating container logger module.

Posted by Joseph Wu <jo...@mesosphere.io>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41781/
-----------------------------------------------------------

(Updated Jan. 8, 2016, 12:06 p.m.)


Review request for mesos, Benjamin Hindman and Artem Harutyunyan.


Changes
-------

Fixed header order, some comments, and some variables names.


Bugs: MESOS-4136
    https://issues.apache.org/jira/browse/MESOS-4136


Repository: mesos


Description
-------

This test loads a non-default ContainerLogger module that rotates logs (i.e. renaming the head log file) and constrains total log size.


Diffs (updated)
-----

  src/tests/container_logger_tests.cpp c6b2e597517c74a55649287dc5ae5a3115f9a640 

Diff: https://reviews.apache.org/r/41781/diff/


Testing
-------

This test is run later in the review chain.


Thanks,

Joseph Wu