You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Guillaume Nodet (Jira)" <ji...@apache.org> on 2023/11/10 15:20:00 UTC

[jira] [Updated] (MNG-7914) Provide a single entry point for configuration

     [ https://issues.apache.org/jira/browse/MNG-7914?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Guillaume Nodet updated MNG-7914:
---------------------------------
    Description: 
Looking at MNG-7772, this should not require any code change, but it's all about configuration.

I propose to load / interpolate the following files:
 * {{${maven.home}/conf/maven.user.properties}}
 * {{${maven.home}/conf/maven.system.properties}}

Those files would be used to load additional user properties and system properties for Maven.  In addition to the simple interpolation mechanism, we should provide two enhancements using special keys {{{}$\{includes{}}}} and {{{}$\{optionals{}}}} which would be used to load additional referenced configuration files such as:

{{    ${optionals} = ${user.home}/.m2/maven.user.properties, ${session.rootDirectory}/.mvn/maven.user.properties}}

Being loaded early when Maven is loaded, those files could reference directories to load extensions from:

  {{{}maven.core.extensions.directories = ${session.rootDirectory}/.mvn/extensions.xml,{}}}{{{}${user.home}/.m2/extensions.xml,${maven.home}/extensions.xml{}}}

 

In various places, the maven code could be simplified and offer more configuration points at the same time.

  was:
Looking at MNG-7772, this should not require any code change, but it's all about configuration.

I propose to load / interpolate the following files:
 * {{${maven.home}/conf/maven.user.properties}}
 * {{${maven.home}/conf/maven.system.properties}}

Those files would be used to load additional user properties and system properties for Maven.  In addition to the simple interpolation mechanism, we should provide two enhancements using special keys {{${includes}}} and {{${optionals}}} which would be used to load additional referenced configuration files such as:

{{{}    ${optionals} = ${user.home}/.m2/maven.user.properties, ${session.rootDirectory}/.mvn/maven.user.properties{}}}{{{}{}}}{{{}{}}}

Being loaded early when Maven is loaded, those files could reference directories to load extensions from:

  {{{}maven.core.extensions.directories = {{{}${session.rootDirectory}/.mvn/extensions.xml,{}}}{{{}${user.home}/.m2/extensions.xml,${maven.home}/extensions.xml{}}}{}}}{{{}{}}}

 

In various places, the maven code could be simplified and offer more configuration points at the same time.


> Provide a single entry point for configuration
> ----------------------------------------------
>
>                 Key: MNG-7914
>                 URL: https://issues.apache.org/jira/browse/MNG-7914
>             Project: Maven
>          Issue Type: New Feature
>            Reporter: Guillaume Nodet
>            Priority: Major
>             Fix For: 4.0.x-candidate
>
>
> Looking at MNG-7772, this should not require any code change, but it's all about configuration.
> I propose to load / interpolate the following files:
>  * {{${maven.home}/conf/maven.user.properties}}
>  * {{${maven.home}/conf/maven.system.properties}}
> Those files would be used to load additional user properties and system properties for Maven.  In addition to the simple interpolation mechanism, we should provide two enhancements using special keys {{{}$\{includes{}}}} and {{{}$\{optionals{}}}} which would be used to load additional referenced configuration files such as:
> {{    ${optionals} = ${user.home}/.m2/maven.user.properties, ${session.rootDirectory}/.mvn/maven.user.properties}}
> Being loaded early when Maven is loaded, those files could reference directories to load extensions from:
>   {{{}maven.core.extensions.directories = ${session.rootDirectory}/.mvn/extensions.xml,{}}}{{{}${user.home}/.m2/extensions.xml,${maven.home}/extensions.xml{}}}
>  
> In various places, the maven code could be simplified and offer more configuration points at the same time.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)