You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Luc Maisonobe (JIRA)" <ji...@apache.org> on 2008/01/10 22:39:34 UTC

[jira] Issue Comment Edited: (MATH-173) One-way ANOVA

    [ https://issues.apache.org/jira/browse/MATH-173?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12557808#action_12557808 ] 

luc edited comment on MATH-173 at 1/10/08 1:38 PM:
-------------------------------------------------------------

Our current policy is to be able to compile it with jdk 1.3. I think this can be done with ant using properties ant.build.javac.source and ant.build.javac.target.

If you really want to associate a name for the error messages, then rather than relying on a map that both does the association and is a container for the double array, then I would prefer a collection of Category such as :
public interface Category {
  public double[] getData();
  public String getName();
}

with a default implementation that simply uses two attributes. I have used the name Category because Class is already used in Java, but this name could really be changed to something more suited.

This would separate the name/data association feature from the multiple category feature. I also think it is cleaner than using simple arrays of double since the abstraction level is higher. Of course, the interface could also be even improved with methods like getSampleSize() or things like that.

      was (Author: luc):
    Our current policy is to be able to compile it with jdk 1.3. I think this can be done with ant using properties ant.build.javac.source and ant.build.javac.target.

If you really want to associate a name for the error messages, then rather than relying on a map that both does the association and is a container for the double array, then I would prefer a collection of Category such as :
public interface Category {
  public double[] getDate();
  public String getName();
}

with a default implementation that simply uses two attributes. I have used the name Category because Class is already used in Java, but this name could really be changed to something more suited.

This would separate the name/data association feature from the multiple category feature. I also think it is cleaner than using simple arrays of double since the abstraction level is higher. Of course, the interface could also be even improved with methods like getSampleSize() or things like that.
  
> One-way ANOVA
> -------------
>
>                 Key: MATH-173
>                 URL: https://issues.apache.org/jira/browse/MATH-173
>             Project: Commons Math
>          Issue Type: New Feature
>    Affects Versions: Nightly Builds
>            Reporter: Bob MacCallum
>             Fix For: 1.2
>
>         Attachments: Anova.java, AnovaImpl.java, AnovaTest.java
>
>
> Here is some proposed code to add one-way ANOVA tests to commons-math
> I will be attaching
> src/test/org/apache/commons/math/stat/inference/AnovaTest.java
> src/java/org/apache/commons/math/stat/inference/Anova.java
> src/java/org/apache/commons/math/stat/inference/AnovaImpl.java
> I followed TTest as a style guide.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.