You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@jackrabbit.apache.org by "Thomas Mueller (JIRA)" <ji...@apache.org> on 2012/07/23 12:39:34 UTC

[jira] [Created] (JCR-3396) Simplify the code when possible

Thomas Mueller created JCR-3396:
-----------------------------------

             Summary: Simplify the code when possible
                 Key: JCR-3396
                 URL: https://issues.apache.org/jira/browse/JCR-3396
             Project: Jackrabbit Content Repository
          Issue Type: Improvement
            Reporter: Thomas Mueller
            Priority: Minor


Sometimes it's possible to simplify the code, for example:

- making methods static when possible, so a reader knows the method doesn't change the state of an object

- the "else" is unnecessary if the "if" block always returns

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Reopened] (JCR-3396) Simplify the code when possible

Posted by "Alex Parvulescu (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/JCR-3396?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Alex Parvulescu reopened JCR-3396:
----------------------------------

    
> Simplify the code when possible
> -------------------------------
>
>                 Key: JCR-3396
>                 URL: https://issues.apache.org/jira/browse/JCR-3396
>             Project: Jackrabbit Content Repository
>          Issue Type: Improvement
>            Reporter: Thomas Mueller
>            Priority: Minor
>
> Sometimes it's possible to simplify the code, for example:
> - making methods static when possible, so a reader knows the method doesn't change the state of an object
> - the "else" is unnecessary if the "if" block always returns

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (JCR-3396) Simplify the code when possible

Posted by "Thomas Mueller (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/JCR-3396?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13421248#comment-13421248 ] 

Thomas Mueller commented on JCR-3396:
-------------------------------------

Hi Julian

I agree, whatever is more readable is OK.

(I actually didn't want to create a bug for JCR but for OAK, so I will close this issue).
                
> Simplify the code when possible
> -------------------------------
>
>                 Key: JCR-3396
>                 URL: https://issues.apache.org/jira/browse/JCR-3396
>             Project: Jackrabbit Content Repository
>          Issue Type: Improvement
>            Reporter: Thomas Mueller
>            Priority: Minor
>
> Sometimes it's possible to simplify the code, for example:
> - making methods static when possible, so a reader knows the method doesn't change the state of an object
> - the "else" is unnecessary if the "if" block always returns

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Resolved] (JCR-3396) Simplify the code when possible

Posted by "Alex Parvulescu (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/JCR-3396?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Alex Parvulescu resolved JCR-3396.
----------------------------------

    Resolution: Not A Problem
    
> Simplify the code when possible
> -------------------------------
>
>                 Key: JCR-3396
>                 URL: https://issues.apache.org/jira/browse/JCR-3396
>             Project: Jackrabbit Content Repository
>          Issue Type: Improvement
>            Reporter: Thomas Mueller
>            Priority: Minor
>
> Sometimes it's possible to simplify the code, for example:
> - making methods static when possible, so a reader knows the method doesn't change the state of an object
> - the "else" is unnecessary if the "if" block always returns

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Resolved] (JCR-3396) Simplify the code when possible

Posted by "Thomas Mueller (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/JCR-3396?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Thomas Mueller resolved JCR-3396.
---------------------------------

    Resolution: Fixed
    
> Simplify the code when possible
> -------------------------------
>
>                 Key: JCR-3396
>                 URL: https://issues.apache.org/jira/browse/JCR-3396
>             Project: Jackrabbit Content Repository
>          Issue Type: Improvement
>            Reporter: Thomas Mueller
>            Priority: Minor
>
> Sometimes it's possible to simplify the code, for example:
> - making methods static when possible, so a reader knows the method doesn't change the state of an object
> - the "else" is unnecessary if the "if" block always returns

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Closed] (JCR-3396) Simplify the code when possible

Posted by "Alex Parvulescu (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/JCR-3396?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Alex Parvulescu closed JCR-3396.
--------------------------------

    
> Simplify the code when possible
> -------------------------------
>
>                 Key: JCR-3396
>                 URL: https://issues.apache.org/jira/browse/JCR-3396
>             Project: Jackrabbit Content Repository
>          Issue Type: Improvement
>            Reporter: Thomas Mueller
>            Priority: Minor
>
> Sometimes it's possible to simplify the code, for example:
> - making methods static when possible, so a reader knows the method doesn't change the state of an object
> - the "else" is unnecessary if the "if" block always returns

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (JCR-3396) Simplify the code when possible

Posted by "Julian Reschke (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/JCR-3396?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13420550#comment-13420550 ] 

Julian Reschke commented on JCR-3396:
-------------------------------------

- the "else" is unnecessary if the "if" block always returns 

I don't consider this an improvement; having return calls always at the same level has also advantages with respect to readability.
                
> Simplify the code when possible
> -------------------------------
>
>                 Key: JCR-3396
>                 URL: https://issues.apache.org/jira/browse/JCR-3396
>             Project: Jackrabbit Content Repository
>          Issue Type: Improvement
>            Reporter: Thomas Mueller
>            Priority: Minor
>
> Sometimes it's possible to simplify the code, for example:
> - making methods static when possible, so a reader knows the method doesn't change the state of an object
> - the "else" is unnecessary if the "if" block always returns

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira