You are viewing a plain text version of this content. The canonical link for it is here.
Posted to c-dev@axis.apache.org by John Hawkins <HA...@uk.ibm.com> on 2005/12/13 16:38:13 UTC

Confusing instructions

Hi Folks, I just came across these instructions in the user guides and I 
would like to know why we think it's necessary to change the name from 
axis_xercesc to axis_xmlparser ? It makes no sense as long as the user 
puts the right name in the conf file? If the name of the xerces lib is 
wrong then we should change that in our build as xerces is all we support 
today anyhow?

--------------------------------------------------------------------------------------------------------------------------------------------
Note: please rename libaxis_xercesc.so (the default parser library) to 
libaxis_xmlparser.so.
cp -f ${AXISCPP_DEPLOY}/lib/libaxis_xercesc.so 
${AXISCPP_DEPLOY}/lib/libaxis_xmlparser.so 

and make sure that you have specified the name of the parser lib correctly 
in your config file ${AXISCPP_DEPLOY}/etc/axiscpp.conf.
--------------------------------------------------------------------------------------------------------------------------------------------


cheers,
john.

Re: Confusing instructions

Posted by Samisa Abeysinghe <sa...@gmail.com>.
John Hawkins wrote:

>
> Hi Folks, I just came across these instructions in the user guides and 
> I would like to know why we think it's necessary to change the name 
> from axis_xercesc to axis_xmlparser ? It makes no sense as long as the 
> user puts the right name in the conf file? If the name of the xerces 
> lib is wrong then we should change that in our build as xerces is all 
> we support today anyhow?

I think this is something we _inherited_ from the Expat/Xerces era.
As we explicitly specify the parser lib in conf, I too agree, this is 
not required.

Samisa...

>
> *--------------------------------------------------------------------------------------------------------------------------------------------* 
>
> *Note:* please rename libaxis_xercesc.so (the default parser library) 
> to libaxis_xmlparser.so.
>
> */cp -f ${AXISCPP_DEPLOY}/lib/libaxis_xercesc.so 
> ${AXISCPP_DEPLOY}/lib/libaxis_xmlparser.so /*
>
> and make sure that you have specified the name of the parser lib 
> correctly in your config file ${AXISCPP_DEPLOY}/etc/axiscpp.conf.
> *--------------------------------------------------------------------------------------------------------------------------------------------* 
>
>
>
> cheers,
> john.
>