You are viewing a plain text version of this content. The canonical link for it is here.
Posted to torque-dev@db.apache.org by "Thomas Fox (JIRA)" <ji...@apache.org> on 2013/04/11 22:13:16 UTC

[jira] [Commented] (TORQUE-274) Change interface of source transformers

    [ https://issues.apache.org/jira/browse/TORQUE-274?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13629295#comment-13629295 ] 

Thomas Fox commented on TORQUE-274:
-----------------------------------

Migrating existing transformers is easy, the first argument of the transform method can be renamed and then a local variable of type SourceElement can be created which is filled by a cast of the new method wvraiable.
e.g. if the old method signature was
public SourceElement transform(SourceElement toTransform,ControllerState controllerState) ...

this can be changed as follows to adhere to the new API

public Object transform(Object modelRoot, ControllerState controllerState) ...
{
    SourceElement toTransform = (SourceElement) modelRoot;


                
> Change interface of source transformers
> ---------------------------------------
>
>                 Key: TORQUE-274
>                 URL: https://issues.apache.org/jira/browse/TORQUE-274
>             Project: Torque
>          Issue Type: Sub-task
>          Components: Generator
>    Affects Versions: 4.0
>            Reporter: Thomas Fox
>            Assignee: Thomas Fox
>
> If the source model can either be typed or untyped, the interface of the source transformers must be changed.
> Currently the interface requires the method
> SourceElement transform(SourceElement, ControllerState)
> which needs to be changed into
> Object transform(Object, ControllerState)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: torque-dev-unsubscribe@db.apache.org
For additional commands, e-mail: torque-dev-help@db.apache.org