You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mesos.apache.org by "Charlie Carson (JIRA)" <ji...@apache.org> on 2014/02/21 00:09:21 UTC
[jira] [Commented] (MESOS-1024) wire up observe end point to
Repairer class in master
[ https://issues.apache.org/jira/browse/MESOS-1024?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13907674#comment-13907674 ]
Charlie Carson commented on MESOS-1024:
---------------------------------------
looking the the code seems like I should create a MockRepairer and pass it into the new overload of the StartMaster method of MesosTest. That's in turn going to need to forward down to Cluster::Masters::start method. It looks like there is an overload of that start method which takes an allocatorProcess that I can follow as an example.
However, that's going to create 3 overloads with a lot of duplicated code. I'd rather have a single start method which takes Option<AllocatorProcess> & Option<Repairer> and either uses the object which is passed in or creates the standard one if None is passed in.
can one of BenH, VinodK, or BenM confirm this idea or point me in another direction?
thanks,
cc
> wire up observe end point to Repairer class in master
> -----------------------------------------------------
>
> Key: MESOS-1024
> URL: https://issues.apache.org/jira/browse/MESOS-1024
> Project: Mesos
> Issue Type: Sub-task
> Components: master
> Reporter: Charlie Carson
> Assignee: Charlie Carson
> Priority: Minor
>
> we want the observe HTTP endpoint to call into the Repairer component in master's observe method. for now the actual Repairer will continue to just log, but this will enable me to add a mock Repaier and verify that the end point passes the values over to master->repairer correctly.
--
This message was sent by Atlassian JIRA
(v6.1.5#6160)