You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@flink.apache.org by "Stephan Ewen (JIRA)" <ji...@apache.org> on 2016/08/09 22:04:20 UTC

[jira] [Created] (FLINK-4343) Implement new TaskManager

Stephan Ewen created FLINK-4343:
-----------------------------------

             Summary: Implement new TaskManager
                 Key: FLINK-4343
                 URL: https://issues.apache.org/jira/browse/FLINK-4343
             Project: Flink
          Issue Type: New Feature
          Components: Cluster Management
            Reporter: Stephan Ewen


This is the parent issue for the efforts to implement the {{TaskManager}} changes based on FLIP-6 (https://cwiki.apache.org/confluence/pages/viewpage.action?pageId=65147077)

Because of the breadth of changes, we should implement a new version of the {{TaskManager}} (let's call it {{TaskExecutor}}) rather than updating the current {{TaskManager}}. That will allow us to keep a working master branch.

At the point when the new cluster management is on par with the current implementation, we will drop the old {{TaskManager}} and rename the {{TaskExecutor}} to {{TaskManager}}.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)