You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@couchdb.apache.org by GitBox <gi...@apache.org> on 2018/09/21 12:47:38 UTC

[GitHub] kmoe commented on issue #1610: Set-Cookie Expires field date format

kmoe commented on issue #1610: Set-Cookie Expires field date format
URL: https://github.com/apache/couchdb/issues/1610#issuecomment-423519223
 
 
   Thanks @nickva, that looks like the correct format.
   
   I was curious at the phrase `Netscape's original proposal` in RFC2109, which implies that the date format specified there is not normative. RFC2109 also does not define another date format despite making normative statements such as
   
   ```
   HTTP/1.1 servers must send Expires: old-date (where old-date is a date long in the past)
   ```
   
   RFC2109 is obsoleted by [RFC2965](https://tools.ietf.org/html/rfc2965), which is in turn obsoleted by RFC6265. The former contains a reference to this undated Netscape proposal, which is no longer available at the cited URL but is hosted here:
   
   https://curl.haxx.se/rfc/cookie_spec.html
   
   ```
   The date string is formatted as:
   
   Wdy, DD-Mon-YYYY HH:MM:SS GMT
   This is based on RFC 822, RFC 850, RFC 1036, and RFC 1123, with the variations that the only legal time zone is GMT and the separators between the elements of the date must be dashes.
   ```
   
   You may want to update the [Cloudant docs](https://console.bluemix.net/docs/services/Cloudant/api/authentication.html#cookie-authentication), since the example response uses the wrong format for `Expires`.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services