You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@trafficserver.apache.org by "Susan Hinrichs (JIRA)" <ji...@apache.org> on 2015/01/05 23:01:35 UTC
[jira] [Comment Edited] (TS-3272) TS_SSL_SNI_HOOK continuously
called
[ https://issues.apache.org/jira/browse/TS-3272?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14265177#comment-14265177 ]
Susan Hinrichs edited comment on TS-3272 at 1/5/15 10:00 PM:
-------------------------------------------------------------
See the attached diff file. It should address the problem.
The sslServerHandShakeEvent() function was returning the generic EVENT_CONT instead of SSL_WAIT_FOR_HOOK.
This meant that the vc was being rescheduled, which caused the CPU spin that Lev obverserved.
In addition, we needed to augment the the SSLNetVConnection::reenable() method to so the readReschedule, so the netvc gets back in the queue when the thread finishes.
was (Author: shinrich):
The sslServerHandShakeEvent() function was returning the generic EVENT_CONT instead of SSL_WAIT_FOR_HOOK.
This meant that the vc was being rescheduled, which caused the CPU spin that Lev obverserved.
In addition, we needed to augment the the SSLNetVConnection::reenable() method to so the readReschedule, so the netvc gets back in the queue when the thread finishes.
> TS_SSL_SNI_HOOK continuously called
> ------------------------------------
>
> Key: TS-3272
> URL: https://issues.apache.org/jira/browse/TS-3272
> Project: Traffic Server
> Issue Type: Bug
> Components: Core
> Reporter: Lev Stipakov
> Assignee: Susan Hinrichs
> Fix For: 5.3.0
>
> Attachments: plugin.cc, ts-3272.diff
>
>
> I have created a simple plugin with TS_SSL_SNI_HOOK handler. Handler starts thread. Thread function has small sleep and after that calls TSVConnTunnel.
> The problem is that during sleep duration TS_SSL_SNI_HOOK handler gets continuously called.
> I would expect that TS_SSL_SNI_HOOK handler should be called just once.
> See plugin code in attach.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)