You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@hudi.apache.org by "Shao Feng Shi (Jira)" <ji...@apache.org> on 2020/03/31 05:40:00 UTC
[jira] [Created] (HUDI-751) Fix some coding issues reported by
FindBugs
Shao Feng Shi created HUDI-751:
----------------------------------
Summary: Fix some coding issues reported by FindBugs
Key: HUDI-751
URL: https://issues.apache.org/jira/browse/HUDI-751
Project: Apache Hudi (incubating)
Issue Type: Improvement
Reporter: Shao Feng Shi
When I go through the code base, the FindBugs plugin in my IDEA reports several issues, such as
1) Class implement "Serializable" doesn't have a "serialVersionUID";
2) Inner class wasn't declared as static;
3) Some static constant variables were not marked as final;
4) Some variable doesn't follow the naming convention, etc;
I fixed them quickly, and will raise a pull request.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)