You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@xalan.apache.org by bu...@apache.org on 2002/06/10 20:18:08 UTC

DO NOT REPLY [Bug 9753] New: - assert() is a keyword in JDK 1.4; update RedundentExprEliminator.assert() methodname

DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9753>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9753

assert() is a keyword in JDK 1.4; update RedundentExprEliminator.assert() methodname

           Summary: assert() is a keyword in JDK 1.4; update
                    RedundentExprEliminator.assert() methodname
           Product: XalanJ2
           Version: CurrentCVS
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: org.apache.xalan.templates
        AssignedTo: xalan-dev@xml.apache.org
        ReportedBy: curcuru@apache.org


See http://nagoya.apache.org/~rubys/gump/java14/xml-xalan2.html

assert() is a keyword and should be avoided; someone should simply 
change the name of this method to not conflict.  Seems this method is strictly 
within this class.

/tmp/gump/xml-
xalan/java/src/org/apache/xalan/templates/RedundentExprEliminator.java:1328: 
warning: as of release 1.4, assert is a keyword, and may not be used as an 
identifier     
  protected static void assert(boolean b, String msg)     
                        ^