You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@sqoop.apache.org by "Jarek Jarcec Cecho (JIRA)" <ji...@apache.org> on 2015/02/26 01:17:04 UTC
[jira] [Created] (SQOOP-2135) Sqoop2: Add direction to the
uniqueness that is verified for config names
Jarek Jarcec Cecho created SQOOP-2135:
-----------------------------------------
Summary: Sqoop2: Add direction to the uniqueness that is verified for config names
Key: SQOOP-2135
URL: https://issues.apache.org/jira/browse/SQOOP-2135
Project: Sqoop
Issue Type: Bug
Affects Versions: 1.99.5
Reporter: Jarek Jarcec Cecho
Fix For: 1.99.6
As part of From/To changes in 1.99.4, we've added [constraint in our repository|https://github.com/apache/sqoop/blob/sqoop2/repository/repository-derby/src/main/java/org/apache/sqoop/repository/derby/DerbySchemaUpgradeQuery.java#L489] that combination of config name, type and configurable needs to be unique (where type is either job or link).
As we are having different configuration objects for both FROM and TO directions and the direction specification is not part of the unique key, it means that one can't have the same input name for both direction. For example instead of:
{code}
class FromConfig {
String table;
}
class ToConfig {
String table;
}
{code}
We have to rename the variables to be unique:
{code}
class FromConfig {
String fromTable;
}
class ToConfig {
String toTable;
}
{code}
This is troublesome because:
* We're requesting uniqueness across different classes.
* We have to rename variables to a longer then necessary names.
* This limitation is not checked by java as it's verified in repository (e.g. no compilation errors, only runtime checks).
Hence I would suggest to allow that back :)
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)