You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Isabelle Giguere (JIRA)" <ji...@apache.org> on 2017/08/18 20:11:00 UTC
[jira] [Updated] (SOLR-11210) Confusing name for aliases in ZK
[ https://issues.apache.org/jira/browse/SOLR-11210?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Isabelle Giguere updated SOLR-11210:
------------------------------------
Description:
There's a confusing discrepancy between the aliases information stored in Zookeeper and the information returned by LISTALIASES.
http://localhost:8983/solr/admin/collections?action=CREATEALIAS&name=alias1&collections=collection0,collection1
http://localhost:8983/solr/admin/collections?action=LISTALIASES&wt=json
{"responseHeader":{"status":0,"QTime":0},"aliases":{"alias1":"collection0,collection1"}}
zkCLI -zkHost localhost:2181/solr -cmd getfile /aliases.json /aliases_ZK_output.json
{"collection":{
"alias1":"collection0,collection1"}}
The information stored in ZK looks like a NamedList named "collection", which doesn't make any sense. It should be named "aliases".
org.apache.solr.handler.admin.CollectionsHandler.CollectionOperation.LISTALIASES_OP adds the value of the ZK response to a NamedList called "aliases", so it doesn't show outside ZK.
was:
There's a confusing discrepancy between the aliases information stored in Zookeeper and the information returned by LISTALIASES.
http://localhost:8983/solr/admin/collections?action=CREATEALIAS&name=alias1&collections=collection0,collection1
http://localhost:8983/solr/admin/collections?action=LISTALIASES&wt=json
{"responseHeader":{"status":0,"QTime":0},"aliases":{"all":"alias1":"collection0,collection1"}}
zkCLI -zkHost localhost:2181/solr -cmd getfile /aliases.json /aliases_ZK_output.json
{"collection":{
"alias1":"collection0,collection1"}}
The information stored in ZK looks like a NamedList named "collection", which doesn't make any sense. It should be named "aliases".
org.apache.solr.handler.admin.CollectionsHandler.CollectionOperation.LISTALIASES_OP adds the value of the ZK response to a NamedList called "aliases", so it doesn't show outside ZK.
> Confusing name for aliases in ZK
> --------------------------------
>
> Key: SOLR-11210
> URL: https://issues.apache.org/jira/browse/SOLR-11210
> Project: Solr
> Issue Type: Bug
> Security Level: Public(Default Security Level. Issues are Public)
> Affects Versions: 6.6
> Reporter: Isabelle Giguere
> Priority: Minor
>
> There's a confusing discrepancy between the aliases information stored in Zookeeper and the information returned by LISTALIASES.
> http://localhost:8983/solr/admin/collections?action=CREATEALIAS&name=alias1&collections=collection0,collection1
> http://localhost:8983/solr/admin/collections?action=LISTALIASES&wt=json
> {"responseHeader":{"status":0,"QTime":0},"aliases":{"alias1":"collection0,collection1"}}
> zkCLI -zkHost localhost:2181/solr -cmd getfile /aliases.json /aliases_ZK_output.json
> {"collection":{
> "alias1":"collection0,collection1"}}
> The information stored in ZK looks like a NamedList named "collection", which doesn't make any sense. It should be named "aliases".
> org.apache.solr.handler.admin.CollectionsHandler.CollectionOperation.LISTALIASES_OP adds the value of the ZK response to a NamedList called "aliases", so it doesn't show outside ZK.
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org