You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-issues@hadoop.apache.org by "Nemo Chen (JIRA)" <ji...@apache.org> on 2016/08/11 14:15:20 UTC

[jira] [Created] (HADOOP-13484) Log refactoring: method invocation should be replaced by variable

Nemo Chen created HADOOP-13484:
----------------------------------

             Summary: Log refactoring: method invocation should be replaced by variable
                 Key: HADOOP-13484
                 URL: https://issues.apache.org/jira/browse/HADOOP-13484
             Project: Hadoop Common
          Issue Type: Bug
          Components: metrics
    Affects Versions: 2.7.2
            Reporter: Nemo Chen


Similar to the fix for HDFS-409. In file:

hadoop-rel-release-2.7.2/hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/metrics2/lib/MutableRates.java

In code block:
{code:borderStyle=solid}
String name = method.getName();
LOG.debug(name);
try { registry.newRate(name, name, false, true); }
catch (Exception e) {
        LOG.error("Error creating rate metrics for "+ method.getName(), e);
}
{code}
method.getName() is better to be replaced by variable name.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org