You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Jitendra Nath Pandey (JIRA)" <ji...@apache.org> on 2016/06/16 20:19:05 UTC
[jira] [Commented] (HDFS-10538) Remove AsyncDistributedFileSystem
[ https://issues.apache.org/jira/browse/HDFS-10538?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15334606#comment-15334606 ]
Jitendra Nath Pandey commented on HDFS-10538:
---------------------------------------------
[~xiaobingo], thanks for the patch. Please rename in the AsyncDistributedFileSystem in the test to "NonBlockingFileSystemTest", to make it explicit it is a test code.
> Remove AsyncDistributedFileSystem
> ---------------------------------
>
> Key: HDFS-10538
> URL: https://issues.apache.org/jira/browse/HDFS-10538
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Components: hdfs-client
> Reporter: Xiaobing Zhou
> Assignee: Xiaobing Zhou
> Attachments: HDFS-10538-HDFS-9924.000.patch
>
>
> Per discussion in HDFS-9924, this JIRA is to remove AsyncDistributedFileSystem to make it invisible by moving it to tests, however, the underlying implementation can be reused by any proposed async API. It makes much sense to keep it, making it easy and possible to try on various async API implementation down the road.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)
---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org