You are viewing a plain text version of this content. The canonical link for it is here.
Posted to java-dev@axis.apache.org by "David Blevins (JIRA)" <ax...@ws.apache.org> on 2005/06/17 02:07:46 UTC

[jira] Created: (AXIS-2061) Refactored RPCProvider

Refactored RPCProvider
----------------------

         Key: AXIS-2061
         URL: http://issues.apache.org/jira/browse/AXIS-2061
     Project: Apache Axis
        Type: Improvement
  Components: Basic Architecture  
    Versions: 1.2.1    
    Reporter: David Blevins
 Attachments: RPCProvider.java.diff

I've split up the RPCProvider's processMessage method so I could override it more easily.  I actually have my own implementation of processMessage and simply use the split out methods.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Re: [jira] Resolved: (AXIS-2061) Refactored RPCProvider

Posted by Davanum Srinivas <da...@gmail.com>.
done.

On 6/17/05, David Blevins <da...@visi.com> wrote:
> Thanks for gettting these refactors in!
> 
> Can anyone make these two methods protected real quick?  Waiting to check in some code that uses them.
> 
> private RPCElement getBody(SOAPEnvelope reqEnv, MessageContext msgContext) throws Exception {
> private OperationDesc getOperationDesc(MessageContext msgContext, RPCElement body) throws SAXException, AxisFault {
> 
> Thanks,
> David
> 
> On Fri, Jun 17, 2005 at 08:46:39PM +0200, Davanum Srinivas (JIRA) wrote:
> >      [ http://issues.apache.org/jira/browse/AXIS-2061?page=all ]
> >
> > Davanum Srinivas resolved AXIS-2061:
> > ------------------------------------
> >
> >     Resolution: Fixed
> >
> > did the refactoring myself...seems to hold up. (still need to figure out why calling getOperationDesc *before* body.getParams() fails)
> >
> > -- dims
> >
> > > Refactored RPCProvider
> > > ----------------------
> > >
> > >          Key: AXIS-2061
> > >          URL: http://issues.apache.org/jira/browse/AXIS-2061
> > >      Project: Apache Axis
> > >         Type: Improvement
> > >   Components: Basic Architecture
> > >     Versions: 1.2.1
> > >     Reporter: David Blevins
> > >  Attachments: RPCProvider.java, RPCProvider.java.diff
> > >
> > > I've split up the RPCProvider's processMessage method so I could override it more easily.  I actually have my own implementation of processMessage and simply use the split out methods.
> >
> > --
> > This message is automatically generated by JIRA.
> > -
> > If you think it was sent incorrectly contact one of the administrators:
> >    http://issues.apache.org/jira/secure/Administrators.jspa
> > -
> > For more information on JIRA, see:
> >    http://www.atlassian.com/software/jira
> 


-- 
Davanum Srinivas -http://blogs.cocoondev.org/dims/

Re: [jira] Resolved: (AXIS-2061) Refactored RPCProvider

Posted by David Blevins <da...@visi.com>.
Thanks for gettting these refactors in!

Can anyone make these two methods protected real quick?  Waiting to check in some code that uses them.

private RPCElement getBody(SOAPEnvelope reqEnv, MessageContext msgContext) throws Exception {
private OperationDesc getOperationDesc(MessageContext msgContext, RPCElement body) throws SAXException, AxisFault {

Thanks,
David

On Fri, Jun 17, 2005 at 08:46:39PM +0200, Davanum Srinivas (JIRA) wrote:
>      [ http://issues.apache.org/jira/browse/AXIS-2061?page=all ]
>      
> Davanum Srinivas resolved AXIS-2061:
> ------------------------------------
> 
>     Resolution: Fixed
> 
> did the refactoring myself...seems to hold up. (still need to figure out why calling getOperationDesc *before* body.getParams() fails)
> 
> -- dims
> 
> > Refactored RPCProvider
> > ----------------------
> >
> >          Key: AXIS-2061
> >          URL: http://issues.apache.org/jira/browse/AXIS-2061
> >      Project: Apache Axis
> >         Type: Improvement
> >   Components: Basic Architecture
> >     Versions: 1.2.1
> >     Reporter: David Blevins
> >  Attachments: RPCProvider.java, RPCProvider.java.diff
> >
> > I've split up the RPCProvider's processMessage method so I could override it more easily.  I actually have my own implementation of processMessage and simply use the split out methods.
> 
> -- 
> This message is automatically generated by JIRA.
> -
> If you think it was sent incorrectly contact one of the administrators:
>    http://issues.apache.org/jira/secure/Administrators.jspa
> -
> For more information on JIRA, see:
>    http://www.atlassian.com/software/jira

[jira] Commented: (AXIS-2061) Refactored RPCProvider

Posted by "Davanum Srinivas (JIRA)" <ax...@ws.apache.org>.
    [ http://issues.apache.org/jira/browse/AXIS-2061?page=comments#action_12313908 ] 

Davanum Srinivas commented on AXIS-2061:
----------------------------------------

got a failure:

    <error message="; nested exception is:
        java.lang.ArrayIndexOutOfBoundsException: 1" type="org.apache.axis.AxisFault">AxisFault
 faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
 faultSubcode:
 faultString: java.lang.ArrayIndexOutOfBoundsException: 1
 faultActor:
 faultNode:
 faultDetail:
        {http://xml.apache.org/axis/}stackTrace:java.lang.ArrayIndexOutOfBoundsException: 1
        at org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:132)
        at org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:323)
        at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
        at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
        at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
        at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:453)
        at org.apache.axis.server.AxisServer.invoke(AxisServer.java:281)
        at test.RPCDispatch.TestSerializedRPC.rpc(TestSerializedRPC.java:125)
        at test.RPCDispatch.TestSerializedRPC.testOverloadedMethodDispatch(TestSerializedRPC.java:286)

        {http://xml.apache.org/axis/}hostname:ws.zones.apache.org
        {http://xml.apache.org/axis/}isRuntimeException:true

java.lang.ArrayIndexOutOfBoundsException: 1
        at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
        at org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:333)
        at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
        at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
        at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
        at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:453)
        at org.apache.axis.server.AxisServer.invoke(AxisServer.java:281)
        at test.RPCDispatch.TestSerializedRPC.rpc(TestSerializedRPC.java:125)
        at test.RPCDispatch.TestSerializedRPC.testOverloadedMethodDispatch(TestSerializedRPC.java:286)
Caused by: java.lang.ArrayIndexOutOfBoundsException: 1
        at org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:132)
        at org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:323)
        ... 24 more
</error>


> Refactored RPCProvider
> ----------------------
>
>          Key: AXIS-2061
>          URL: http://issues.apache.org/jira/browse/AXIS-2061
>      Project: Apache Axis
>         Type: Improvement
>   Components: Basic Architecture
>     Versions: 1.2.1
>     Reporter: David Blevins
>  Attachments: RPCProvider.java, RPCProvider.java.diff
>
> I've split up the RPCProvider's processMessage method so I could override it more easily.  I actually have my own implementation of processMessage and simply use the split out methods.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Resolved: (AXIS-2061) Refactored RPCProvider

Posted by "Davanum Srinivas (JIRA)" <ax...@ws.apache.org>.
     [ http://issues.apache.org/jira/browse/AXIS-2061?page=all ]
     
Davanum Srinivas resolved AXIS-2061:
------------------------------------

    Resolution: Fixed

did the refactoring myself...seems to hold up. (still need to figure out why calling getOperationDesc *before* body.getParams() fails)

-- dims

> Refactored RPCProvider
> ----------------------
>
>          Key: AXIS-2061
>          URL: http://issues.apache.org/jira/browse/AXIS-2061
>      Project: Apache Axis
>         Type: Improvement
>   Components: Basic Architecture
>     Versions: 1.2.1
>     Reporter: David Blevins
>  Attachments: RPCProvider.java, RPCProvider.java.diff
>
> I've split up the RPCProvider's processMessage method so I could override it more easily.  I actually have my own implementation of processMessage and simply use the split out methods.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Updated: (AXIS-2061) Refactored RPCProvider

Posted by "David Blevins (JIRA)" <ax...@ws.apache.org>.
     [ http://issues.apache.org/jira/browse/AXIS-2061?page=all ]

David Blevins updated AXIS-2061:
--------------------------------

    Attachment: RPCProvider.java.diff

> Refactored RPCProvider
> ----------------------
>
>          Key: AXIS-2061
>          URL: http://issues.apache.org/jira/browse/AXIS-2061
>      Project: Apache Axis
>         Type: Improvement
>   Components: Basic Architecture
>     Versions: 1.2.1
>     Reporter: David Blevins
>  Attachments: RPCProvider.java.diff
>
> I've split up the RPCProvider's processMessage method so I could override it more easily.  I actually have my own implementation of processMessage and simply use the split out methods.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Updated: (AXIS-2061) Refactored RPCProvider

Posted by "David Blevins (JIRA)" <ax...@ws.apache.org>.
     [ http://issues.apache.org/jira/browse/AXIS-2061?page=all ]

David Blevins updated AXIS-2061:
--------------------------------

    Attachment: RPCProvider.java

cvs diff -u RPCProvider.java > RPCProvider.java.diff
cvs diff: conflicting specifications of output style

Doesn't seem to work just like that.  I attached the whole file.

> Refactored RPCProvider
> ----------------------
>
>          Key: AXIS-2061
>          URL: http://issues.apache.org/jira/browse/AXIS-2061
>      Project: Apache Axis
>         Type: Improvement
>   Components: Basic Architecture
>     Versions: 1.2.1
>     Reporter: David Blevins
>  Attachments: RPCProvider.java, RPCProvider.java.diff
>
> I've split up the RPCProvider's processMessage method so I could override it more easily.  I actually have my own implementation of processMessage and simply use the split out methods.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


[jira] Commented: (AXIS-2061) Refactored RPCProvider

Posted by "Davanum Srinivas (JIRA)" <ax...@ws.apache.org>.
    [ http://issues.apache.org/jira/browse/AXIS-2061?page=comments#action_12313878 ] 

Davanum Srinivas commented on AXIS-2061:
----------------------------------------

can you please upload a "cvs diff -u" version. easier to read and apply.

thanks,
dims

> Refactored RPCProvider
> ----------------------
>
>          Key: AXIS-2061
>          URL: http://issues.apache.org/jira/browse/AXIS-2061
>      Project: Apache Axis
>         Type: Improvement
>   Components: Basic Architecture
>     Versions: 1.2.1
>     Reporter: David Blevins
>  Attachments: RPCProvider.java.diff
>
> I've split up the RPCProvider's processMessage method so I could override it more easily.  I actually have my own implementation of processMessage and simply use the split out methods.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira