You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@airflow.apache.org by "ASF subversion and git services (JIRA)" <ji...@apache.org> on 2018/06/04 09:05:00 UTC

[jira] [Commented] (AIRFLOW-2513) Change `bql` to `sql` for BigQuery Hooks & Operators for consistency

    [ https://issues.apache.org/jira/browse/AIRFLOW-2513?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16499920#comment-16499920 ] 

ASF subversion and git services commented on AIRFLOW-2513:
----------------------------------------------------------

Commit b220fe60d5302546d85ee15cf6c8eaa5859316d3 in incubator-airflow's branch refs/heads/master from [~kaxilnaik]
[ https://git-wip-us.apache.org/repos/asf?p=incubator-airflow.git;h=b220fe6 ]

[AIRFLOW-2513] Change `bql` to `sql` for BigQuery Hooks & Ops

- Change `bql` to `sql` for BigQuery Hooks &
Operators for consistency

Closes #3454 from kaxil/consistent-bq-lang


> Change `bql` to `sql` for BigQuery Hooks & Operators for consistency
> --------------------------------------------------------------------
>
>                 Key: AIRFLOW-2513
>                 URL: https://issues.apache.org/jira/browse/AIRFLOW-2513
>             Project: Apache Airflow
>          Issue Type: Task
>    Affects Versions: 1.9.0, 1.8.2
>            Reporter: Kaxil Naik
>            Assignee: Kaxil Naik
>            Priority: Major
>             Fix For: 2.0.0
>
>
> After discussing this yesterday with Google data engineers I can confirm that there is nothing called *bql* as used as parameter to pass SQL queries by some of the BigQuery operators (*BigQueryCheckOperator* for example uses *sql* and *BigQueryOperator* uses *bql* ) and hooks while some of the other Bigquery operators and Hooks have *sql* instead. It makes more sense to stick with *sql* instead of *bql*.
> However as most of the previous stable versions used it, we should first show a deprecation warning for a stable release or we can change this in *Airflow 2.0* and mention it in the release doc that regarding the change of parameter name.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)