You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@jena.apache.org by "Andy Seaborne (JIRA)" <ji...@apache.org> on 2010/12/10 12:22:00 UTC
[jira] Created: (JENA-7) IRI isRootless flips true and false.
IRI isRootless flips true and false.
------------------------------------
Key: JENA-7
URL: https://issues.apache.org/jira/browse/JENA-7
Project: Jena
Issue Type: Bug
Reporter: Andy Seaborne
This operations returns true for false and vice versa, give it's name: should be named is "isRooted" or the result sense chnaged.
{{
@Override
public boolean isRootless() {
if (!has(SCHEME))
return false;
if (has(AUTHORITY))
return false;
if (path.equals(""))
return false;
if (path.charAt(0) == '/')
return false;
return true;
}
}}
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.
[jira] Updated: (JENA-7) IRI isRootless flips true and false.
Posted by "Andy Seaborne (JIRA)" <ji...@apache.org>.
[ https://issues.apache.org/jira/browse/JENA-7?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Andy Seaborne updated JENA-7:
-----------------------------
Component/s: IRI
Description:
This operations returns true for false and vice versa, give it's name: should be named is "isRooted" or the result sense changed.
@Override
public boolean isRootless() {
if (!has(SCHEME))
return false;
if (has(AUTHORITY))
return false;
if (path.equals(""))
return false;
if (path.charAt(0) == '/')
return false;
return true;
}
was:
This operations returns true for false and vice versa, give it's name: should be named is "isRooted" or the result sense chnaged.
{{
@Override
public boolean isRootless() {
if (!has(SCHEME))
return false;
if (has(AUTHORITY))
return false;
if (path.equals(""))
return false;
if (path.charAt(0) == '/')
return false;
return true;
}
}}
Priority: Minor (was: Major)
> IRI isRootless flips true and false.
> ------------------------------------
>
> Key: JENA-7
> URL: https://issues.apache.org/jira/browse/JENA-7
> Project: Jena
> Issue Type: Bug
> Components: IRI
> Reporter: Andy Seaborne
> Priority: Minor
>
> This operations returns true for false and vice versa, give it's name: should be named is "isRooted" or the result sense changed.
> @Override
> public boolean isRootless() {
> if (!has(SCHEME))
> return false;
> if (has(AUTHORITY))
> return false;
> if (path.equals(""))
> return false;
> if (path.charAt(0) == '/')
> return false;
> return true;
> }
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.