You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hive.apache.org by "Alexander Pivovarov (JIRA)" <ji...@apache.org> on 2015/05/02 09:27:06 UTC

[jira] [Created] (HIVE-10582) variable typo in HiveOpConverter line 714

Alexander Pivovarov created HIVE-10582:
------------------------------------------

             Summary: variable typo in HiveOpConverter line 714
                 Key: HIVE-10582
                 URL: https://issues.apache.org/jira/browse/HIVE-10582
             Project: Hive
          Issue Type: Bug
          Components: Logical Optimizer
            Reporter: Alexander Pivovarov
            Assignee: Alexander Pivovarov
            Priority: Minor


HiveOpConverter lines 703-717
{code}
      int kindex = exprBack == null ? -1 : ExprNodeDescUtils.indexOf(exprBack, reduceKeysBack);
      if (kindex >= 0) {
        ColumnInfo newColInfo = new ColumnInfo(colInfo);
        newColInfo.setInternalName(Utilities.ReduceField.KEY + ".reducesinkkey" + kindex);
        newColInfo.setAlias(outputColName);
        newColInfo.setTabAlias(colInfo.getTabAlias());
        outputColumns.add(newColInfo);
        index[i] = kindex;
        continue;
      }
      int vindex = exprBack == null ? -1 : ExprNodeDescUtils.indexOf(exprBack, reduceValuesBack);
      if (kindex >= 0) { // looks like it should be vindex instead of kindex
        index[i] = -vindex - 1;
        continue;
      }
{code}

Most probably the second "if (kindex >= 0)" (line 714) should be replaces with "if (vindex >= 0)"



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)