You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-dev@hadoop.apache.org by "Stephen Chu (JIRA)" <ji...@apache.org> on 2013/05/30 20:54:20 UTC
[jira] [Created] (HDFS-4868) Clean up error message when trying to
snapshot using ViewFileSystem
Stephen Chu created HDFS-4868:
---------------------------------
Summary: Clean up error message when trying to snapshot using ViewFileSystem
Key: HDFS-4868
URL: https://issues.apache.org/jira/browse/HDFS-4868
Project: Hadoop HDFS
Issue Type: Improvement
Components: snapshots
Reporter: Stephen Chu
Priority: Minor
Snapshots aren't supported for the ViewFileSystem. When users try to create a snapshot, they'll run into a message like the following:
{code}
schu-mbp:presentation schu$ hadoop fs -createSnapshot /user/schu
-createSnapshot: Fatal internal error
java.lang.UnsupportedOperationException: ViewFileSystem doesn't support createSnapshot
at org.apache.hadoop.fs.FileSystem.createSnapshot(FileSystem.java:2285)
at org.apache.hadoop.fs.shell.SnapshotCommands$CreateSnapshot.processArguments(SnapshotCommands.java:87)
at org.apache.hadoop.fs.shell.Command.processRawArguments(Command.java:194)
at org.apache.hadoop.fs.shell.Command.run(Command.java:155)
at org.apache.hadoop.fs.FsShell.run(FsShell.java:255)
at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
at org.apache.hadoop.fs.FsShell.main(FsShell.java:305)
{code}
To make things more readable and avoid confusion, it would be helpful to clean up the error message stacktrace and just state that ViewFileSystem doesn't support createSnapshot, similar to what was done in HDFS-4846. The "fatal internal error" message is a bit scary and it might be useful to remove that message to avoid confusion from operators.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira