You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@storm.apache.org by bo...@apache.org on 2016/01/05 18:18:18 UTC

[1/2] storm git commit: AvroGenericRecordBolt instead of SequenceFileBolt

Repository: storm
Updated Branches:
  refs/heads/master c242378be -> a8554305b


AvroGenericRecordBolt instead of SequenceFileBolt

Changing the example code and use AvroGenericRecordBolt  instead of
SequenceFileBolt…

Section “Support for Avro Files” starts by explained the use of
org.apache.storm.hdfs.bolt.AvroGenericRecordBolt for Avro files.
However, the example code uses SequenceFileBolt instead, and that
doesn’t work, obviously because the method withSchemaAsString isn’t
part of SequenceFileBolt, but part of
org.apache.storm.hdfs.bolt.AvroGenericRecordBolt instead. So, the
change is nothing but changing the name of class SequenceFileBolt and
replace it with the correct AvroGenericRecordBolt.


Project: http://git-wip-us.apache.org/repos/asf/storm/repo
Commit: http://git-wip-us.apache.org/repos/asf/storm/commit/51746991
Tree: http://git-wip-us.apache.org/repos/asf/storm/tree/51746991
Diff: http://git-wip-us.apache.org/repos/asf/storm/diff/51746991

Branch: refs/heads/master
Commit: 51746991079dee7ac4ad4045eb3cfbadc78fc038
Parents: 6d88951
Author: johanwitters <jo...@witters.be>
Authored: Tue Jan 5 16:16:04 2016 +0000
Committer: johanwitters <jo...@witters.be>
Committed: Tue Jan 5 16:16:04 2016 +0000

----------------------------------------------------------------------
 external/storm-hdfs/README.md | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/storm/blob/51746991/external/storm-hdfs/README.md
----------------------------------------------------------------------
diff --git a/external/storm-hdfs/README.md b/external/storm-hdfs/README.md
index 7819f81..450a8f5 100644
--- a/external/storm-hdfs/README.md
+++ b/external/storm-hdfs/README.md
@@ -295,7 +295,7 @@ The `org.apache.storm.hdfs.bolt.AvroGenericRecordBolt` class allows you to write
         // create sequence format instance.
         DefaultSequenceFormat format = new DefaultSequenceFormat("timestamp", "sentence");
 
-        SequenceFileBolt bolt = new SequenceFileBolt()
+        AvroGenericRecordBolt bolt = new AvroGenericRecordBolt()
                 .withFsUrl("hdfs://localhost:54310")
                 .withFileNameFormat(fileNameFormat)
                 .withSchemaAsString(schema)


[2/2] storm git commit: Merge branch 'master' of https://github.com/johanwitters/storm into PULL-989

Posted by bo...@apache.org.
Merge branch 'master' of https://github.com/johanwitters/storm into PULL-989

Pull Request 989: AvroGenericRecordBolt instead of SequenceFileBolt in documentation.


Project: http://git-wip-us.apache.org/repos/asf/storm/repo
Commit: http://git-wip-us.apache.org/repos/asf/storm/commit/a8554305
Tree: http://git-wip-us.apache.org/repos/asf/storm/tree/a8554305
Diff: http://git-wip-us.apache.org/repos/asf/storm/diff/a8554305

Branch: refs/heads/master
Commit: a8554305b288ba6f729d40f4670db95ecc1139af
Parents: c242378 5174699
Author: Robert (Bobby) Evans <ev...@yahoo-inc.com>
Authored: Tue Jan 5 11:17:23 2016 -0600
Committer: Robert (Bobby) Evans <ev...@yahoo-inc.com>
Committed: Tue Jan 5 11:17:23 2016 -0600

----------------------------------------------------------------------
 external/storm-hdfs/README.md | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
----------------------------------------------------------------------