You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by Gary Gregory <ga...@gmail.com> on 2015/08/12 17:48:44 UTC

Fwd: [jira] [Resolved] (BCEL-233) The access_flags field in AccessFlags class should be final

Any thoughts on not using underscores in names?

Gary

---------- Forwarded message ----------
From: Sebb (JIRA) <ji...@apache.org>
Date: Wed, Aug 12, 2015 at 5:52 AM
Subject: [jira] [Resolved] (BCEL-233) The access_flags field in AccessFlags
class should be final
To: issues@commons.apache.org



     [
https://issues.apache.org/jira/browse/BCEL-233?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sebb resolved BCEL-233.
-----------------------
       Resolution: Fixed
    Fix Version/s: 6.0

URL: http://svn.apache.org/r1695497
Log:
BCEL-233 The access_flags field in AccessFlags class should be final

Modified:
    commons/proper/bcel/trunk/src/changes/changes.xml

commons/proper/bcel/trunk/src/main/java/org/apache/commons/bcel6/classfile/AccessFlags.java


> The access_flags field in AccessFlags class should be final
> -----------------------------------------------------------
>
>                 Key: BCEL-233
>                 URL: https://issues.apache.org/jira/browse/BCEL-233
>             Project: Commons BCEL
>          Issue Type: Improvement
>            Reporter: Sebb
>             Fix For: 6.0
>
>
> The access_flags field in the AccessFlags class should be final.
> It is currently not set by any other classes outside their constructors.
> The public setters - e.g. isPrivate(boolean) - are not used and should be
deleted. [Apart from that, their names are really confusing.]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)



-- 
E-Mail: garydgregory@gmail.com | ggregory@apache.org
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory

Re: [jira] [Resolved] (BCEL-233) The access_flags field in AccessFlags class should be final

Posted by Gary Gregory <ga...@gmail.com>.
+1

Gary

On Fri, Aug 14, 2015 at 12:44 AM, Benedikt Ritter <br...@apache.org>
wrote:

> I would prefer field anmes in camel case...
>
> 2015-08-12 17:48 GMT+02:00 Gary Gregory <ga...@gmail.com>:
>
> > Any thoughts on not using underscores in names?
> >
> > Gary
> >
> > ---------- Forwarded message ----------
> > From: Sebb (JIRA) <ji...@apache.org>
> > Date: Wed, Aug 12, 2015 at 5:52 AM
> > Subject: [jira] [Resolved] (BCEL-233) The access_flags field in
> AccessFlags
> > class should be final
> > To: issues@commons.apache.org
> >
> >
> >
> >      [
> >
> >
> https://issues.apache.org/jira/browse/BCEL-233?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
> > ]
> >
> > Sebb resolved BCEL-233.
> > -----------------------
> >        Resolution: Fixed
> >     Fix Version/s: 6.0
> >
> > URL: http://svn.apache.org/r1695497
> > Log:
> > BCEL-233 The access_flags field in AccessFlags class should be final
> >
> > Modified:
> >     commons/proper/bcel/trunk/src/changes/changes.xml
> >
> >
> >
> commons/proper/bcel/trunk/src/main/java/org/apache/commons/bcel6/classfile/AccessFlags.java
> >
> >
> > > The access_flags field in AccessFlags class should be final
> > > -----------------------------------------------------------
> > >
> > >                 Key: BCEL-233
> > >                 URL: https://issues.apache.org/jira/browse/BCEL-233
> > >             Project: Commons BCEL
> > >          Issue Type: Improvement
> > >            Reporter: Sebb
> > >             Fix For: 6.0
> > >
> > >
> > > The access_flags field in the AccessFlags class should be final.
> > > It is currently not set by any other classes outside their
> constructors.
> > > The public setters - e.g. isPrivate(boolean) - are not used and should
> be
> > deleted. [Apart from that, their names are really confusing.]
> >
> >
> >
> > --
> > This message was sent by Atlassian JIRA
> > (v6.3.4#6332)
> >
> >
> >
> > --
> > E-Mail: garydgregory@gmail.com | ggregory@apache.org
> > Java Persistence with Hibernate, Second Edition
> > <http://www.manning.com/bauer3/>
> > JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
> > Spring Batch in Action <http://www.manning.com/templier/>
> > Blog: http://garygregory.wordpress.com
> > Home: http://garygregory.com/
> > Tweet! http://twitter.com/GaryGregory
> >
>
>
>
> --
> http://people.apache.org/~britter/
> http://www.systemoutprintln.de/
> http://twitter.com/BenediktRitter
> http://github.com/britter
>



-- 
E-Mail: garydgregory@gmail.com | ggregory@apache.org
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory

Re: [jira] [Resolved] (BCEL-233) The access_flags field in AccessFlags class should be final

Posted by Benedikt Ritter <br...@apache.org>.
I would prefer field anmes in camel case...

2015-08-12 17:48 GMT+02:00 Gary Gregory <ga...@gmail.com>:

> Any thoughts on not using underscores in names?
>
> Gary
>
> ---------- Forwarded message ----------
> From: Sebb (JIRA) <ji...@apache.org>
> Date: Wed, Aug 12, 2015 at 5:52 AM
> Subject: [jira] [Resolved] (BCEL-233) The access_flags field in AccessFlags
> class should be final
> To: issues@commons.apache.org
>
>
>
>      [
>
> https://issues.apache.org/jira/browse/BCEL-233?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
> ]
>
> Sebb resolved BCEL-233.
> -----------------------
>        Resolution: Fixed
>     Fix Version/s: 6.0
>
> URL: http://svn.apache.org/r1695497
> Log:
> BCEL-233 The access_flags field in AccessFlags class should be final
>
> Modified:
>     commons/proper/bcel/trunk/src/changes/changes.xml
>
>
> commons/proper/bcel/trunk/src/main/java/org/apache/commons/bcel6/classfile/AccessFlags.java
>
>
> > The access_flags field in AccessFlags class should be final
> > -----------------------------------------------------------
> >
> >                 Key: BCEL-233
> >                 URL: https://issues.apache.org/jira/browse/BCEL-233
> >             Project: Commons BCEL
> >          Issue Type: Improvement
> >            Reporter: Sebb
> >             Fix For: 6.0
> >
> >
> > The access_flags field in the AccessFlags class should be final.
> > It is currently not set by any other classes outside their constructors.
> > The public setters - e.g. isPrivate(boolean) - are not used and should be
> deleted. [Apart from that, their names are really confusing.]
>
>
>
> --
> This message was sent by Atlassian JIRA
> (v6.3.4#6332)
>
>
>
> --
> E-Mail: garydgregory@gmail.com | ggregory@apache.org
> Java Persistence with Hibernate, Second Edition
> <http://www.manning.com/bauer3/>
> JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
> Spring Batch in Action <http://www.manning.com/templier/>
> Blog: http://garygregory.wordpress.com
> Home: http://garygregory.com/
> Tweet! http://twitter.com/GaryGregory
>



-- 
http://people.apache.org/~britter/
http://www.systemoutprintln.de/
http://twitter.com/BenediktRitter
http://github.com/britter