You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@airflow.apache.org by "potiuk (via GitHub)" <gi...@apache.org> on 2023/08/23 07:34:56 UTC

[GitHub] [airflow] potiuk commented on a diff in pull request #33649: Upgrade botocore/aiobotocore minimum requirements

potiuk commented on code in PR #33649:
URL: https://github.com/apache/airflow/pull/33649#discussion_r1302605345


##########
Dockerfile.ci:
##########
@@ -1393,11 +1393,10 @@ ENV AIRFLOW_REPO=${AIRFLOW_REPO}\
 RUN echo "Airflow version: ${AIRFLOW_VERSION}"
 
 # Those are additional constraints that are needed for some extras but we do not want to
-# force them on the main Airflow package.
-# Recent aiobotocore (2.6.0+) requires this specific botocore version, while
-# boto3 1.28.17 is the last version supporting that, so we pin them to help pip
-# avoid extra work. Revisit this when a new aiobotocore version is released.
-ARG EAGER_UPGRADE_ADDITIONAL_REQUIREMENTS="botocore==1.31.17 boto3<=1.28.17"
+# force them on the main Airflow package. Currently we need no extra limits as PIP 23.1+ has much better
+# dependency resolution and we do not need to limit the versions of the dependencies
+# aiobotocore is limited temporarily until it stops backtracking pip
+ARG EAGER_UPGRADE_ADDITIONAL_REQUIREMENTS=""

Review Comment:
   I believe this will also remove the need of aiobotocore limiting in EAGER UPGRADE . .. let see.



-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: commits-unsubscribe@airflow.apache.org

For queries about this service, please contact Infrastructure at:
users@infra.apache.org