You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Tsz Wo (Nicholas), SZE (JIRA)" <ji...@apache.org> on 2014/03/04 04:47:20 UTC
[jira] [Commented] (HDFS-6041) Downgrade/Finalize should rename the
rollback image instead of purging it
[ https://issues.apache.org/jira/browse/HDFS-6041?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13918985#comment-13918985 ]
Tsz Wo (Nicholas), SZE commented on HDFS-6041:
----------------------------------------------
Two very minor comments:
- After the patch, FSImage.purgeCheckpoints(..) is unused and can be removed.
- Let's put the comment below in one line.
{code}
- // renameTo fails on Windows if the destination file
+ // renameTo fails on Windows if the destination file
// already exists.
{code}
> Downgrade/Finalize should rename the rollback image instead of purging it
> -------------------------------------------------------------------------
>
> Key: HDFS-6041
> URL: https://issues.apache.org/jira/browse/HDFS-6041
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Components: datanode, ha, hdfs-client, namenode
> Reporter: Jing Zhao
> Assignee: Jing Zhao
> Attachments: HDFS-6041.000.patch
>
>
> After we do rollingupgrade downgrade/finalize, instead of purging the rollback image, we'd better rename it back to normal image, since the rollback image can be the most recent checkpoint.
--
This message was sent by Atlassian JIRA
(v6.2#6252)