You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Eric Yang (JIRA)" <ji...@apache.org> on 2017/12/05 23:44:01 UTC

[jira] [Comment Edited] (YARN-7540) Convert yarn app cli to call yarn api services

    [ https://issues.apache.org/jira/browse/YARN-7540?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16279389#comment-16279389 ] 

Eric Yang edited comment on YARN-7540 at 12/5/17 11:43 PM:
-----------------------------------------------------------

[~billie.rinaldi] Thank you for the review.
# I will reduce config object.
# I will reuse RMHAUtils.getRMHAWebappAddress.
# EnableFastLaunch seems to be a problem because Rest API server doesn't have this functionality.  I am more inclined to fix this issue by start up of Resource Manager to check if the required libraries are uploaded to hdfs, and remove the enableFastLaunch option.  Thoughts?
# I will fix the conflict introduced via YARN-6669.
# I agree that NATIVE_TYPE is confusing, and we need this special type for unit tests.  Therefore, I am inclined to rename NATIVE_TYPE to "unit-test" type for correctness.  


was (Author: eyang):
[~billie.rinaldi] 
# I will reduce config object.
# I will reuse RMHAUtils.getRMHAWebappAddress.
# EnableFastLaunch seems to be a problem because Rest API server doesn't have this functionality.  I am more inclined to fix this issue by start up of Resource Manager to check if the required libraries are uploaded to hdfs, and remove the enableFastLaunch option.  Thoughts?
# I will fix the conflict introduced via YARN-6669.
# I agree that NATIVE_TYPE is confusing, and we need this special type for unit tests.  Therefore, I am inclined to rename NATIVE_TYPE to "unit-test" type for correctness.  

> Convert yarn app cli to call yarn api services
> ----------------------------------------------
>
>                 Key: YARN-7540
>                 URL: https://issues.apache.org/jira/browse/YARN-7540
>             Project: Hadoop YARN
>          Issue Type: Sub-task
>            Reporter: Eric Yang
>            Assignee: Eric Yang
>             Fix For: yarn-native-services
>
>         Attachments: YARN-7540.001.patch, YARN-7540.002.patch
>
>
> For YARN docker application to launch through CLI, it works differently from launching through REST API.  All application launched through REST API is currently stored in yarn user HDFS home directory.  Application managed through CLI are stored into individual user's HDFS home directory.  For consistency, we want to have yarn app cli to interact with API service to manage applications.  For performance reason, it is easier to implement list all applications from one user's home directory instead of crawling all user's home directories.  For security reason, it is safer to access only one user home directory instead of all users.  Given the reasons above, the proposal is to change how {{yarn app -launch}}, {{yarn app -list}} and {{yarn app -destroy}} work.  Instead of calling HDFS API and RM API to launch containers, CLI will be converted to call API service REST API resides in RM.  RM perform the persist and operations to launch the actual application.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org