You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@sentry.apache.org by "Gregory Chanan (JIRA)" <ji...@apache.org> on 2016/05/18 23:38:12 UTC
[jira] [Updated] (SENTRY-1269) Converter vs Convertor is
inconsistent
[ https://issues.apache.org/jira/browse/SENTRY-1269?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Gregory Chanan updated SENTRY-1269:
-----------------------------------
Status: Patch Available (was: Open)
> Converter vs Convertor is inconsistent
> --------------------------------------
>
> Key: SENTRY-1269
> URL: https://issues.apache.org/jira/browse/SENTRY-1269
> Project: Sentry
> Issue Type: Improvement
> Components: Solr Plugin
> Affects Versions: 1.8.0
> Reporter: Gregory Chanan
> Assignee: Gregory Chanan
> Priority: Minor
> Fix For: 1.8.0
>
> Attachments: SENTRY-1269.patch
>
>
> ./sentry-provider/sentry-provider-db/src/main/java/org/apache/sentry/service/thrift/ServiceConstants.java: public static final String PRIVILEGE_CONVERTER = "sentry.provider.backend.generic.privilege.converter";
> But the individual types are defined as Convertors:
> ./sentry-provider/sentry-provider-db/src/main/java/org/apache/sentry/provider/db/generic/tools/command/TSentryPrivilegeConvertor.java
> ./sentry-provider/sentry-provider-db/src/main/java/org/apache/sentry/provider/db/generic/tools/KafkaTSentryPrivilegeConvertor.java
> ./sentry-provider/sentry-provider-db/src/main/java/org/apache/sentry/provider/db/generic/tools/SolrTSentryPrivilegeConvertor.java
> ./sentry-provider/sentry-provider-db/target/classes/org/apache/sentry/provider/db/generic/tools/command/TSentryPrivilegeConvertor.class
> ./sentry-provider/sentry-provider-db/target/classes/org/apache/sentry/provider/db/generic/tools/KafkaTSentryPrivilegeConvertor.class
> ./sentry-provider/sentry-provider-db/target/classes/org/apache/sentry/provider/db/generic/tools/SolrTSentryPrivilegeConvertor.class
> This is American vs British spelling, most projects seem to go with American (Converter). We should make this consistent before we do a release.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)