You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@camel.apache.org by "Claus Ibsen (JIRA)" <ji...@apache.org> on 2019/04/06 11:06:00 UTC
[jira] [Commented] (CAMEL-13108) Move mock component out of
camel-core
[ https://issues.apache.org/jira/browse/CAMEL-13108?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16811555#comment-16811555 ]
Claus Ibsen commented on CAMEL-13108:
-------------------------------------
Okay lets start with moving dataset out into camel-dataset, and rename test to dataset-test, then they can be in the same component.
> Move mock component out of camel-core
> -------------------------------------
>
> Key: CAMEL-13108
> URL: https://issues.apache.org/jira/browse/CAMEL-13108
> Project: Camel
> Issue Type: Task
> Reporter: Claus Ibsen
> Assignee: Claus Ibsen
> Priority: Major
> Fix For: 3.0.0
>
> Time Spent: 20m
> Remaining Estimate: 0h
>
> We should likely put mock, dataset and test components in the same JAR as dataset and test extends mock component. So its easier they are in the same JAR.
> Also we already have camel-test for junit testing, so the test component would conflict with camel-test.
> So if we call it camel-mock JAR then we have a free name to use.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)