You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@tinkerpop.apache.org by sp...@apache.org on 2020/01/31 14:42:26 UTC
svn commit: r1873418 [3/7] - in /tinkerpop/site:
docs/3.4.5-SNAPSHOT/dev/developer/ docs/3.4.5-SNAPSHOT/dev/provider/
docs/3.4.5-SNAPSHOT/recipes/ docs/3.4.5-SNAPSHOT/reference/
docs/3.4.5-SNAPSHOT/tutorials/getting-started/ docs/3.4.5-SNAPSHOT/tutoria...
Modified: tinkerpop/site/docs/3.4.5-SNAPSHOT/reference/index.html
URL: http://svn.apache.org/viewvc/tinkerpop/site/docs/3.4.5-SNAPSHOT/reference/index.html?rev=1873418&r1=1873417&r2=1873418&view=diff
==============================================================================
--- tinkerpop/site/docs/3.4.5-SNAPSHOT/reference/index.html (original)
+++ tinkerpop/site/docs/3.4.5-SNAPSHOT/reference/index.html Fri Jan 31 14:42:25 2020
@@ -936,6 +936,7 @@ table.CodeRay td.code>pre{padding:0}
<li><a href="#properties-step">Properties Step</a></li>
<li><a href="#propertymap-step">PropertyMap Step</a></li>
<li><a href="#range-step">Range Step</a></li>
+<li><a href="#read-step">Read Step</a></li>
<li><a href="#repeat-step">Repeat Step</a></li>
<li><a href="#sack-step">Sack Step</a></li>
<li><a href="#sample-step">Sample Step</a></li>
@@ -962,6 +963,7 @@ table.CodeRay td.code>pre{padding:0}
<li><a href="#vertex-steps">Vertex Steps</a></li>
<li><a href="#where-step">Where Step</a></li>
<li><a href="#with-step">With Step</a></li>
+<li><a href="#write-step">Write Step</a></li>
</ul>
</li>
<li><a href="#a-note-on-predicates">A Note on Predicates</a></li>
@@ -1796,10 +1798,10 @@ gremlin> g.V().has(<span class="strin
be spawned off that vertex.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573367-1" type="radio" name="radio-set-1578573367-1" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573367-1" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573367-2" type="radio" name="radio-set-1578573367-1" class="tab-selector-2" />
- <label for="tab-1578573367-2" class="tab-label-2">groovy</label>
+ <input id="tab-1580479155-1" type="radio" name="radio-set-1580479155-1" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479155-1" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479155-2" type="radio" name="radio-set-1580479155-1" class="tab-selector-2" />
+ <label for="tab-1580479155-2" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -1860,10 +1862,10 @@ traverser has gone through a loop, the p
Traverser metadata may be accessed by a step. A classic example is the <a href="#path-step"><code>path()</code></a>-step.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573367-3" type="radio" name="radio-set-1578573367-3" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573367-3" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573367-4" type="radio" name="radio-set-1578573367-3" class="tab-selector-2" />
- <label for="tab-1578573367-4" class="tab-label-2">groovy</label>
+ <input id="tab-1580479155-3" type="radio" name="radio-set-1580479155-3" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479155-3" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479155-4" type="radio" name="radio-set-1580479155-3" class="tab-selector-2" />
+ <label for="tab-1580479155-4" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -1904,10 +1906,10 @@ required. If not, then path calculations
has gone through a particular section of the traversal expression (i.e. a loop).</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573367-5" type="radio" name="radio-set-1578573367-5" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573367-5" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573367-6" type="radio" name="radio-set-1578573367-5" class="tab-selector-2" />
- <label for="tab-1578573367-6" class="tab-label-2">groovy</label>
+ <input id="tab-1580479155-5" type="radio" name="radio-set-1580479155-5" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479155-5" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479155-6" type="radio" name="radio-set-1580479155-5" class="tab-selector-2" />
+ <label for="tab-1580479155-6" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -2099,16 +2101,16 @@ the server which means that there is no
the location of the Gremlin Server to connect to:</p>
</div>
<section class="tabs tabs-5">
- <input id="tab-1578573367-7" type="radio" name="radio-set-1578573367-7" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573367-7" class="tab-label-1">java</label>
- <input id="tab-1578573367-8" type="radio" name="radio-set-1578573367-7" class="tab-selector-2" />
- <label for="tab-1578573367-8" class="tab-label-2">groovy</label>
- <input id="tab-1578573367-9" type="radio" name="radio-set-1578573367-7" class="tab-selector-3" />
- <label for="tab-1578573367-9" class="tab-label-3">csharp</label>
- <input id="tab-1578573367-10" type="radio" name="radio-set-1578573367-7" class="tab-selector-4" />
- <label for="tab-1578573367-10" class="tab-label-4">javascript</label>
- <input id="tab-1578573367-11" type="radio" name="radio-set-1578573367-7" class="tab-selector-5" />
- <label for="tab-1578573367-11" class="tab-label-5">python</label>
+ <input id="tab-1580479155-7" type="radio" name="radio-set-1580479155-7" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479155-7" class="tab-label-1">java</label>
+ <input id="tab-1580479155-8" type="radio" name="radio-set-1580479155-7" class="tab-selector-2" />
+ <label for="tab-1580479155-8" class="tab-label-2">groovy</label>
+ <input id="tab-1580479155-9" type="radio" name="radio-set-1580479155-7" class="tab-selector-3" />
+ <label for="tab-1580479155-9" class="tab-label-3">csharp</label>
+ <input id="tab-1580479155-10" type="radio" name="radio-set-1580479155-7" class="tab-selector-4" />
+ <label for="tab-1580479155-10" class="tab-label-4">javascript</label>
+ <input id="tab-1580479155-11" type="radio" name="radio-set-1580479155-7" class="tab-selector-5" />
+ <label for="tab-1580479155-11" class="tab-label-5">python</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -2251,18 +2253,18 @@ of this documentation, so be sure to con
getting data into the graph regardless of programming language or mode of operation is just some basic Gremlin:</p>
</div>
<section class="tabs tabs-6">
- <input id="tab-1578573367-12" type="radio" name="radio-set-1578573367-12" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573367-12" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573367-13" type="radio" name="radio-set-1578573367-12" class="tab-selector-2" />
- <label for="tab-1578573367-13" class="tab-label-2">groovy</label>
- <input id="tab-1578573367-14" type="radio" name="radio-set-1578573367-12" class="tab-selector-3" />
- <label for="tab-1578573367-14" class="tab-label-3">csharp</label>
- <input id="tab-1578573367-15" type="radio" name="radio-set-1578573367-12" class="tab-selector-4" />
- <label for="tab-1578573367-15" class="tab-label-4">java</label>
- <input id="tab-1578573367-16" type="radio" name="radio-set-1578573367-12" class="tab-selector-5" />
- <label for="tab-1578573367-16" class="tab-label-5">javascript</label>
- <input id="tab-1578573367-17" type="radio" name="radio-set-1578573367-12" class="tab-selector-6" />
- <label for="tab-1578573367-17" class="tab-label-6">python</label>
+ <input id="tab-1580479155-12" type="radio" name="radio-set-1580479155-12" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479155-12" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479155-13" type="radio" name="radio-set-1580479155-12" class="tab-selector-2" />
+ <label for="tab-1580479155-13" class="tab-label-2">groovy</label>
+ <input id="tab-1580479155-14" type="radio" name="radio-set-1580479155-12" class="tab-selector-3" />
+ <label for="tab-1580479155-14" class="tab-label-3">csharp</label>
+ <input id="tab-1580479155-15" type="radio" name="radio-set-1580479155-12" class="tab-selector-4" />
+ <label for="tab-1580479155-15" class="tab-label-4">java</label>
+ <input id="tab-1580479155-16" type="radio" name="radio-set-1580479155-12" class="tab-selector-5" />
+ <label for="tab-1580479155-16" class="tab-label-5">javascript</label>
+ <input id="tab-1580479155-17" type="radio" name="radio-set-1580479155-12" class="tab-selector-6" />
+ <label for="tab-1580479155-17" class="tab-label-6">python</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -2356,18 +2358,18 @@ is a large one-time load to do.
<p>Retrieving this data is also a just writing a Gremlin statement:</p>
</div>
<section class="tabs tabs-6">
- <input id="tab-1578573367-18" type="radio" name="radio-set-1578573367-18" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573367-18" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573367-19" type="radio" name="radio-set-1578573367-18" class="tab-selector-2" />
- <label for="tab-1578573367-19" class="tab-label-2">groovy</label>
- <input id="tab-1578573367-20" type="radio" name="radio-set-1578573367-18" class="tab-selector-3" />
- <label for="tab-1578573367-20" class="tab-label-3">csharp</label>
- <input id="tab-1578573367-21" type="radio" name="radio-set-1578573367-18" class="tab-selector-4" />
- <label for="tab-1578573367-21" class="tab-label-4">java</label>
- <input id="tab-1578573367-22" type="radio" name="radio-set-1578573367-18" class="tab-selector-5" />
- <label for="tab-1578573367-22" class="tab-label-5">javascript</label>
- <input id="tab-1578573367-23" type="radio" name="radio-set-1578573367-18" class="tab-selector-6" />
- <label for="tab-1578573367-23" class="tab-label-6">python</label>
+ <input id="tab-1580479155-18" type="radio" name="radio-set-1580479155-18" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479155-18" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479155-19" type="radio" name="radio-set-1580479155-18" class="tab-selector-2" />
+ <label for="tab-1580479155-19" class="tab-label-2">groovy</label>
+ <input id="tab-1580479155-20" type="radio" name="radio-set-1580479155-18" class="tab-selector-3" />
+ <label for="tab-1580479155-20" class="tab-label-3">csharp</label>
+ <input id="tab-1580479155-21" type="radio" name="radio-set-1580479155-18" class="tab-selector-4" />
+ <label for="tab-1580479155-21" class="tab-label-4">java</label>
+ <input id="tab-1580479155-22" type="radio" name="radio-set-1580479155-18" class="tab-selector-5" />
+ <label for="tab-1580479155-22" class="tab-label-5">javascript</label>
+ <input id="tab-1580479155-23" type="radio" name="radio-set-1580479155-18" class="tab-selector-6" />
+ <label for="tab-1580479155-23" class="tab-label-6">python</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -2538,10 +2540,10 @@ utilize it as a pointer. For <code>Graph
spawn <code>GraphTraversalSource</code> instances so as to write Gremlin:</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573481-1" type="radio" name="radio-set-1578573481-1" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573481-1" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573481-2" type="radio" name="radio-set-1578573481-1" class="tab-selector-2" />
- <label for="tab-1578573481-2" class="tab-label-2">groovy</label>
+ <input id="tab-1580429183-1" type="radio" name="radio-set-1580429183-1" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580429183-1" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580429183-2" type="radio" name="radio-set-1580429183-1" class="tab-selector-2" />
+ <label for="tab-1580429183-2" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -2624,10 +2626,10 @@ system providers for two purposes:</p>
<p>The following example in the Gremlin Console shows how to print all the features of a <code>Graph</code>:</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573481-3" type="radio" name="radio-set-1578573481-3" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573481-3" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573481-4" type="radio" name="radio-set-1578573481-3" class="tab-selector-2" />
- <label for="tab-1578573481-4" class="tab-label-2">groovy</label>
+ <input id="tab-1580429183-3" type="radio" name="radio-set-1580429183-3" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580429183-3" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580429183-4" type="radio" name="radio-set-1580429183-3" class="tab-selector-2" />
+ <label for="tab-1580429183-4" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -2637,13 +2639,13 @@ system providers for two purposes:</p>
gremlin> graph.features()
==>FEATURES
> GraphFeatures
+>-- <span class="key">Transactions</span>: <span class="predefined-constant">false</span>
>-- <span class="key">Computer</span>: <span class="predefined-constant">true</span>
>-- <span class="key">Persistence</span>: <span class="predefined-constant">true</span>
>-- <span class="key">ConcurrentAccess</span>: <span class="predefined-constant">false</span>
>-- <span class="key">ThreadedTransactions</span>: <span class="predefined-constant">false</span>
>-- <span class="key">IoRead</span>: <span class="predefined-constant">true</span>
>-- <span class="key">IoWrite</span>: <span class="predefined-constant">true</span>
->-- <span class="key">Transactions</span>: <span class="predefined-constant">false</span>
> VariableFeatures
>-- <span class="key">Variables</span>: <span class="predefined-constant">true</span>
>-- <span class="key">BooleanValues</span>: <span class="predefined-constant">true</span>
@@ -2665,19 +2667,19 @@ gremlin> graph.features()
>-- <span class="key">LongArrayValues</span>: <span class="predefined-constant">true</span>
>-- <span class="key">StringArrayValues</span>: <span class="predefined-constant">true</span>
> VertexFeatures
->-- <span class="key">Upsert</span>: <span class="predefined-constant">false</span>
+>-- <span class="key">MetaProperties</span>: <span class="predefined-constant">true</span>
>-- <span class="key">AddVertices</span>: <span class="predefined-constant">true</span>
>-- <span class="key">RemoveVertices</span>: <span class="predefined-constant">true</span>
>-- <span class="key">DuplicateMultiProperties</span>: <span class="predefined-constant">true</span>
->-- <span class="key">MetaProperties</span>: <span class="predefined-constant">true</span>
+>-- <span class="key">Upsert</span>: <span class="predefined-constant">false</span>
>-- <span class="key">MultiProperties</span>: <span class="predefined-constant">true</span>
->-- <span class="key">AddProperty</span>: <span class="predefined-constant">true</span>
>-- <span class="key">RemoveProperty</span>: <span class="predefined-constant">true</span>
>-- <span class="key">NumericIds</span>: <span class="predefined-constant">true</span>
>-- <span class="key">StringIds</span>: <span class="predefined-constant">true</span>
>-- <span class="key">UuidIds</span>: <span class="predefined-constant">true</span>
>-- <span class="key">CustomIds</span>: <span class="predefined-constant">false</span>
>-- <span class="key">AnyIds</span>: <span class="predefined-constant">true</span>
+>-- <span class="key">AddProperty</span>: <span class="predefined-constant">true</span>
>-- <span class="key">UserSuppliedIds</span>: <span class="predefined-constant">true</span>
> VertexPropertyFeatures
>-- <span class="key">RemoveProperty</span>: <span class="predefined-constant">true</span>
@@ -2707,16 +2709,16 @@ gremlin> graph.features()
>-- <span class="key">LongArrayValues</span>: <span class="predefined-constant">true</span>
>-- <span class="key">StringArrayValues</span>: <span class="predefined-constant">true</span>
> EdgeFeatures
->-- <span class="key">AddEdges</span>: <span class="predefined-constant">true</span>
>-- <span class="key">RemoveEdges</span>: <span class="predefined-constant">true</span>
>-- <span class="key">Upsert</span>: <span class="predefined-constant">false</span>
->-- <span class="key">AddProperty</span>: <span class="predefined-constant">true</span>
+>-- <span class="key">AddEdges</span>: <span class="predefined-constant">true</span>
>-- <span class="key">RemoveProperty</span>: <span class="predefined-constant">true</span>
>-- <span class="key">NumericIds</span>: <span class="predefined-constant">true</span>
>-- <span class="key">StringIds</span>: <span class="predefined-constant">true</span>
>-- <span class="key">UuidIds</span>: <span class="predefined-constant">true</span>
>-- <span class="key">CustomIds</span>: <span class="predefined-constant">false</span>
>-- <span class="key">AnyIds</span>: <span class="predefined-constant">true</span>
+>-- <span class="key">AddProperty</span>: <span class="predefined-constant">true</span>
>-- <span class="key">UserSuppliedIds</span>: <span class="predefined-constant">true</span>
> EdgePropertyFeatures
>-- <span class="predefined-type">Properties</span>: <span class="predefined-constant">true</span>
@@ -2757,10 +2759,10 @@ graph.features()</code></pre>
<p>A common pattern for using features is to check their support prior to performing an operation:</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573481-5" type="radio" name="radio-set-1578573481-5" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573481-5" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573481-6" type="radio" name="radio-set-1578573481-5" class="tab-selector-2" />
- <label for="tab-1578573481-6" class="tab-label-2">groovy</label>
+ <input id="tab-1580429183-5" type="radio" name="radio-set-1580429183-5" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580429183-5" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580429183-6" type="radio" name="radio-set-1580429183-5" class="tab-selector-2" />
+ <label for="tab-1580429183-6" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -2859,10 +2861,10 @@ of a name from different sources.</p>
<p>A running example using vertex properties is provided below to demonstrate and explain the API.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573481-7" type="radio" name="radio-set-1578573481-7" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573481-7" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573481-8" type="radio" name="radio-set-1578573481-7" class="tab-selector-2" />
- <label for="tab-1578573481-8" class="tab-label-2">groovy</label>
+ <input id="tab-1580429183-7" type="radio" name="radio-set-1580429183-7" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580429183-7" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580429183-8" type="radio" name="radio-set-1580429183-7" class="tab-selector-2" />
+ <label for="tab-1580429183-8" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -3020,10 +3022,10 @@ A toy graph demonstrating all of the new
<div class="title">Figure 3. TinkerPop Crew</div>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573481-9" type="radio" name="radio-set-1578573481-9" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573481-9" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573481-10" type="radio" name="radio-set-1578573481-9" class="tab-selector-2" />
- <label for="tab-1578573481-10" class="tab-label-2">groovy</label>
+ <input id="tab-1580429183-9" type="radio" name="radio-set-1580429183-9" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580429183-9" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580429183-10" type="radio" name="radio-set-1580429183-9" class="tab-selector-2" />
+ <label for="tab-1580429183-10" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -3091,10 +3093,10 @@ variables are intended to store metadata
<p>An example of graph variables in use is presented below:</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573481-11" type="radio" name="radio-set-1578573481-11" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573481-11" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573481-12" type="radio" name="radio-set-1578573481-11" class="tab-selector-2" />
- <label for="tab-1578573481-12" class="tab-label-2">groovy</label>
+ <input id="tab-1580429183-11" type="radio" name="radio-set-1580429183-11" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580429183-11" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580429183-12" type="radio" name="radio-set-1580429183-11" class="tab-selector-2" />
+ <label for="tab-1580429183-12" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -3733,10 +3735,10 @@ with lambdas, please read <a href="#a-no
<p><span class="image" style="float: right"><img src="../images/map-lambda.png" alt="map lambda" width="150"></span></p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-1" type="radio" name="radio-set-1578573570-1" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-1" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-2" type="radio" name="radio-set-1578573570-1" class="tab-selector-2" />
- <label for="tab-1578573570-2" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-1" type="radio" name="radio-set-1580479264-1" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-1" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-2" type="radio" name="radio-set-1580479264-1" class="tab-selector-2" />
+ <label for="tab-1580479264-2" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -3786,10 +3788,10 @@ g.V(<span class="integer">1</span>).out(
<p><span class="image" style="float: right"><img src="../images/filter-lambda.png" alt="filter lambda" width="160"></span></p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-3" type="radio" name="radio-set-1578573570-3" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-3" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-4" type="radio" name="radio-set-1578573570-3" class="tab-selector-2" />
- <label for="tab-1578573570-4" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-3" type="radio" name="radio-set-1580479264-3" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-3" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-4" type="radio" name="radio-set-1580479264-3" class="tab-selector-2" />
+ <label for="tab-1580479264-4" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -3842,10 +3844,10 @@ g.V().hasLabel(<span class="string"><spa
<p><span class="image" style="float: right"><img src="../images/side-effect-lambda.png" alt="side effect lambda" width="175"></span></p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-5" type="radio" name="radio-set-1578573570-5" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-5" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-6" type="radio" name="radio-set-1578573570-5" class="tab-selector-2" />
- <label for="tab-1578573570-6" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-5" type="radio" name="radio-set-1580479264-5" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-5" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-6" type="radio" name="radio-set-1580479264-5" class="tab-selector-2" />
+ <label for="tab-1580479264-6" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -3892,10 +3894,10 @@ g.V().sideEffect(outE().count().store(<s
<p><span class="image" style="float: right"><img src="../images/branch-lambda.png" alt="branch lambda" width="180"></span></p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-7" type="radio" name="radio-set-1578573570-7" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-7" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-8" type="radio" name="radio-set-1578573570-7" class="tab-selector-2" />
- <label for="tab-1578573570-8" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-7" type="radio" name="radio-set-1580479264-7" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-7" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-8" type="radio" name="radio-set-1580479264-7" class="tab-selector-2" />
+ <label for="tab-1580479264-8" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -3972,10 +3974,10 @@ However, some steps do not return a trav
as terminal steps (<strong>terminal</strong>) and they are explained via the examples below.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-9" type="radio" name="radio-set-1578573570-9" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-9" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-10" type="radio" name="radio-set-1578573570-9" class="tab-selector-2" />
- <label for="tab-1578573570-10" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-9" type="radio" name="radio-set-1580479264-9" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-9" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-10" type="radio" name="radio-set-1580479264-9" class="tab-selector-2" />
+ <label for="tab-1580479264-10" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4095,10 +4097,10 @@ worked on the same project together. Thi
</div>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-11" type="radio" name="radio-set-1578573570-11" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-11" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-12" type="radio" name="radio-set-1578573570-11" class="tab-selector-2" />
- <label for="tab-1578573570-12" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-11" type="radio" name="radio-set-1580479264-11" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-11" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-12" type="radio" name="radio-set-1580479264-11" class="tab-selector-2" />
+ <label for="tab-1580479264-12" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4211,10 +4213,10 @@ supports user provided ids.</p>
created. Moreover, <code>GraphTraversalSource</code> maintains an <code>addV()</code> method.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-13" type="radio" name="radio-set-1578573570-13" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-13" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-14" type="radio" name="radio-set-1578573570-13" class="tab-selector-2" />
- <label for="tab-1578573570-14" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-13" type="radio" name="radio-set-1580479264-13" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-13" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-14" type="radio" name="radio-set-1580479264-13" class="tab-selector-2" />
+ <label for="tab-1580479264-14" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4272,10 +4274,10 @@ that streamed into it. Moreover, if <cod
previous step to enable vertex and edge creation with all its properties in one creation operation.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-15" type="radio" name="radio-set-1578573570-15" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-15" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-16" type="radio" name="radio-set-1578573570-15" class="tab-selector-2" />
- <label for="tab-1578573570-16" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-15" type="radio" name="radio-set-1580479264-15" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-15" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-16" type="radio" name="radio-set-1580479264-15" class="tab-selector-2" />
+ <label for="tab-1580479264-16" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4349,10 +4351,10 @@ where everything at a particular point i
<code>aggregate()</code> is called without a <code>Scope</code>, the default is <code>global</code>. An example is provided below.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-17" type="radio" name="radio-set-1578573570-17" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-17" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-18" type="radio" name="radio-set-1578573570-17" class="tab-selector-2" />
- <label for="tab-1578573570-18" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-17" type="radio" name="radio-set-1580479264-17" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-17" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-18" type="radio" name="radio-set-1580479264-17" class="tab-selector-2" />
+ <label for="tab-1580479264-18" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4429,10 +4431,10 @@ g.V(<span class="integer">1</span>).out(
<p>Finally, <code>aggregate()</code>-step can be modulated via <code>by()</code>-projection.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-19" type="radio" name="radio-set-1578573570-19" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-19" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-20" type="radio" name="radio-set-1578573570-19" class="tab-selector-2" />
- <label for="tab-1578573570-20" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-19" type="radio" name="radio-set-1580479264-19" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-19" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-20" type="radio" name="radio-set-1580479264-19" class="tab-selector-2" />
+ <label for="tab-1580479264-20" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4472,10 +4474,10 @@ Prior to 3.4.3, <code>local</code> aggre
</table>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-21" type="radio" name="radio-set-1578573570-21" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-21" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-22" type="radio" name="radio-set-1578573570-21" class="tab-selector-2" />
- <label for="tab-1578573570-22" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-21" type="radio" name="radio-set-1580479264-21" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-21" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-22" type="radio" name="radio-set-1580479264-21" class="tab-selector-2" />
+ <label for="tab-1580479264-22" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4509,10 +4511,10 @@ though the interval selection is for 1 o
filter (i.e. <code>[0..1]</code>), it passes through <code>aggregate()</code> and thus, stored before filtered.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-23" type="radio" name="radio-set-1578573570-23" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-23" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-24" type="radio" name="radio-set-1578573570-23" class="tab-selector-2" />
- <label for="tab-1578573570-24" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-23" type="radio" name="radio-set-1580479264-23" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-23" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-24" type="radio" name="radio-set-1580479264-23" class="tab-selector-2" />
+ <label for="tab-1580479264-24" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4561,10 +4563,10 @@ http://tinkerpop.apache.org/javadocs/3.4
</table>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-25" type="radio" name="radio-set-1578573570-25" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-25" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-26" type="radio" name="radio-set-1578573570-25" class="tab-selector-2" />
- <label for="tab-1578573570-26" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-25" type="radio" name="radio-set-1580479264-25" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-25" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-26" type="radio" name="radio-set-1580479264-25" class="tab-selector-2" />
+ <label for="tab-1580479264-26" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4599,10 +4601,10 @@ original traverser to pass to the next s
<p>An <a href="http://en.wikipedia.org/wiki/Infix_notation">infix notation</a> can be used as well.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-27" type="radio" name="radio-set-1578573570-27" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-27" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-28" type="radio" name="radio-set-1578573570-27" class="tab-selector-2" />
- <label for="tab-1578573570-28" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-27" type="radio" name="radio-set-1580479264-27" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-27" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-28" type="radio" name="radio-set-1580479264-27" class="tab-selector-2" />
+ <label for="tab-1580479264-28" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4667,10 +4669,10 @@ to in Gremlin with the double underscore
</table>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-29" type="radio" name="radio-set-1578573570-29" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-29" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-30" type="radio" name="radio-set-1578573570-29" class="tab-selector-2" />
- <label for="tab-1578573570-30" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-29" type="radio" name="radio-set-1580479264-29" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-29" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-30" type="radio" name="radio-set-1580479264-29" class="tab-selector-2" />
+ <label for="tab-1580479264-30" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4714,10 +4716,10 @@ g.V().as(<span class="string"><span clas
<p>A step can have any number of labels associated with it. This is useful for referencing the same step multiple times in a future step.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-31" type="radio" name="radio-set-1578573570-31" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-31" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-32" type="radio" name="radio-set-1578573570-31" class="tab-selector-2" />
- <label for="tab-1578573570-32" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-31" type="radio" name="radio-set-1580479264-31" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-31" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-32" type="radio" name="radio-set-1580479264-31" class="tab-selector-2" />
+ <label for="tab-1580479264-32" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4771,10 +4773,10 @@ useful in the following situations:</p>
</ul>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-33" type="radio" name="radio-set-1578573570-33" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-33" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-34" type="radio" name="radio-set-1578573570-33" class="tab-selector-2" />
- <label for="tab-1578573570-34" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-33" type="radio" name="radio-set-1580479264-33" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-33" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-34" type="radio" name="radio-set-1580479264-33" class="tab-selector-2" />
+ <label for="tab-1580479264-34" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4827,10 +4829,10 @@ traverser with a <code>Traverser.bulk()<
made more salient on a larger graph. Therefore, the example below leverages the <a href="#grateful-dead">Grateful Dead graph</a>.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-35" type="radio" name="radio-set-1578573570-35" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-35" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-36" type="radio" name="radio-set-1578573570-35" class="tab-selector-2" />
- <label for="tab-1578573570-36" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-35" type="radio" name="radio-set-1580479264-35" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-35" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-36" type="radio" name="radio-set-1580479264-35" class="tab-selector-2" />
+ <label for="tab-1580479264-36" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4843,13 +4845,13 @@ gremlin> g.io(<span class="string"><s
gremlin> g = graph.traversal().withoutStrategies(LazyBarrierStrategy) <span class="invisible">//</span><b class="conum">1</b><span class="invisible">\</span>
==>graphtraversalsource[tinkergraph[<span class="key">vertices</span>:<span class="integer">808</span> <span class="key">edges</span>:<span class="integer">8049</span>], standard]
gremlin> clockWithResult(<span class="integer">1</span>){g.V().both().both().both().count().next()} <span class="invisible">//</span><b class="conum">2</b><span class="invisible">\</span>
-==><span class="float">7351.478593</span>
+==><span class="float">7378.611081999999</span>
==><span class="integer">126653966</span>
gremlin> clockWithResult(<span class="integer">1</span>){g.V().repeat(both()).times(<span class="integer">3</span>).count().next()} <span class="invisible">//</span><b class="conum">3</b><span class="invisible">\</span>
-==><span class="float">10.110994</span>
+==><span class="float">9.828116999999999</span>
==><span class="integer">126653966</span>
gremlin> clockWithResult(<span class="integer">1</span>){g.V().both().barrier().both().barrier().both().barrier().count().next()} <span class="invisible">//</span><b class="conum">4</b><span class="invisible">\</span>
-==><span class="float">8.281848</span>
+==><span class="float">9.438056999999999</span>
==><span class="integer">126653966</span></code></pre>
</div>
</div>
@@ -4897,10 +4899,10 @@ optimization scenario with the added ben
"bulking optimization."</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-37" type="radio" name="radio-set-1578573570-37" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-37" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-38" type="radio" name="radio-set-1578573570-37" class="tab-selector-2" />
- <label for="tab-1578573570-38" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-37" type="radio" name="radio-set-1580479264-37" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-37" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-38" type="radio" name="radio-set-1580479264-37" class="tab-selector-2" />
+ <label for="tab-1580479264-38" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -4911,7 +4913,7 @@ gremlin> g = graph.traversal() <span
==>graphtraversalsource[tinkergraph[<span class="key">vertices</span>:<span class="integer">0</span> <span class="key">edges</span>:<span class="integer">0</span>], standard]
gremlin> g.io(<span class="string"><span class="delimiter">'</span><span class="content">data/grateful-dead.xml</span><span class="delimiter">'</span></span>).read().iterate()
gremlin> clockWithResult(<span class="integer">1</span>){g.V().both().both().both().count().next()}
-==><span class="float">6.103153</span>
+==><span class="float">5.4798469999999995</span>
==><span class="integer">126653966</span>
gremlin> g.V().both().both().both().count().iterate().toString() <span class="invisible">//</span><b class="conum">2</b><span class="invisible">\</span>
==>[TinkerGraphStep(vertex,<span class="type">[]</span>), VertexStep(BOTH,vertex), NoOpBarrierStep(<span class="integer">2500</span>), VertexStep(BOTH,vertex), NoOpBarrierStep(<span class="integer">2500</span>), VertexStep(BOTH,edge), CountGlobalStep, NoneStep]</code></pre>
@@ -4961,10 +4963,10 @@ means by which they are added. The gener
while others can take an arbitrary amount.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-39" type="radio" name="radio-set-1578573570-39" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-39" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-40" type="radio" name="radio-set-1578573570-39" class="tab-selector-2" />
- <label for="tab-1578573570-40" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-39" type="radio" name="radio-set-1580479264-39" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-39" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-40" type="radio" name="radio-set-1580479264-39" class="tab-selector-2" />
+ <label for="tab-1580479264-40" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5079,10 +5081,10 @@ on a step-by-step level and thus, as dis
key. If multiple keys are provided, then a <code>Map<String,Object></code> of sideEffects is emitted.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-41" type="radio" name="radio-set-1578573570-41" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-41" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-42" type="radio" name="radio-set-1578573570-41" class="tab-selector-2" />
- <label for="tab-1578573570-42" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-41" type="radio" name="radio-set-1580479264-41" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-41" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-42" type="radio" name="radio-set-1580479264-41" class="tab-selector-2" />
+ <label for="tab-1580479264-42" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5135,10 +5137,10 @@ g.V().groupCount(<span class="string"><s
it is possible to implement if/then/else-semantics as well as more complicated selections.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-43" type="radio" name="radio-set-1578573570-43" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-43" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-44" type="radio" name="radio-set-1578573570-43" class="tab-selector-2" />
- <label for="tab-1578573570-44" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-43" type="radio" name="radio-set-1580479264-43" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-43" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-44" type="radio" name="radio-set-1580479264-43" class="tab-selector-2" />
+ <label for="tab-1580479264-44" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5193,10 +5195,10 @@ g.V().hasLabel(<span class="string"><spa
<p>If the "false"-branch is not provided, then if/then-semantics are implemented.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-45" type="radio" name="radio-set-1578573570-45" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-45" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-46" type="radio" name="radio-set-1578573570-45" class="tab-selector-2" />
- <label for="tab-1578573570-46" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-45" type="radio" name="radio-set-1580479264-45" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-45" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-46" type="radio" name="radio-set-1580479264-45" class="tab-selector-2" />
+ <label for="tab-1580479264-46" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5244,10 +5246,10 @@ g.V().choose(hasLabel(<span class="strin
<p>Note that <code>choose()</code> can have an arbitrary number of options and moreover, can take an anonymous traversal as its choice function.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-47" type="radio" name="radio-set-1578573570-47" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-47" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-48" type="radio" name="radio-set-1578573570-47" class="tab-selector-2" />
- <label for="tab-1578573570-48" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-47" type="radio" name="radio-set-1580479264-47" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-47" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-48" type="radio" name="radio-set-1580479264-47" class="tab-selector-2" />
+ <label for="tab-1580479264-48" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5285,10 +5287,10 @@ g.V().choose(hasLabel(<span class="strin
<p>The <code>choose()</code>-step can leverage the <code>Pick.none</code> option match. For anything that does not match a specified option, the <code>none</code>-option is taken.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-49" type="radio" name="radio-set-1578573570-49" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-49" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-50" type="radio" name="radio-set-1578573570-49" class="tab-selector-2" />
- <label for="tab-1578573570-50" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-49" type="radio" name="radio-set-1580479264-49" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-49" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-50" type="radio" name="radio-set-1580479264-49" class="tab-selector-2" />
+ <label for="tab-1580479264-50" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5337,10 +5339,10 @@ g.V().choose(hasLabel(<span class="strin
least one element.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-51" type="radio" name="radio-set-1578573570-51" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-51" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-52" type="radio" name="radio-set-1578573570-51" class="tab-selector-2" />
- <label for="tab-1578573570-52" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-51" type="radio" name="radio-set-1580479264-51" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-51" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-52" type="radio" name="radio-set-1580479264-51" class="tab-selector-2" />
+ <label for="tab-1580479264-52" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5387,10 +5389,10 @@ g.V().hasLabel(<span class="string"><spa
<p>To randomly filter out a traverser, use the <code>coin()</code>-step (<strong>filter</strong>). The provided double argument biases the "coin toss."</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-53" type="radio" name="radio-set-1578573570-53" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-53" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-54" type="radio" name="radio-set-1578573570-53" class="tab-selector-2" />
- <label for="tab-1578573570-54" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-53" type="radio" name="radio-set-1580479264-53" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-53" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-54" type="radio" name="radio-set-1580479264-53" class="tab-selector-2" />
+ <label for="tab-1580479264-54" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5398,10 +5400,8 @@ g.V().hasLabel(<span class="string"><spa
<pre class="CodeRay highlight"><code data-lang="groovy">gremlin> g.V().coin(<span class="float">0.5</span>)
==>v[<span class="integer">1</span>]
==>v[<span class="integer">2</span>]
-==>v[<span class="integer">3</span>]
==>v[<span class="integer">4</span>]
==>v[<span class="integer">5</span>]
-==>v[<span class="integer">6</span>]
gremlin> g.V().coin(<span class="float">0.0</span>)
gremlin> g.V().coin(<span class="float">1.0</span>)
==>v[<span class="integer">1</span>]
@@ -5454,10 +5454,10 @@ that supports <code>GraphComputer</code>
</table>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-55" type="radio" name="radio-set-1578573570-55" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-55" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-56" type="radio" name="radio-set-1578573570-55" class="tab-selector-2" />
- <label for="tab-1578573570-56" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-55" type="radio" name="radio-set-1580479264-55" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-55" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-56" type="radio" name="radio-set-1580479264-55" class="tab-selector-2" />
+ <label for="tab-1580479264-56" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5470,12 +5470,12 @@ gremlin> g.V().
project(<span class="string"><span class="delimiter">'</span><span class="content">name</span><span class="delimiter">'</span></span>,<span class="string"><span class="delimiter">'</span><span class="content">component</span><span class="delimiter">'</span></span>).
by(<span class="string"><span class="delimiter">'</span><span class="content">name</span><span class="delimiter">'</span></span>).
by(<span class="string"><span class="delimiter">'</span><span class="content">component</span><span class="delimiter">'</span></span>)
-==>[<span class="key">name</span>:josh,<span class="key">component</span>:<span class="integer">1</span>]
-==>[<span class="key">name</span>:marko,<span class="key">component</span>:<span class="integer">1</span>]
-==>[<span class="key">name</span>:vadas,<span class="key">component</span>:<span class="integer">1</span>]
-==>[<span class="key">name</span>:ripple,<span class="key">component</span>:<span class="integer">1</span>]
==>[<span class="key">name</span>:peter,<span class="key">component</span>:<span class="integer">1</span>]
==>[<span class="key">name</span>:lop,<span class="key">component</span>:<span class="integer">1</span>]
+==>[<span class="key">name</span>:vadas,<span class="key">component</span>:<span class="integer">1</span>]
+==>[<span class="key">name</span>:marko,<span class="key">component</span>:<span class="integer">1</span>]
+==>[<span class="key">name</span>:ripple,<span class="key">component</span>:<span class="integer">1</span>]
+==>[<span class="key">name</span>:josh,<span class="key">component</span>:<span class="integer">1</span>]
gremlin> g.V().hasLabel(<span class="string"><span class="delimiter">'</span><span class="content">person</span><span class="delimiter">'</span></span>).
connectedComponent().
with(ConnectedComponent.propertyName, <span class="string"><span class="delimiter">'</span><span class="content">component</span><span class="delimiter">'</span></span>).
@@ -5483,10 +5483,10 @@ gremlin> g.V().hasLabel(<span class="
project(<span class="string"><span class="delimiter">'</span><span class="content">name</span><span class="delimiter">'</span></span>,<span class="string"><span class="delimiter">'</span><span class="content">component</span><span class="delimiter">'</span></span>).
by(<span class="string"><span class="delimiter">'</span><span class="content">name</span><span class="delimiter">'</span></span>).
by(<span class="string"><span class="delimiter">'</span><span class="content">component</span><span class="delimiter">'</span></span>)
+==>[<span class="key">name</span>:peter,<span class="key">component</span>:<span class="integer">6</span>]
==>[<span class="key">name</span>:marko,<span class="key">component</span>:<span class="integer">1</span>]
==>[<span class="key">name</span>:vadas,<span class="key">component</span>:<span class="integer">1</span>]
-==>[<span class="key">name</span>:josh,<span class="key">component</span>:<span class="integer">1</span>]
-==>[<span class="key">name</span>:peter,<span class="key">component</span>:<span class="integer">6</span>]</code></pre>
+==>[<span class="key">name</span>:josh,<span class="key">component</span>:<span class="integer">1</span>]</code></pre>
</div>
</div>
</div>
@@ -5532,10 +5532,10 @@ configuration keys from the <code>Connec
steps like <a href="#choose-step"><code>choose()</code>-step</a> or <a href="#coalesce-step"><code>coalesce()</code>-step</a>.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-57" type="radio" name="radio-set-1578573570-57" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-57" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-58" type="radio" name="radio-set-1578573570-57" class="tab-selector-2" />
- <label for="tab-1578573570-58" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-57" type="radio" name="radio-set-1580479264-57" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-57" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-58" type="radio" name="radio-set-1580479264-57" class="tab-selector-2" />
+ <label for="tab-1580479264-58" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5605,10 +5605,10 @@ g.V().coalesce(
<p>The <code>count()</code>-step (<strong>map</strong>) counts the total number of represented traversers in the streams (i.e. the bulk count).</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-59" type="radio" name="radio-set-1578573570-59" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-59" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-60" type="radio" name="radio-set-1578573570-59" class="tab-selector-2" />
- <label for="tab-1578573570-60" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-59" type="radio" name="radio-set-1580479264-59" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-59" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-60" type="radio" name="radio-set-1580479264-59" class="tab-selector-2" />
+ <label for="tab-1580479264-60" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5684,10 +5684,10 @@ analyzes the path of the traverser thus
traversal computation. If non-cyclic behavior is desired, see <a href="#simplepath-step"><code>simplePath()</code></a>.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-61" type="radio" name="radio-set-1578573570-61" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-61" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-62" type="radio" name="radio-set-1578573570-61" class="tab-selector-2" />
- <label for="tab-1578573570-62" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-61" type="radio" name="radio-set-1580479264-61" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-61" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-62" type="radio" name="radio-set-1580479264-61" class="tab-selector-2" />
+ <label for="tab-1580479264-62" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5755,10 +5755,10 @@ g.V(<span class="integer">1</span>).as(<
traverser’s bulk is greater than 1, then it is set to 1 before being emitted.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-63" type="radio" name="radio-set-1578573570-63" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-63" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-64" type="radio" name="radio-set-1578573570-63" class="tab-selector-2" />
- <label for="tab-1578573570-64" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-63" type="radio" name="radio-set-1580479264-63" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-63" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-64" type="radio" name="radio-set-1580479264-63" class="tab-selector-2" />
+ <label for="tab-1580479264-64" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5801,10 +5801,10 @@ g.V(<span class="integer">1</span>).repe
has been seen or not.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-65" type="radio" name="radio-set-1578573570-65" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-65" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-66" type="radio" name="radio-set-1578573570-65" class="tab-selector-2" />
- <label for="tab-1578573570-66" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-65" type="radio" name="radio-set-1580479264-65" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-65" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-66" type="radio" name="radio-set-1580479264-65" class="tab-selector-2" />
+ <label for="tab-1580479264-66" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5839,10 +5839,10 @@ g.V().dedup().by(label).values(<span cla
to the current traverser object, but to the path history of the traverser.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-67" type="radio" name="radio-set-1578573570-67" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-67" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-68" type="radio" name="radio-set-1578573570-67" class="tab-selector-2" />
- <label for="tab-1578573570-68" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-67" type="radio" name="radio-set-1580479264-67" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-67" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-68" type="radio" name="radio-set-1580479264-67" class="tab-selector-2" />
+ <label for="tab-1580479264-68" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5901,10 +5901,10 @@ g.V().as(<span class="string"><span clas
is a filter step because the traversal yields no outgoing objects.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-69" type="radio" name="radio-set-1578573570-69" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-69" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-70" type="radio" name="radio-set-1578573570-69" class="tab-selector-2" />
- <label for="tab-1578573570-70" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-69" type="radio" name="radio-set-1580479264-69" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-69" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-70" type="radio" name="radio-set-1580479264-69" class="tab-selector-2" />
+ <label for="tab-1580479264-70" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -5957,10 +5957,10 @@ g.V()</code></pre>
<p>The <code>elementMap()</code>-step yields a <code>Map</code> representation of the structure of an element.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-71" type="radio" name="radio-set-1578573570-71" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-71" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-72" type="radio" name="radio-set-1578573570-71" class="tab-selector-2" />
- <label for="tab-1578573570-72" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-71" type="radio" name="radio-set-1580479264-71" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-71" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-72" type="radio" name="radio-set-1580479264-71" class="tab-selector-2" />
+ <label for="tab-1580479264-72" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6016,10 +6016,10 @@ then only the first item encountered wil
assumption should serve the greatest number of use cases.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-73" type="radio" name="radio-set-1578573570-73" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-73" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-74" type="radio" name="radio-set-1578573570-73" class="tab-selector-2" />
- <label for="tab-1578573570-74" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-73" type="radio" name="radio-set-1580479264-73" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-73" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-74" type="radio" name="radio-set-1580479264-73" class="tab-selector-2" />
+ <label for="tab-1580479264-74" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6103,10 +6103,10 @@ traversal strategy being applied. The se
post strategy application. The final traversal is the resultant execution plan.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-75" type="radio" name="radio-set-1578573570-75" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-75" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-76" type="radio" name="radio-set-1578573570-75" class="tab-selector-2" />
- <label for="tab-1578573570-76" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-75" type="radio" name="radio-set-1580479264-75" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-75" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-76" type="radio" name="radio-set-1580479264-75" class="tab-selector-2" />
+ <label for="tab-1580479264-76" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6159,10 +6159,10 @@ that is a function of the aggregate. The
<a href="#unfold-step"><code>unfold()</code></a>-step for the inverse functionality.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-77" type="radio" name="radio-set-1578573570-77" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-77" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-78" type="radio" name="radio-set-1578573570-77" class="tab-selector-2" />
- <label for="tab-1578573570-78" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-77" type="radio" name="radio-set-1580479264-77" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-77" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-78" type="radio" name="radio-set-1580479264-77" class="tab-selector-2" />
+ <label for="tab-1580479264-78" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6286,10 +6286,10 @@ means by which they are added. The gener
<p>The <code>V()</code>-step is usually used to start a <code>GraphTraversal</code>, but can also be used mid-traversal.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-79" type="radio" name="radio-set-1578573570-79" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-79" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-80" type="radio" name="radio-set-1578573570-79" class="tab-selector-2" />
- <label for="tab-1578573570-80" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-79" type="radio" name="radio-set-1580479264-79" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-79" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-80" type="radio" name="radio-set-1580479264-79" class="tab-selector-2" />
+ <label for="tab-1580479264-80" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6330,10 +6330,10 @@ Whether a mid-traversal <code>V()</code>
</table>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-81" type="radio" name="radio-set-1578573570-81" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-81" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-82" type="radio" name="radio-set-1578573570-81" class="tab-selector-2" />
- <label for="tab-1578573570-82" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-81" type="radio" name="radio-set-1580479264-81" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-81" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-82" type="radio" name="radio-set-1580479264-81" class="tab-selector-2" />
+ <label for="tab-1580479264-82" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6388,10 +6388,10 @@ organizes the objects according to some
reduced. An example is provided below.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-83" type="radio" name="radio-set-1578573570-83" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-83" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-84" type="radio" name="radio-set-1578573570-83" class="tab-selector-2" />
- <label for="tab-1578573570-84" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-83" type="radio" name="radio-set-1580479264-83" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-83" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-84" type="radio" name="radio-set-1580479264-83" class="tab-selector-2" />
+ <label for="tab-1580479264-84" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6464,10 +6464,10 @@ g.V().group().by(label).by(count()) <spa
</div>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-85" type="radio" name="radio-set-1578573570-85" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-85" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-86" type="radio" name="radio-set-1578573570-85" class="tab-selector-2" />
- <label for="tab-1578573570-86" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-85" type="radio" name="radio-set-1580479264-85" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-85" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-86" type="radio" name="radio-set-1580479264-85" class="tab-selector-2" />
+ <label for="tab-1580479264-86" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6513,10 +6513,10 @@ group the incoming object by.</p>
</div>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-87" type="radio" name="radio-set-1578573570-87" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-87" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-88" type="radio" name="radio-set-1578573570-87" class="tab-selector-2" />
- <label for="tab-1578573570-88" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-87" type="radio" name="radio-set-1580479264-87" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-87" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-88" type="radio" name="radio-set-1580479264-87" class="tab-selector-2" />
+ <label for="tab-1580479264-88" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6596,10 +6596,10 @@ it received to its output. Internal to <
</ul>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-89" type="radio" name="radio-set-1578573570-89" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-89" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-90" type="radio" name="radio-set-1578573570-89" class="tab-selector-2" />
- <label for="tab-1578573570-90" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-89" type="radio" name="radio-set-1580479264-89" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-89" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-90" type="radio" name="radio-set-1580479264-89" class="tab-selector-2" />
+ <label for="tab-1580479264-90" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6729,10 +6729,10 @@ may provide a partial match extension.</
<p>The <code>id()</code>-step (<strong>map</strong>) takes an <code>Element</code> and extracts its identifier from it.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-91" type="radio" name="radio-set-1578573570-91" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-91" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-92" type="radio" name="radio-set-1578573570-91" class="tab-selector-2" />
- <label for="tab-1578573570-92" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-91" type="radio" name="radio-set-1580479264-91" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-91" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-92" type="radio" name="radio-set-1580479264-91" class="tab-selector-2" />
+ <label for="tab-1580479264-92" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6784,10 +6784,10 @@ g.V(<span class="integer">1</span>).prop
the current object to itself.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-93" type="radio" name="radio-set-1578573570-93" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-93" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-94" type="radio" name="radio-set-1578573570-93" class="tab-selector-2" />
- <label for="tab-1578573570-94" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-93" type="radio" name="radio-set-1580479264-93" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-93" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-94" type="radio" name="radio-set-1580479264-93" class="tab-selector-2" />
+ <label for="tab-1580479264-94" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6828,10 +6828,10 @@ available, which can be chosen using the
being the index. The map indexer created a linked hash map in which the index represents the key and the original item is used as the value.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-95" type="radio" name="radio-set-1578573570-95" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-95" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-96" type="radio" name="radio-set-1578573570-95" class="tab-selector-2" />
- <label for="tab-1578573570-96" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-95" type="radio" name="radio-set-1580479264-95" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-95" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-96" type="radio" name="radio-set-1580479264-95" class="tab-selector-2" />
+ <label for="tab-1580479264-96" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6927,10 +6927,10 @@ g.V().hasLabel(<span class="string"><spa
<code>inject()</code>-step (<strong>sideEffect</strong>) exists and a few examples are provided below.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-97" type="radio" name="radio-set-1578573570-97" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-97" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-98" type="radio" name="radio-set-1578573570-97" class="tab-selector-2" />
- <label for="tab-1578573570-98" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-97" type="radio" name="radio-set-1580479264-97" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-97" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-98" type="radio" name="radio-set-1580479264-97" class="tab-selector-2" />
+ <label for="tab-1580479264-98" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -6969,10 +6969,10 @@ g.V(<span class="integer">4</span>).out(
start of the traversal is not a graph object.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-99" type="radio" name="radio-set-1578573570-99" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-99" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-100" type="radio" name="radio-set-1578573570-99" class="tab-selector-2" />
- <label for="tab-1578573570-100" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-99" type="radio" name="radio-set-1580479264-99" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-99" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-100" type="radio" name="radio-set-1580479264-99" class="tab-selector-2" />
+ <label for="tab-1580479264-100" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7331,10 +7331,10 @@ g.io(<span class="string"><span class="d
</table>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-101" type="radio" name="radio-set-1578573570-101" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-101" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-102" type="radio" name="radio-set-1578573570-101" class="tab-selector-2" />
- <label for="tab-1578573570-102" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-101" type="radio" name="radio-set-1580479264-101" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-101" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-102" type="radio" name="radio-set-1580479264-101" class="tab-selector-2" />
+ <label for="tab-1580479264-102" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7403,10 +7403,10 @@ g.V().where(__.in(<span class="string"><
<p>The <code>key()</code>-step (<strong>map</strong>) takes a <code>Property</code> and extracts the key from it.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-103" type="radio" name="radio-set-1578573570-103" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-103" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-104" type="radio" name="radio-set-1578573570-103" class="tab-selector-2" />
- <label for="tab-1578573570-104" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-103" type="radio" name="radio-set-1580479264-103" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-103" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-104" type="radio" name="radio-set-1580479264-103" class="tab-selector-2" />
+ <label for="tab-1580479264-104" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7453,10 +7453,10 @@ g.V(<span class="integer">1</span>).prop
<p>The <code>label()</code>-step (<strong>map</strong>) takes an <code>Element</code> and extracts its label from it.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-105" type="radio" name="radio-set-1578573570-105" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-105" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-106" type="radio" name="radio-set-1578573570-105" class="tab-selector-2" />
- <label for="tab-1578573570-106" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-105" type="radio" name="radio-set-1580479264-105" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-105" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-106" type="radio" name="radio-set-1580479264-105" class="tab-selector-2" />
+ <label for="tab-1580479264-106" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7504,10 +7504,10 @@ g.V(<span class="integer">1</span>).prop
<p>The <code>limit()</code>-step is analogous to <a href="#range-step"><code>range()</code>-step</a> save that the lower end range is set to 0.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-107" type="radio" name="radio-set-1578573570-107" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-107" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-108" type="radio" name="radio-set-1578573570-107" class="tab-selector-2" />
- <label for="tab-1578573570-108" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-107" type="radio" name="radio-set-1580479264-107" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-107" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-108" type="radio" name="radio-set-1580479264-107" class="tab-selector-2" />
+ <label for="tab-1580479264-108" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7538,10 +7538,10 @@ g.V().range(<span class="integer">0</spa
The examples below use the <a href="#the-crew-toy-graph">The Crew</a> toy data set.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-109" type="radio" name="radio-set-1578573570-109" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-109" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-110" type="radio" name="radio-set-1578573570-109" class="tab-selector-2" />
- <label for="tab-1578573570-110" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-109" type="radio" name="radio-set-1580479264-109" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-109" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-110" type="radio" name="radio-set-1580479264-109" class="tab-selector-2" />
+ <label for="tab-1580479264-110" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7605,10 +7605,10 @@ single element within that stream. To do
Note that the examples below use the <a href="#the-crew-toy-graph">The Crew</a> toy data set.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-111" type="radio" name="radio-set-1578573570-111" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-111" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-112" type="radio" name="radio-set-1578573570-111" class="tab-selector-2" />
- <label for="tab-1578573570-112" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-111" type="radio" name="radio-set-1580479264-111" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-111" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-112" type="radio" name="radio-set-1580479264-111" class="tab-selector-2" />
+ <label for="tab-1580479264-112" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7670,10 +7670,10 @@ a âglobal traversalâ with loca
optimizations (i.e. when writing <code>TraversalStrategy</code> implementations. As another example consider:</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-113" type="radio" name="radio-set-1578573570-113" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-113" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-114" type="radio" name="radio-set-1578573570-113" class="tab-selector-2" />
- <label for="tab-1578573570-114" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-113" type="radio" name="radio-set-1580479264-113" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-113" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-114" type="radio" name="radio-set-1580479264-113" class="tab-selector-2" />
+ <label for="tab-1580479264-114" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7740,10 +7740,10 @@ the confines of the vertex’s star
<p>The <code>loops()</code>-step (<strong>map</strong>) extracts the number of times the <code>Traverser</code> has gone through the current loop.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-115" type="radio" name="radio-set-1578573570-115" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-115" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-116" type="radio" name="radio-set-1578573570-115" class="tab-selector-2" />
- <label for="tab-1578573570-116" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-115" type="radio" name="radio-set-1580479264-115" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-115" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-116" type="radio" name="radio-set-1580479264-115" class="tab-selector-2" />
+ <label for="tab-1580479264-116" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7800,10 +7800,10 @@ express via <code>match()</code> than wi
</div>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-117" type="radio" name="radio-set-1578573570-117" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-117" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-118" type="radio" name="radio-set-1578573570-117" class="tab-selector-2" />
- <label for="tab-1578573570-118" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-117" type="radio" name="radio-set-1580479264-117" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-117" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-118" type="radio" name="radio-set-1580479264-117" class="tab-selector-2" />
+ <label for="tab-1580479264-118" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7841,10 +7841,10 @@ express via <code>match()</code> than wi
be arbitrarily defined.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-119" type="radio" name="radio-set-1578573570-119" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-119" class="tab-label-1">console (groovy)</label>
- <input id="tab-1578573570-120" type="radio" name="radio-set-1578573570-119" class="tab-selector-2" />
- <label for="tab-1578573570-120" class="tab-label-2">groovy</label>
+ <input id="tab-1580479264-119" type="radio" name="radio-set-1580479264-119" class="tab-selector-1" checked="checked" />
+ <label for="tab-1580479264-119" class="tab-label-1">console (groovy)</label>
+ <input id="tab-1580479264-120" type="radio" name="radio-set-1580479264-119" class="tab-selector-2" />
+ <label for="tab-1580479264-120" class="tab-label-2">groovy</label>
<div class="tabcontent">
<div class="tabcontent-1">
<div class="listingblock">
@@ -7878,10 +7878,10 @@ be arbitrarily defined.</p>
previous query can thus be written in a more expressive way as shown below.</p>
</div>
<section class="tabs tabs-2">
- <input id="tab-1578573570-121" type="radio" name="radio-set-1578573570-121" class="tab-selector-1" checked="checked" />
- <label for="tab-1578573570-121" class="tab-label-1">console (groovy)</label>
[... 3294 lines stripped ...]