You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@nutch.apache.org by Sebastian Nagel <sn...@apache.org> on 2026/09/08 10:37:49 UTC

CVE-2026-41871: Apache Nutch: Unauthenticated reflection-based job execution in Nutch Server (Nutch REST API)

Severity: important 

Affected versions:

- Apache Nutch 1.10 through 1.22

Description:

Missing Authorization, Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Nutch Server  (Nutch REST API).



This issue affects Apache Nutch: from 1.10 through 1.22.



Users are recommended to upgrade to version 1.23, which removes the Nutch Server.
If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only.
Please, also visit the  Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

This issue is being tracked as NUTCH-3165 

Credit:

The Apache Nutch Project Management Committee would like to thank Th1nk for reporting this issue. (finder)

References:

https://nutch.apache.org/
https://www.cve.org/CVERecord?id=CVE-2026-41871
https://issues.apache.org/jira/browse/NUTCH-3165