You are viewing a plain text version of this content. The canonical link for it is here.
Posted to cvs@httpd.apache.org by lg...@apache.org on 2014/04/27 15:56:10 UTC

svn commit: r1590396 - in /httpd/httpd/trunk/docs/manual: compliance.xml.fr expr.xml.fr mod/core.xml.fr mod/mod_authnz_ldap.xml.fr mod/mod_authz_host.xml.fr mod/mod_ldap.xml.fr mod/mod_rewrite.xml.fr

Author: lgentis
Date: Sun Apr 27 13:56:09 2014
New Revision: 1590396

URL: http://svn.apache.org/r1590396
Log:
Updates.

Modified:
    httpd/httpd/trunk/docs/manual/compliance.xml.fr
    httpd/httpd/trunk/docs/manual/expr.xml.fr
    httpd/httpd/trunk/docs/manual/mod/core.xml.fr
    httpd/httpd/trunk/docs/manual/mod/mod_authnz_ldap.xml.fr
    httpd/httpd/trunk/docs/manual/mod/mod_authz_host.xml.fr
    httpd/httpd/trunk/docs/manual/mod/mod_ldap.xml.fr
    httpd/httpd/trunk/docs/manual/mod/mod_rewrite.xml.fr

Modified: httpd/httpd/trunk/docs/manual/compliance.xml.fr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/compliance.xml.fr?rev=1590396&r1=1590395&r2=1590396&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/compliance.xml.fr (original)
+++ httpd/httpd/trunk/docs/manual/compliance.xml.fr Sun Apr 27 13:56:09 2014
@@ -1,7 +1,7 @@
 <?xml version="1.0" encoding="ISO-8859-1" ?>
 <!DOCTYPE manualpage SYSTEM "./style/manualpage.dtd">
 <?xml-stylesheet type="text/xsl" href="./style/manual.fr.xsl"?>
-<!-- English Revision : 1242907 -->
+<!-- English Revision : 1590372 -->
 <!-- French translation : Lucien GENTIS -->
 <!-- Reviewed by : Vincent Deffontaines -->
 
@@ -225,7 +225,7 @@
 
     <p>De nombreuses m&eacute;thodes pour d&eacute;terminer la taille d'un
     corps de r&eacute;ponse sont d&eacute;crites dans la <a
-    href="http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec4.4">RFC2616
+    href="http://www.w3.org/Protocols/rfc2616/rfc2616-sec4.html#sec4.4">RFC2616
     section 4.4 Message Length</a>.</p>
 
     <p>Lorsque l'en-t&ecirc;te <code>Content-Length</code> est pr&eacute;sente, la
@@ -283,7 +283,7 @@
 
     <p>Le type de media du corps est plac&eacute; dans une en-t&ecirc;te
     <code>Content-Type</code> dont le format est d&eacute;crit en d&eacute;tail dans
-    la <a href="http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec3.7">
+    la <a href="http://www.w3.org/Protocols/rfc2616/rfc2616-sec3.html#sec3.7">
     RFC2616 section 3.7 Media Types</a>.</p>
 
     <p>Une en-t&ecirc;te <code>Content-Type</code> dont la syntaxe est valide
@@ -328,7 +328,7 @@
 
     <p>De nombreuses mani&egrave;res pour d&eacute;terminer la taille d'un
     corps de r&eacute;ponse sont d&eacute;crites dans la <a
-    href="http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec4.4">RFC2616
+    href="http://www.w3.org/Protocols/rfc2616/rfc2616-sec4.html#sec4.4">RFC2616
     section 4.4 Message Length</a>.</p>
 
     <p>Pour indiquer la fin de la r&eacute;ponse au client sans que ce dernier
@@ -403,7 +403,7 @@
 
     <p>Vous trouverez tous les d&eacute;tails &agrave; propos du calcul d'une dur&eacute;e de
     fra&icirc;cheur dans la <a
-    href="http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec13.2">RFC2616
+    href="http://www.w3.org/Protocols/rfc2616/rfc2616-sec13.html#sec13.2">RFC2616
     section 13.2 Expiration Model</a>.</p>
 
     <p>Pendant la dur&eacute;e de fra&icirc;cheur, un cache n'a pas besoin de

Modified: httpd/httpd/trunk/docs/manual/expr.xml.fr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/expr.xml.fr?rev=1590396&r1=1590395&r2=1590396&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/expr.xml.fr (original)
+++ httpd/httpd/trunk/docs/manual/expr.xml.fr Sun Apr 27 13:56:09 2014
@@ -1,7 +1,7 @@
 <?xml version="1.0" encoding="ISO-8859-1" ?>
 <!DOCTYPE manualpage SYSTEM "./style/manualpage.dtd">
 <?xml-stylesheet type="text/xsl" href="./style/manual.fr.xsl"?>
-<!-- English Revision : 1575406 -->
+<!-- English Revision : 1589993 -->
 <!-- French translation : Lucien GENTIS -->
 <!-- Reviewed by : Vincent Deffontaines -->
 
@@ -62,6 +62,7 @@
 <seealso><a href="mod/mod_authnz_ldap.html#reqdn">Require ldap-dn</a></seealso>
 <seealso><a href="mod/mod_authnz_ldap.html#reqattribute">Require ldap-attribute</a></seealso>
 <seealso><a href="mod/mod_authnz_ldap.html#reqfilter">Require ldap-filter</a></seealso>
+<seealso><a href="mod/mod_authnz_ldap.html#reqsearch">Require ldap-search</a></seealso>
 <seealso><a href="mod/mod_authz_dbd.html#reqgroup">Require dbd-group</a></seealso>
 <seealso><a href="mod/mod_authz_dbm.html#reqgroup">Require dbm-group</a></seealso>
 <seealso><a href="mod/mod_authz_groupfile.html#reqgroup">Require group</a></seealso>
@@ -535,7 +536,12 @@ listfunction ::= listfuncname "<strong>(
         <td>Lit le contenu d'un fichier</td><td>oui</td></tr>
     <tr><td><code>filesize</code></td>
         <td>Renvoie la taille d'un fichier (ou 0 si le fichier n'existe
-	pas ou ne correspond pas &agrave; un fichier r&eacute;gulier)</td><td>oui</td></tr>
+	pas ou ne correspond pas &agrave; un fichier
+	r&eacute;gulier)</td><td>oui</td></tr>
+    <tr><td><code>ldap</code></td>
+        <td>Echappe les caract&egrave;res selon la RFC4514 (Echappement des
+	noms distinctifs LDAP - DN) et la RFC4515 (Echappement des
+	filtres LDAP).</td><td></td></tr>
 
     </table>
 

Modified: httpd/httpd/trunk/docs/manual/mod/core.xml.fr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/core.xml.fr?rev=1590396&r1=1590395&r2=1590396&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/core.xml.fr (original)
+++ httpd/httpd/trunk/docs/manual/mod/core.xml.fr Sun Apr 27 13:56:09 2014
@@ -1,7 +1,7 @@
 <?xml version="1.0"?>
 <!DOCTYPE modulesynopsis SYSTEM "../style/modulesynopsis.dtd">
 <?xml-stylesheet type="text/xsl" href="../style/manual.fr.xsl"?>
-<!-- English Revision : 1585829 -->
+<!-- English Revision : 1590310 -->
 <!-- French translation : Lucien GENTIS -->
 <!-- Reviewed by : Vincent Deffontaines -->
 
@@ -2100,7 +2100,7 @@ host</context>
     <p>serait satisfaite pour les requ&ecirc;tes HTTP/1.0 sans en-t&ecirc;te
     <var>Host:</var>. Les expressions peuvent contenir diff&eacute;rents
     op&eacute;rateurs de type shell pour la comparaison de cha&icirc;nes
-    (<code>=</code>, <code>!=</code>, <code>&lt;</code>, ...), la
+    (<code>==</code>, <code>!=</code>, <code>&lt;</code>, ...), la
     comparaison d'entiers (<code>-eq</code>, <code>-ne</code>, ...), ou
     &agrave; usages divers (<code>-n</code>, <code>-z</code>, <code>-f</code>,
     ...). Les expressions rationnelles sont aussi support&eacute;es,</p>

Modified: httpd/httpd/trunk/docs/manual/mod/mod_authnz_ldap.xml.fr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/mod_authnz_ldap.xml.fr?rev=1590396&r1=1590395&r2=1590396&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/mod_authnz_ldap.xml.fr (original)
+++ httpd/httpd/trunk/docs/manual/mod/mod_authnz_ldap.xml.fr Sun Apr 27 13:56:09 2014
@@ -1,7 +1,7 @@
 <?xml version="1.0"?>
 <!DOCTYPE modulesynopsis SYSTEM "../style/modulesynopsis.dtd">
 <?xml-stylesheet type="text/xsl" href="../style/manual.fr.xsl"?>
-<!-- English Revision : 1587325 -->
+<!-- English Revision : 1589993 -->
 <!-- French translation : Lucien GENTIS -->
 <!-- Reviewed by : Vincent Deffontaines -->
 
@@ -90,6 +90,7 @@ HTTP de base.</description>
           <li><a href="#reqdn">Require ldap-dn</a></li>
           <li><a href="#reqattribute">Require ldap-attribute</a></li>
           <li><a href="#reqfilter">Require ldap-filter</a></li>
+	  <li><a href="#reqsearch">Require ldap-search</a></li>
         </ul>
       </li>
 
@@ -245,6 +246,12 @@ HTTP de base.</description>
       utilisateur unique qui corresponde au DN de l'utilisateur
       authentifi&eacute;.</li>
 
+      <li>Avec la directive <a href="#reqsearch">
+      <code>Require ldap-search</code></a>, l'autorisation d'acc&egrave;s
+      est accord&eacute;e si le filtre de recherche renvoie avec succ&egrave;s
+      un seul objet correspondant aux crit&egrave;res avec tout nom distinctif
+      (DN).</li>
+
       <li>dans tous les autres cas, refus ou restriction de
       l'acc&egrave;s.</li>
     </ul>
@@ -551,6 +558,43 @@ AuthLDAPMaxSubGroupDepth 1
     <code>ldap-filter</code>, en particulier dans le cas d'un annuaire
     LDAP de grande taille.</p>
 
+    <p>Lorsqu'on utilise une <a href="../expr.html">expression
+    rationnelle</a> au sein d'un filtre, il faut bien s'assurer que les
+    filtres LDAP sont correctement &eacute;chapp&eacute;s afin de se pr&eacute;munir contre
+    toute injection LDAP. A cet effet, il est possible d'utiliser la
+    fonction ldap.</p>
+
+<highlight language="config">
+&lt;LocationMatch ^/dav/(?<SITENAME>[^/]+)/&gt;
+  Require ldap-filter (memberOf=cn=%{ldap:%{unescape:%{env:MATCH_SITENAME}},ou=Websites,o=Example)
+&lt;/LocationMatch&gt;
+</highlight>
+
+</section>
+
+<section id="reqsearch"><title>Require ldap-search</title>
+
+    <p>La directive <code>Require ldap-search</code> permet &agrave;
+    l'administrateur d'autoriser l'acc&egrave;s en fonction d'un filtre de
+    recherche LDAP g&eacute;n&eacute;rique contenant une <a
+    href="../expr.html">expression rationnelle</a>. Si le filtre de
+    recherche renvoie une et une seule correspondance, l'acc&egrave;s est
+    accord&eacute; sans tenir compte du DN.</p>
+
+    <p>La directive suivante accorderait l'acc&egrave;s aux URLs correspondant
+    aux objets sp&eacute;cifi&eacute;s dans le serveur LDAP :</p>
+
+<highlight language="config">
+&lt;LocationMatch ^/dav/(?<SITENAME>[^/]+)/&gt;
+Require ldap-search (cn=%{ldap:%{unescape:%{env:MATCH_SITENAME}} Website)
+&lt;/LocationMatch&gt;
+</highlight>
+
+    <p>Note : il faut bien s'assurer que les
+    expressions sont correctement &eacute;chapp&eacute;s afin de se pr&eacute;munir contre
+    toute injection LDAP. A cet effet, il est possible d'utiliser la
+    fonction <strong>ldap</strong> comme dans l'exemple ci-dessus.</p>
+
 </section>
 
 </section>

Modified: httpd/httpd/trunk/docs/manual/mod/mod_authz_host.xml.fr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/mod_authz_host.xml.fr?rev=1590396&r1=1590395&r2=1590396&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/mod_authz_host.xml.fr (original)
+++ httpd/httpd/trunk/docs/manual/mod/mod_authz_host.xml.fr Sun Apr 27 13:56:09 2014
@@ -1,7 +1,7 @@
 <?xml version="1.0"?>
 <!DOCTYPE modulesynopsis SYSTEM "../style/modulesynopsis.dtd">
 <?xml-stylesheet type="text/xsl" href="../style/manual.fr.xsl"?>
-<!-- English Revision: 1554188:1587032 (outdated) -->
+<!-- English Revision : 1587032 -->
 <!-- French translation : Lucien GENTIS -->
 <!-- Reviewed by : Vincent Deffontaines -->
 
@@ -74,7 +74,7 @@ contr&ocirc;le d'acc&egrave;s</a></seeal
     l'acc&egrave;s en fonction du nom d'h&ocirc;te, de l'adresse IP, ou d'un intervalle
     d'adresses IP.</p>
 
-    <p>A partir de la version 2.5.0, les directives require host
+    <p>A partir de la version 2.4.8, les directives require host
     supportent les <a href="../expr.html">expressions</a>.</p>
 
 <section id="reqip"><title>Require ip</title>
@@ -166,6 +166,7 @@ Require host .net example.edu
 </section>
 
 <section id="reqlocal"><title>Require local</title>
+
     <p>Le fournisseur <code>local</code> autorise l'acc&egrave;s au serveur si
     l'une au moins de ces conditions est satisfaite :</p>
 

Modified: httpd/httpd/trunk/docs/manual/mod/mod_ldap.xml.fr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/mod_ldap.xml.fr?rev=1590396&r1=1590395&r2=1590396&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/mod_ldap.xml.fr (original)
+++ httpd/httpd/trunk/docs/manual/mod/mod_ldap.xml.fr Sun Apr 27 13:56:09 2014
@@ -1,7 +1,7 @@
 <?xml version="1.0"?>
 <!DOCTYPE modulesynopsis SYSTEM "../style/modulesynopsis.dtd">
 <?xml-stylesheet type="text/xsl" href="../style/manual.fr.xsl"?>
-<!-- English Revision: 1521346:1587097 (outdated) -->
+<!-- English Revision : 1587097 -->
 <!-- French translation : Lucien GENTIS -->
 <!-- Reviewed by : Vincent Deffontaines -->
 
@@ -544,7 +544,7 @@ LDAP.</description>
 <override>AuthConfig</override>
 
 <usage>
-    <p>Si elle est activ&eacute;e par la directive <code>LDAPReferrals</code>,
+    <p>Si elle est activ&eacute;e par la directive <directive>LDAPReferrals</directive>,
     cette directive permet de d&eacute;finir le nombre maximum de sauts vers
     des serveurs alternatifs (referrals) avant l'abandon de la requ&ecirc;te
     LDAP.</p>
@@ -559,10 +559,12 @@ LDAP.</description>
 <name>LDAPReferrals</name>
 <description>Active la redirection vers des serveurs alternatifs au
 cours des requ&ecirc;tes vers le serveur LDAP.</description>
-<syntax>LDAPReferrals On|Off|default</syntax>
+<syntax>LDAPReferrals <var>On|Off|default</var></syntax>
 <default>LDAPReferrals On</default>
 <contextlist><context>directory</context><context>.htaccess</context></contextlist>
 <override>AuthConfig</override>
+<compatibility>Le param&egrave;tre <var>default</var> est disponible depuis la
+version 2.4.7 du serveur HTTP Apache.</compatibility>
 
 <usage>
     <p>Certains serveurs LDAP partagent leur annuaire en plusieurs
@@ -592,7 +594,7 @@ cours des requ&ecirc;tes vers le serveur
      "hop limit" du SDK, et aucun "LDAP rebind callback" n'est enregistr&eacute;.</p></dd>
     </dl>
     
-    <p>La directive <code>LDAPReferralHopLimit</code> travaille en
+    <p>La directive <directive>LDAPReferralHopLimit</directive> travaille en
     conjonction avec cette directive pour limiter le nombre de
     redirections &agrave; suivre pour achever le traitement de la requ&ecirc;te LDAP.
     Lorsque le processus de redirection est activ&eacute; par la valeur "On",

Modified: httpd/httpd/trunk/docs/manual/mod/mod_rewrite.xml.fr
URL: http://svn.apache.org/viewvc/httpd/httpd/trunk/docs/manual/mod/mod_rewrite.xml.fr?rev=1590396&r1=1590395&r2=1590396&view=diff
==============================================================================
--- httpd/httpd/trunk/docs/manual/mod/mod_rewrite.xml.fr (original)
+++ httpd/httpd/trunk/docs/manual/mod/mod_rewrite.xml.fr Sun Apr 27 13:56:09 2014
@@ -1,7 +1,7 @@
 <?xml version="1.0"?>
 <!DOCTYPE modulesynopsis SYSTEM "../style/modulesynopsis.dtd">
 <?xml-stylesheet type="text/xsl" href="../style/manual.fr.xsl"?>
-<!-- English Revision: 1586452:1587032 (outdated) -->
+<!-- English Revision : 1587032 -->
 <!-- French translation : Lucien GENTIS -->
 <!-- Reviewed by : Vincent Deffontaines -->
 
@@ -580,6 +580,8 @@ la r&eacute;&eacute;criture soit effectu
                  IS_SUBREQ<br />
                  HTTPS<br />
 		 REQUEST_SCHEME<br />
+		 REMOTE_ADDR<br />
+                 CONN_REMOTE_ADDR<br />
               </td>
             </tr>
           </table>