You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by Jay Guo <gu...@gmail.com> on 2017/01/06 06:43:16 UTC

Review Request 55252: Added `_getRoles()` to extract some logic of `getRoles()`.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55252/
-----------------------------------------------------------

Review request for mesos, Anand Mazumdar, Benjamin Bannier, Benjamin Mahler, and Guangya Liu.


Bugs: MESOS-6855
    https://issues.apache.org/jira/browse/MESOS-6855


Repository: mesos


Description
-------

To add 'roles' section in `/state` endpoint, some of the logic in
`getRoles()` could be reused. This patch added `_getRoles()` method
to extract that logic away from `getRoles()`.


Diffs
-----

  src/master/http.cpp 75dcd6199dbfcca6260baed49b838a45312bb667 
  src/master/master.hpp 57fc6e6f2995078df80f0aa52707727db802ede0 

Diff: https://reviews.apache.org/r/55252/diff/


Testing
-------


Thanks,

Jay Guo


Re: Review Request 55252: Moved some logic from `Master::Http::_roles` into `filterRoles`.

Posted by Jay Guo <gu...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55252/
-----------------------------------------------------------

(Updated March 14, 2017, 6:29 p.m.)


Review request for mesos, Benjamin Mahler and Michael Park.


Summary (updated)
-----------------

Moved some logic from `Master::Http::_roles` into `filterRoles`.


Bugs: MESOS-6855
    https://issues.apache.org/jira/browse/MESOS-6855


Repository: mesos


Description (updated)
-------

Moved some logic in `Master::Http::_roles` into a new method
`filterRoles`, which could be reused by `Master::Http::state`.


Diffs (updated)
-----

  src/master/http.cpp 862b68ff2e8846d6fb968556a6612ec7dab2a61a 
  src/master/master.hpp d92c8adef79d997f255cf26ebd10ab0e87da8413 


Diff: https://reviews.apache.org/r/55252/diff/3/

Changes: https://reviews.apache.org/r/55252/diff/2-3/


Testing
-------


Thanks,

Jay Guo


Re: Review Request 55252: Refactored `roles()` and `getRoles()` to reuse common logic.

Posted by Jay Guo <gu...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55252/
-----------------------------------------------------------

(Updated Jan. 16, 2017, 2:30 p.m.)


Review request for mesos, Anand Mazumdar, Benjamin Bannier, Benjamin Mahler, and Guangya Liu.


Changes
-------

rebase and squashed previous patch into this one to make the review more readable.


Summary (updated)
-----------------

Refactored `roles()` and `getRoles()` to reuse common logic.


Bugs: MESOS-6855
    https://issues.apache.org/jira/browse/MESOS-6855


Repository: mesos


Description (updated)
-------

Some common logic are extracted into two new methods `filterRoles`
and `_getRoles`, which can be reused by both v0 and v1 APIs. This
is a step toward adding 'roles' section into '/state' endpoint.


Diffs (updated)
-----

  src/master/http.cpp a44621f39cb059e654a56f57f75b38947f3a4230 
  src/master/master.hpp 44f4fecb1fbe8bebf830990a59a5462338e6e004 

Diff: https://reviews.apache.org/r/55252/diff/


Testing
-------


Thanks,

Jay Guo