You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@manifoldcf.apache.org by "Karl Wright (Created) (JIRA)" <ji...@apache.org> on 2011/12/29 17:11:34 UTC

[jira] [Created] (CONNECTORS-346) Testing hierarchy needs work

Testing hierarchy needs work
----------------------------

                 Key: CONNECTORS-346
                 URL: https://issues.apache.org/jira/browse/CONNECTORS-346
             Project: ManifoldCF
          Issue Type: Task
          Components: Tests
            Reporter: Karl Wright


The testing hierarchy is in need of some work.  Specifically:
- Load tests should be pulled back into the "tests" directory, if possible, and given a suffix (LT?) which allows Maven to skip them by default.  This will simplify the ant build.xml too.
- Final ant targets (test-dr, load-dr, UI, etc.) need to be regularized.  They all should begin with "test", for one thing.  I don't yet have a proposal though.
- There's a lot of code duplication in the hierarchy and across the different database base classes.  For example, methods that talk with the API appear in the base class for each database, and could be shared if there was such a thing as multiple inheritance.  Since there isn't we could instead pull these into their own support class, like HTMLTester does for the UI stuff.


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CONNECTORS-346) Testing hierarchy needs work

Posted by "Karl Wright (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CONNECTORS-346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13177615#comment-13177615 ] 

Karl Wright commented on CONNECTORS-346:
----------------------------------------

r1225802 to reorganize base classes to remove duplicated code.

                
> Testing hierarchy needs work
> ----------------------------
>
>                 Key: CONNECTORS-346
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-346
>             Project: ManifoldCF
>          Issue Type: Task
>          Components: Tests
>            Reporter: Karl Wright
>            Assignee: Karl Wright
>             Fix For: ManifoldCF 0.5
>
>
> The testing hierarchy is in need of some work.  Specifically:
> - Load tests should be pulled back into the "tests" directory, if possible, and given a suffix (LT?) which allows Maven to skip them by default.  This will simplify the ant build.xml too.
> - Final ant targets (test-dr, load-dr, UI, etc.) need to be regularized.  They all should begin with "test", for one thing.  I don't yet have a proposal though.
> - There's a lot of code duplication in the hierarchy and across the different database base classes.  For example, methods that talk with the API appear in the base class for each database, and could be shared if there was such a thing as multiple inheritance.  Since there isn't we could instead pull these into their own support class, like HTMLTester does for the UI stuff.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CONNECTORS-346) Testing hierarchy needs work

Posted by "Karl Wright (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CONNECTORS-346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13177393#comment-13177393 ] 

Karl Wright commented on CONNECTORS-346:
----------------------------------------

r1225655 for pulling loadtests out of their own hierarchy into the integration test hierarchy.

                
> Testing hierarchy needs work
> ----------------------------
>
>                 Key: CONNECTORS-346
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-346
>             Project: ManifoldCF
>          Issue Type: Task
>          Components: Tests
>            Reporter: Karl Wright
>            Assignee: Karl Wright
>             Fix For: ManifoldCF 0.5
>
>
> The testing hierarchy is in need of some work.  Specifically:
> - Load tests should be pulled back into the "tests" directory, if possible, and given a suffix (LT?) which allows Maven to skip them by default.  This will simplify the ant build.xml too.
> - Final ant targets (test-dr, load-dr, UI, etc.) need to be regularized.  They all should begin with "test", for one thing.  I don't yet have a proposal though.
> - There's a lot of code duplication in the hierarchy and across the different database base classes.  For example, methods that talk with the API appear in the base class for each database, and could be shared if there was such a thing as multiple inheritance.  Since there isn't we could instead pull these into their own support class, like HTMLTester does for the UI stuff.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CONNECTORS-346) Testing hierarchy needs work

Posted by "Karl Wright (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CONNECTORS-346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13177607#comment-13177607 ] 

Karl Wright commented on CONNECTORS-346:
----------------------------------------

r1225781 to un-Derby-fy the base class names, so agnostic base classes can be introduced.

                
> Testing hierarchy needs work
> ----------------------------
>
>                 Key: CONNECTORS-346
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-346
>             Project: ManifoldCF
>          Issue Type: Task
>          Components: Tests
>            Reporter: Karl Wright
>            Assignee: Karl Wright
>             Fix For: ManifoldCF 0.5
>
>
> The testing hierarchy is in need of some work.  Specifically:
> - Load tests should be pulled back into the "tests" directory, if possible, and given a suffix (LT?) which allows Maven to skip them by default.  This will simplify the ant build.xml too.
> - Final ant targets (test-dr, load-dr, UI, etc.) need to be regularized.  They all should begin with "test", for one thing.  I don't yet have a proposal though.
> - There's a lot of code duplication in the hierarchy and across the different database base classes.  For example, methods that talk with the API appear in the base class for each database, and could be shared if there was such a thing as multiple inheritance.  Since there isn't we could instead pull these into their own support class, like HTMLTester does for the UI stuff.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Resolved] (CONNECTORS-346) Testing hierarchy needs work

Posted by "Karl Wright (Resolved) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CONNECTORS-346?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Karl Wright resolved CONNECTORS-346.
------------------------------------

    Resolution: Fixed

r1226141 completes the changes


                
> Testing hierarchy needs work
> ----------------------------
>
>                 Key: CONNECTORS-346
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-346
>             Project: ManifoldCF
>          Issue Type: Task
>          Components: Tests
>            Reporter: Karl Wright
>            Assignee: Karl Wright
>             Fix For: ManifoldCF 0.5
>
>
> The testing hierarchy is in need of some work.  Specifically:
> - Load tests should be pulled back into the "tests" directory, if possible, and given a suffix (LT?) which allows Maven to skip them by default.  This will simplify the ant build.xml too.
> - Final ant targets (test-dr, load-dr, UI, etc.) need to be regularized.  They all should begin with "test", for one thing.  I don't yet have a proposal though.
> - There's a lot of code duplication in the hierarchy and across the different database base classes.  For example, methods that talk with the API appear in the base class for each database, and could be shared if there was such a thing as multiple inheritance.  Since there isn't we could instead pull these into their own support class, like HTMLTester does for the UI stuff.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (CONNECTORS-346) Testing hierarchy needs work

Posted by "Karl Wright (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/CONNECTORS-346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13177527#comment-13177527 ] 

Karl Wright commented on CONNECTORS-346:
----------------------------------------

r1225740 to create a common infrastructure for firing up a ManifoldCF instance.

                
> Testing hierarchy needs work
> ----------------------------
>
>                 Key: CONNECTORS-346
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-346
>             Project: ManifoldCF
>          Issue Type: Task
>          Components: Tests
>            Reporter: Karl Wright
>            Assignee: Karl Wright
>             Fix For: ManifoldCF 0.5
>
>
> The testing hierarchy is in need of some work.  Specifically:
> - Load tests should be pulled back into the "tests" directory, if possible, and given a suffix (LT?) which allows Maven to skip them by default.  This will simplify the ant build.xml too.
> - Final ant targets (test-dr, load-dr, UI, etc.) need to be regularized.  They all should begin with "test", for one thing.  I don't yet have a proposal though.
> - There's a lot of code duplication in the hierarchy and across the different database base classes.  For example, methods that talk with the API appear in the base class for each database, and could be shared if there was such a thing as multiple inheritance.  Since there isn't we could instead pull these into their own support class, like HTMLTester does for the UI stuff.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Updated] (CONNECTORS-346) Testing hierarchy needs work

Posted by "Karl Wright (Updated) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/CONNECTORS-346?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Karl Wright updated CONNECTORS-346:
-----------------------------------

    Fix Version/s: ManifoldCF 0.5
         Assignee: Karl Wright
    
> Testing hierarchy needs work
> ----------------------------
>
>                 Key: CONNECTORS-346
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-346
>             Project: ManifoldCF
>          Issue Type: Task
>          Components: Tests
>            Reporter: Karl Wright
>            Assignee: Karl Wright
>             Fix For: ManifoldCF 0.5
>
>
> The testing hierarchy is in need of some work.  Specifically:
> - Load tests should be pulled back into the "tests" directory, if possible, and given a suffix (LT?) which allows Maven to skip them by default.  This will simplify the ant build.xml too.
> - Final ant targets (test-dr, load-dr, UI, etc.) need to be regularized.  They all should begin with "test", for one thing.  I don't yet have a proposal though.
> - There's a lot of code duplication in the hierarchy and across the different database base classes.  For example, methods that talk with the API appear in the base class for each database, and could be shared if there was such a thing as multiple inheritance.  Since there isn't we could instead pull these into their own support class, like HTMLTester does for the UI stuff.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira