You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@commons.apache.org by Gary Gregory <gg...@seagullsoftware.com> on 2005/01/25 19:43:22 UTC

RE: [lang] 2.1...

Hello All:

I just noticed it's been about a month since the last 2.1 ponderings.
Where do we stand now?

Curious,
Gary

-----Original Message-----
From: Henri Yandell [mailto:flamefew@gmail.com] 
Sent: Friday, December 17, 2004 7:22 PM
To: Jakarta Commons Developers List
Subject: [lang] 2.1...

Sorry for the silence from me. As I've probably said a million times,
baby happened.

I'm full of coding energy, or perhaps the need to 'have coded' that
leads to coding happening and looking to direct some of it to Lang
2.1.

Looking at the wiki and bugzilla, we were nearly there as far as I
recall. Not a lot has cropped up in the 2 months or so that have
passed, couple of bugs I've easily closed out and a couple of trickier
ones.

Gary seems to have taken care of
http://issues.apache.org/bugzilla/show_bug.cgi?id=32625. Is it ready
for closure Gary? Despite Matt Blum's comment on a work-around, it
still sounds like a fine change to the library.

The only other new bug is a note on incorrect javadoc and should be an
easy one: http://issues.apache.org/bugzilla/show_bug.cgi?id=32619.

Stephen listed the following as smelling:

-------
1)
- ArrayUtils.lastIndex()
Gets the last valid index of an array. Surely users would just call
getLength() - 1?

2)
- ClassUtils.CLASS_NAME_COMPARATOR
- ClassUtils.PACKAGE_NAME_COMPARATOR
Although potentially useful, they seem quite specific. What about
comparing
packages using Class objects? (I've never used a Package object in my
work)
Or comparing just the short name of a class?

3)
- NotImplementedException
This now implements Nestable, with a lot of extra methods. None of the
other
exception classes in the main package have been changed. We should
revert
this change, or find a lighter weight solution that works with
ExceptionUtils.

4)
- Validate.allElementsOfClass
Should rename to allElementsOfType, and use instanceof style check, not
class equals style check

Still TODO:
5)
- WordUtils
Capitalize with separator methods need to define null handling for
delimiter
list, and better javadoc for two of the three methods

6)
- time.DurationFormatUtils (complete?)
7)
- time.StopWatch (complete?)
8)
- text subpackage (not in 2.1)
---------

I think we were all agreed on 8. 6+7 I'm open to ideas on
improvements, I think they were complete but need to look again to
convince myself.

3, 4 and 5 all look to be quite agreeable and so just need to be done.

1 and 2 look to be "justify thy existence" questions to the relevant
features. So we need to decide whether we think they should go or not.

1 seems to be a classic "it's semantically better" argument, whereas 2
seems to be a "it's not generic enough". Usually we keep code with
semantically better arguments and drop not-generic enough code I
think, so 1 would stay and 2 would be rm'd. I'm not tied to either
though, so ymmv.

I've clovered and uploaded to: 
http://www.apache.org/~bayard/commons-lang-2.1/clover/

Thoughts?

Hen

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [lang] 2.1...

Posted by Stephen Colebourne <sc...@btopenworld.com>.
From: "Henri Yandell" <fl...@gmail.com>
>> > > > Still TODO:
>> > > > - WordUtils
>> Unsure exactly what was wanted with this.
>> 
>> The null handling seems to be there. I modified the javadoc a bit to
>> hopefully make understanding it easier. Although it's technically
>> correct to say that in the capitalzed word 'Home', the 'o' is in the
>> capitalized form, I suspect that most users will get confused thinking
>> that capitalization means titlecase.
> 
> Assuming this is good.

Seems OK now

Stephen


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [lang] 2.1...

Posted by Henri Yandell <fl...@gmail.com>.
On Tue, 1 Feb 2005 23:50:56 -0500, Henri Yandell <fl...@gmail.com> wrote:
> > On Wed, 26 Jan 2005 00:14:24 -0000, Stephen Colebourne
> > <sc...@btopenworld.com> wrote:
> > > Checking my mail history
> > >
> > > > Still TODO:
> > > > 5)
> > > > - WordUtils
> > > > Capitalize with separator methods need to define null handling for
> > > > delimiter
> > > > list, and better javadoc for two of the three methods
> 
> Unsure exactly what was wanted with this.
> 
> The null handling seems to be there. I modified the javadoc a bit to
> hopefully make understanding it easier. Although it's technically
> correct to say that in the capitalzed word 'Home', the 'o' is in the
> capitalized form, I suspect that most users will get confused thinking
> that capitalization means titlecase.

Assuming this is good.

> I'll wait to hear Stephen's reply to my latest ClassUtils.forName
> comment as I think it's a worthwhile method and it's very easy to test
> it completely so risk should be low. 

Code pulled back out. Wouldn't be a release without me trying to add a
new thing at the last minute I suspect :) I have deja vu to the last
couple of releases.

> Once we get that squared away
> I'll go ahead and create an informal 2.1-rc1 for us to look at and
> vote over, with clover/jdiff/javadoc etc.

I'll do this over the next few days. It's neck and neck with more work
on the Jakarta download pages for my attention at the moment.

Hen

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [lang] 2.1...

Posted by Henri Yandell <fl...@gmail.com>.
> On Wed, 26 Jan 2005 00:14:24 -0000, Stephen Colebourne
> <sc...@btopenworld.com> wrote:
> > Checking my mail history
> >
> > > Still TODO:
> > > 5)
> > > - WordUtils
> > > Capitalize with separator methods need to define null handling for
> > > delimiter
> > > list, and better javadoc for two of the three methods

Unsure exactly what was wanted with this.

The null handling seems to be there. I modified the javadoc a bit to
hopefully make understanding it easier. Although it's technically
correct to say that in the capitalzed word 'Home', the 'o' is in the
capitalized form, I suspect that most users will get confused thinking
that capitalization means titlecase.

Apart from the method I added to ClassUtils that'll need removing if I
can't justify it, and whatever needs to happen to the javadoc above,
we seem to be ready for 2.1.

I'll wait to hear Stephen's reply to my latest ClassUtils.forName
comment as I think it's a worthwhile method and it's very easy to test
it completely so risk should be low. Once we get that squared away
I'll go ahead and create an informal 2.1-rc1 for us to look at and
vote over, with clover/jdiff/javadoc etc.

Hen

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [lang] 2.1...

Posted by Henri Yandell <fl...@gmail.com>.
I've been filling out some tests/overloads in ArrayUtils when I've
found time. Need to commit my latest.

I think we should wait until after the svn change, sounds like it'll
happen pretty soon.

I'm happy to volunteer to do the release management.

Who wants to handle the WordUtils changes?

Hen

On Wed, 26 Jan 2005 00:14:24 -0000, Stephen Colebourne
<sc...@btopenworld.com> wrote:
> Checking my mail history
> 
> > Still TODO:
> > 5)
> > - WordUtils
> > Capitalize with separator methods need to define null handling for
> > delimiter
> > list, and better javadoc for two of the three methods
> 
> And thats it, besides finding a volunteer to do the release (before a svn
> change?)
> 
> Stephen
> 
> 
> ----- Original Message -----
> From: "Gary Gregory" <gg...@seagullsoftware.com>
> Hello All:
> 
> I just noticed it's been about a month since the last 2.1 ponderings.
> Where do we stand now?
> 
> Curious,
> Gary
> 
> -----Original Message-----
> From: Henri Yandell [mailto:flamefew@gmail.com]
> Sent: Friday, December 17, 2004 7:22 PM
> To: Jakarta Commons Developers List
> Subject: [lang] 2.1...
> 
> Sorry for the silence from me. As I've probably said a million times,
> baby happened.
> 
> I'm full of coding energy, or perhaps the need to 'have coded' that
> leads to coding happening and looking to direct some of it to Lang
> 2.1.
> 
> Looking at the wiki and bugzilla, we were nearly there as far as I
> recall. Not a lot has cropped up in the 2 months or so that have
> passed, couple of bugs I've easily closed out and a couple of trickier
> ones.
> 
> Gary seems to have taken care of
> http://issues.apache.org/bugzilla/show_bug.cgi?id=32625. Is it ready
> for closure Gary? Despite Matt Blum's comment on a work-around, it
> still sounds like a fine change to the library.
> 
> The only other new bug is a note on incorrect javadoc and should be an
> easy one: http://issues.apache.org/bugzilla/show_bug.cgi?id=32619.
> 
> Stephen listed the following as smelling:
> 
> -------
> 1)
> - ArrayUtils.lastIndex()
> Gets the last valid index of an array. Surely users would just call
> getLength() - 1?
> 
> 2)
> - ClassUtils.CLASS_NAME_COMPARATOR
> - ClassUtils.PACKAGE_NAME_COMPARATOR
> Although potentially useful, they seem quite specific. What about
> comparing
> packages using Class objects? (I've never used a Package object in my
> work)
> Or comparing just the short name of a class?
> 
> 3)
> - NotImplementedException
> This now implements Nestable, with a lot of extra methods. None of the
> other
> exception classes in the main package have been changed. We should
> revert
> this change, or find a lighter weight solution that works with
> ExceptionUtils.
> 
> 4)
> - Validate.allElementsOfClass
> Should rename to allElementsOfType, and use instanceof style check, not
> class equals style check
> 
> Still TODO:
> 5)
> - WordUtils
> Capitalize with separator methods need to define null handling for
> delimiter
> list, and better javadoc for two of the three methods
> 
> 6)
> - time.DurationFormatUtils (complete?)
> 7)
> - time.StopWatch (complete?)
> 8)
> - text subpackage (not in 2.1)
> ---------
> 
> I think we were all agreed on 8. 6+7 I'm open to ideas on
> improvements, I think they were complete but need to look again to
> convince myself.
> 
> 3, 4 and 5 all look to be quite agreeable and so just need to be done.
> 
> 1 and 2 look to be "justify thy existence" questions to the relevant
> features. So we need to decide whether we think they should go or not.
> 
> 1 seems to be a classic "it's semantically better" argument, whereas 2
> seems to be a "it's not generic enough". Usually we keep code with
> semantically better arguments and drop not-generic enough code I
> think, so 1 would stay and 2 would be rm'd. I'm not tied to either
> though, so ymmv.
> 
> I've clovered and uploaded to:
> http://www.apache.org/~bayard/commons-lang-2.1/clover/
> 
> Thoughts?
> 
> Hen
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-dev-help@jakarta.apache.org
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


Re: [lang] 2.1...

Posted by Stephen Colebourne <sc...@btopenworld.com>.
Checking my mail history

> Still TODO:
> 5)
> - WordUtils
> Capitalize with separator methods need to define null handling for
> delimiter
> list, and better javadoc for two of the three methods

And thats it, besides finding a volunteer to do the release (before a svn 
change?)

Stephen


----- Original Message ----- 
From: "Gary Gregory" <gg...@seagullsoftware.com>
Hello All:

I just noticed it's been about a month since the last 2.1 ponderings.
Where do we stand now?

Curious,
Gary

-----Original Message-----
From: Henri Yandell [mailto:flamefew@gmail.com]
Sent: Friday, December 17, 2004 7:22 PM
To: Jakarta Commons Developers List
Subject: [lang] 2.1...

Sorry for the silence from me. As I've probably said a million times,
baby happened.

I'm full of coding energy, or perhaps the need to 'have coded' that
leads to coding happening and looking to direct some of it to Lang
2.1.

Looking at the wiki and bugzilla, we were nearly there as far as I
recall. Not a lot has cropped up in the 2 months or so that have
passed, couple of bugs I've easily closed out and a couple of trickier
ones.

Gary seems to have taken care of
http://issues.apache.org/bugzilla/show_bug.cgi?id=32625. Is it ready
for closure Gary? Despite Matt Blum's comment on a work-around, it
still sounds like a fine change to the library.

The only other new bug is a note on incorrect javadoc and should be an
easy one: http://issues.apache.org/bugzilla/show_bug.cgi?id=32619.

Stephen listed the following as smelling:

-------
1)
- ArrayUtils.lastIndex()
Gets the last valid index of an array. Surely users would just call
getLength() - 1?

2)
- ClassUtils.CLASS_NAME_COMPARATOR
- ClassUtils.PACKAGE_NAME_COMPARATOR
Although potentially useful, they seem quite specific. What about
comparing
packages using Class objects? (I've never used a Package object in my
work)
Or comparing just the short name of a class?

3)
- NotImplementedException
This now implements Nestable, with a lot of extra methods. None of the
other
exception classes in the main package have been changed. We should
revert
this change, or find a lighter weight solution that works with
ExceptionUtils.

4)
- Validate.allElementsOfClass
Should rename to allElementsOfType, and use instanceof style check, not
class equals style check

Still TODO:
5)
- WordUtils
Capitalize with separator methods need to define null handling for
delimiter
list, and better javadoc for two of the three methods

6)
- time.DurationFormatUtils (complete?)
7)
- time.StopWatch (complete?)
8)
- text subpackage (not in 2.1)
---------

I think we were all agreed on 8. 6+7 I'm open to ideas on
improvements, I think they were complete but need to look again to
convince myself.

3, 4 and 5 all look to be quite agreeable and so just need to be done.

1 and 2 look to be "justify thy existence" questions to the relevant
features. So we need to decide whether we think they should go or not.

1 seems to be a classic "it's semantically better" argument, whereas 2
seems to be a "it's not generic enough". Usually we keep code with
semantically better arguments and drop not-generic enough code I
think, so 1 would stay and 2 would be rm'd. I'm not tied to either
though, so ymmv.

I've clovered and uploaded to:
http://www.apache.org/~bayard/commons-lang-2.1/clover/

Thoughts?

Hen

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: commons-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-dev-help@jakarta.apache.org