You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Szilard Nemeth (JIRA)" <ji...@apache.org> on 2018/11/13 14:16:00 UTC

[jira] [Comment Edited] (YARN-9008) Extend YARN distributed shell with file localization feature

    [ https://issues.apache.org/jira/browse/YARN-9008?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16685266#comment-16685266 ] 

Szilard Nemeth edited comment on YARN-9008 at 11/13/18 2:15 PM:
----------------------------------------------------------------

Thanks [~pbacsko] for uploading this patch!

 

In {{AppMaster.java}}: 
 1. The code block where you iterate over {{localizableFiles}}: 
 I would call {{suffix}} differently, for example: filePath, or something like that.

2. Also in the same added code block, I don't get why the variable {{scFileStatus}} is named like that. What is *sc* in this context? Can you please change it to a more descriptive name?

In Client.java:

1. Nit: Remove the additional blank commented line between the two sentences in the comments above: 
 \{{StringBuilder localizableFiles = new StringBuilder();}}
 2. In {{uploadFile}}: I would call suffix differently, as indicated above.

Testing: 
 In {{Client.java}}, you added a code block that iterates over the localizable files and uploads them.
 Can you somehow test if this code works correctly? I mean some test that runs the client and checks if uploadFile invokes {{FileSystem}} with the correct arguments?

Thanks!


was (Author: snemeth):
Thanks [~pbacsko] for uploading this patch!

 


In {{AppMaster.java}}: 
1. The code block where you iterate over {{localizableFiles}}: 
I would call \{{suffix}} differently, for example: filePath, or something like that.

2. Also in the same added code block, I don't get why the variable \{{scFileStatus}} is named like that. What is *sc* in this context? Can you please change it to a more descriptive name?

In Client.java:

1. Nit: Remove the additional blank commented line between the two sentences in the comments above: 
{\{ StringBuilder localizableFiles = new StringBuilder(); }}
2. In {{uploadFile}}: I would call suffix differently, as indicated above.


Testing: 
In {{Client.java}}, you added a code block that iterates over the localizable files and uploads them.
Can you somehow test if this code works correctly? I mean some test that runs the client and checks if uploadFile invokes \{{FileSystem}} with the correct arguments?

Thanks!

> Extend YARN distributed shell with file localization feature
> ------------------------------------------------------------
>
>                 Key: YARN-9008
>                 URL: https://issues.apache.org/jira/browse/YARN-9008
>             Project: Hadoop YARN
>          Issue Type: Improvement
>          Components: yarn
>    Affects Versions: 2.9.1, 3.1.1
>            Reporter: Peter Bacsko
>            Assignee: Peter Bacsko
>            Priority: Major
>         Attachments: YARN-9008-001.patch, YARN-9008-002.patch, YARN-9008-003.patch
>
>
> YARN distributed shell is a very handy tool to test various features of YARN.
> However, it lacks support for file localization - that is, you define files in the command line that you wish to be localized remotely. This can be extremely useful in certain scenarios.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org