You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Alexandre Rafalovitch (JIRA)" <ji...@apache.org> on 2016/11/06 03:49:59 UTC

[jira] [Commented] (SOLR-9572) config API to show expanded useParams for request handlers inline

    [ https://issues.apache.org/jira/browse/SOLR-9572?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15641064#comment-15641064 ] 

Alexandre Rafalovitch commented on SOLR-9572:
---------------------------------------------

The \_effectiveParameters_ parameter name is quite misleading, as it still does not seem to incorporate the parameters that are defined in initParams sections (as per SOLR-6960).

> config API to show expanded useParams for request handlers inline
> -----------------------------------------------------------------
>
>                 Key: SOLR-9572
>                 URL: https://issues.apache.org/jira/browse/SOLR-9572
>             Project: Solr
>          Issue Type: Sub-task
>      Security Level: Public(Default Security Level. Issues are Public) 
>            Reporter: Noble Paul
>            Assignee: Noble Paul
>             Fix For: 6.3, master (7.0)
>
>         Attachments: SOLR-9572.patch, SOLR-9572.patch
>
>
> sample request
> {{http://localhost:8983/solr/gettingstarted/config/requestHandler?expandParams=true&componentName=/browse}}
> The new parameter is expandParams and it expands all the params and will show all the params expanded individually and cumulative
> response:
> {code:JavaScript}
> {
>    "config":{"requestHandler":{"/browse":{
>         "name":"/browse",
>         "class":"solr.SearchHandler",
>         "useParams":"query,facets,velocity,browse",
>         "defaults":{"echoParams":"explicit"},
>         "_useParamsExpanded_":{
>           "query":{
>             "defType":"edismax",
>             "q.alt":"*:*",
>             "rows":"10",
>             "fl":"*,score",
>             "":{"v":0}},
>           "facets":{
>             "facet":"on",
>             "facet.mincount":"1",
>             "":{"v":0}},
>           "velocity":{
>             "wt":"velocity",
>             "v.template":"browse",
>             "v.layout":"layout",
>             "":{"v":0}},
>           "browse":"[NOT AVAILABLE]"},
>         "_effectiveParams_":{
>           "q.alt":"*:*",
>           "indent":"true",
>           "echoParams":"explicit",
>           "v.layout":"layout",
>           "fl":"*,score",
>           "rows":"10",
>           "v.template":"browse",
>           "defType":"edismax",
>           "facet.mincount":"1",
>           "wt":"json",
>           "facet":"on"}}}}}
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org